summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-03-18 17:45:46 +0100
committerNarrat2018-03-18 17:48:48 +0100
commita00981d4c8382554e35d0e32b54d79c27753f79f (patch)
tree420a4cb4ead9d13b4213ff79003755cf4d73f462
parent8c6997583b4ddf2ce50af641f5c3caaf25f9169b (diff)
downloadaur-a00981d4c8382554e35d0e32b54d79c27753f79f.tar.gz
xdg-utils-mimeo: Add lxqt patch
May there be the case if someone switches between mimeo and lxqt.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--lxqt.patch54
3 files changed, 68 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 113df04d30ec..6569ad095c7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = xdg-utils-mimeo
pkgdesc = Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
pkgver = 1.1.2
- pkgrel = 1
- url = https://wiki.freedesktop.org/www/Software/xdg-utils/
+ pkgrel = 2
+ url = https://www.freedesktop.org/wiki/Software/xdg-utils/
arch = any
license = MIT
makedepends = docbook-xsl
@@ -22,9 +22,11 @@ pkgbase = xdg-utils-mimeo
provides = xdg-utils
conflicts = xdg-utils
source = https://portland.freedesktop.org/download/xdg-utils-1.1.2.tar.gz
+ source = lxqt.patch
source = mimeo-detection.patch
- md5sums = 361e75eb76c94d19f6f4f330d8ee626b
- md5sums = 81b8920bf164863ddeb6ac999cd0d046
+ sha1sums = 20cd4cc5cfaa904b12abf6d584deb568367f4d83
+ sha1sums = a8b5435d4ee217512a455d099344bdc2dc80da94
+ sha1sums = 47f7127d594427006fcee51a5da90f135269859b
pkgname = xdg-utils-mimeo
diff --git a/PKGBUILD b/PKGBUILD
index cbfb3c2b89ec..9c511cf8264d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
_pkgname=xdg-utils
pkgname=$_pkgname-mimeo
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo"
arch=('any')
-url="https://wiki.freedesktop.org/www/Software/xdg-utils/"
+url="https://www.freedesktop.org/wiki/Software/xdg-utils/"
license=('MIT')
depends=('sh' 'xorg-xset') # xset needed inside xdg-screensaver
makedepends=('docbook-xsl' 'lynx' 'xmlto' 'git')
@@ -24,15 +24,18 @@ optdepends=('kde-cli-tools: for KDE Plasma5 support in xdg-open'
provides=($_pkgname)
conflicts=($_pkgname)
source=(https://portland.freedesktop.org/download/$_pkgname-$pkgver.tar.gz #{,.asc}
+ lxqt.patch
mimeo-detection.patch)
-md5sums=('361e75eb76c94d19f6f4f330d8ee626b'
- '81b8920bf164863ddeb6ac999cd0d046')
+sha1sums=('20cd4cc5cfaa904b12abf6d584deb568367f4d83'
+ 'a8b5435d4ee217512a455d099344bdc2dc80da94'
+ '47f7127d594427006fcee51a5da90f135269859b')
#validpgpkeys=('8B75CA7811367175D05F3B03C43570F80CC295E6') # "Per Olofsson <pelle@pqz.se>"
prepare() {
cd $_pkgname-$pkgver
-
+ # lxde and lxqt are different
+ patch -Np1 -i ../lxqt.patch
patch -p1 -i "${srcdir}"/mimeo-detection.patch
}
diff --git a/lxqt.patch b/lxqt.patch
new file mode 100644
index 000000000000..35a97616d468
--- /dev/null
+++ b/lxqt.patch
@@ -0,0 +1,54 @@
+From 7d4360c64d94de53d907f13ca99837285e972ec6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Lu=C3=ADs=20Pereira?= <luis.artur.pereira@gmail.com>
+Date: Wed, 17 May 2017 14:33:30 +0100
+Subject: xdg-open: Fixes LXQt behavior
+
+Commit 6387086e4938d568c2bab185632f60e1619b3f68 introduced LXQt support.
+In xdg-open it assumed that LXQt and LXDE are the same. They aren't. LXQt
+does not have pcmanfm, it has pcmanfm-qt.
+LXQt doesn't want to rely on pcmamfm-qt to handle it: LXQt is very modular
+and can be deployed without pcmanfm-qt.
+
+open_generic() works for LXQt but it depends on mimeopen and mimetype. In
+the future we will want, for sure, to drop those dependencies. That's the
+reason for the existence of open_lxqt().
+---
+ scripts/xdg-open.in | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/scripts/xdg-open.in b/scripts/xdg-open.in
+index 9817c5f..2972257 100644
+--- a/scripts/xdg-open.in
++++ b/scripts/xdg-open.in
+@@ -447,6 +447,11 @@ open_lxde()
+ fi
+ }
+
++open_lxqt()
++{
++ open_generic "$1"
++}
++
+ [ x"$1" != x"" ] || exit_failure_syntax
+
+ url=
+@@ -511,10 +516,14 @@ case "$DE" in
+ open_xfce "$url"
+ ;;
+
+- lxde|lxqt)
++ lxde)
+ open_lxde "$url"
+ ;;
+
++ lxqt)
++ open_lxqt "$url"
++ ;;
++
+ enlightenment)
+ open_enlightenment "$url"
+ ;;
+--
+cgit v1.1
+
+