summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-07-25 18:50:14 +0200
committerNarrat2015-07-25 18:50:14 +0200
commitc6788fda848613bae15e648934e45d95392e095a (patch)
tree96b33f4c7500107f8c35c785c7f58b8656d68562
parentb5b5fc46177945ecab7228848e11214b28eae34a (diff)
downloadaur-c6788fda848613bae15e648934e45d95392e095a.tar.gz
Update xdg-utils to 20150715
They made changes, which made it necessary to adjust the mimeo detection patch. Mostly line number adjustments. Exception is xdg-settings.in They switched from the $DE to $handler, so mimeo needed to added as extra case. Additionally I added {get,check,set}_url_scheme_handler_mimeo but it is handled like the ones from xfce (Dunno if it can be supported)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--mimeo-detection.diff53
3 files changed, 46 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b36374f2034..3c276104201e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xdg-utils-mimeo
pkgdesc = Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
- pkgver = 1.1.0.git20150323
+ pkgver = 1.1.0.git20150715
pkgrel = 1
url = http://cgit.freedesktop.org/xdg/xdg-utils/
arch = any
@@ -21,10 +21,10 @@ pkgbase = xdg-utils-mimeo
optdepends = perl-file-mimeinfo: for generic support in xdg-open
provides = xdg-utils
conflicts = xdg-utils
- source = git://anongit.freedesktop.org/xdg/xdg-utils#commit=686f6f48f6ff939c757881e3fc7a852b61d32c94
+ source = git://anongit.freedesktop.org/xdg/xdg-utils#commit=3c499bd6d88c9d2b4f824f1e2f9c9158a5b95aa6
source = mimeo-detection.diff
md5sums = SKIP
- md5sums = 5f38d0201009df739bb70452f2a3f5b4
+ md5sums = 8693c0986515de30872f0ff054539eaf
pkgname = xdg-utils-mimeo
diff --git a/PKGBUILD b/PKGBUILD
index bbf78e8c0404..00df01a7ffd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: cantabile <cantabile dot desu at gmail dot com>
pkgname=xdg-utils-mimeo
-pkgver=1.1.0.git20150323
+pkgver=1.1.0.git20150715
pkgrel=1
pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo"
arch=('any')
@@ -22,10 +22,10 @@ optdepends=('kdebase-runtime: for KDE4 support in xdg-open'
'perl-file-mimeinfo: for generic support in xdg-open')
provides=('xdg-utils')
conflicts=('xdg-utils')
-source=(git://anongit.freedesktop.org/xdg/xdg-utils#commit=686f6f48f6ff939c757881e3fc7a852b61d32c94
+source=(git://anongit.freedesktop.org/xdg/xdg-utils#commit=3c499bd6d88c9d2b4f824f1e2f9c9158a5b95aa6
mimeo-detection.diff)
md5sums=('SKIP'
- '5f38d0201009df739bb70452f2a3f5b4')
+ '8693c0986515de30872f0ff054539eaf')
pkgver() {
diff --git a/mimeo-detection.diff b/mimeo-detection.diff
index 208d4bc74aac..b67e34cf27e9 100644
--- a/mimeo-detection.diff
+++ b/mimeo-detection.diff
@@ -1,6 +1,6 @@
--- xdg-utils/scripts/xdg-utils-common.in
+++ xdg-utils/scripts/xdg-utils-common.in
-@@ -286,6 +286,7 @@
+@@ -291,6 +291,7 @@
elif xprop -root _DT_SAVE_MODE 2> /dev/null | grep ' = \"xfce4\"$' >/dev/null 2>&1; then DE=xfce;
elif xprop -root 2> /dev/null | grep -i '^xfce_desktop_window' >/dev/null 2>&1; then DE=xfce
elif echo $DESKTOP | grep -q '^Enlightenment'; then DE=enlightenment;
@@ -11,7 +11,7 @@
--- xdg-utils/scripts/xdg-open.in
+++ xdg-utils/scripts/xdg-open.in
-@@ -147,6 +147,17 @@
+@@ -158,6 +158,17 @@
{
enlightenment_open "$1"
@@ -29,8 +29,8 @@
if [ $? -eq 0 ]; then
exit_success
else
-@@ -420,6 +431,10 @@
- open_enlightenment "$url"
+@@ -440,6 +451,10 @@
+ open_darwin "$url"
;;
+ mimeo)
@@ -62,7 +62,7 @@
if [ $? -eq 0 ]; then
exit_success
-@@ -409,6 +421,10 @@
+@@ -424,6 +436,10 @@
open_xfce "${mailto}"
;;
@@ -70,7 +70,7 @@
+ open_mimeo "${mailto}"
+ ;;
+
- generic|lxde)
+ generic)
open_generic "${mailto}"
;;
@@ -93,7 +93,7 @@
if [ $? -eq 0 ]; then
exit_success
else
-@@ -565,6 +575,10 @@
+@@ -570,6 +580,10 @@
info_gnome "$filename"
;;
@@ -150,12 +150,39 @@
# }}} default browser
# {{{ default url scheme handler
-@@ -754,7 +790,7 @@
- detectDE
+@@ -624,6 +660,24 @@
+ }
- case "$DE" in
-- kde|gnome*|xfce)
-+ kde|gnome*|xfce|mimeo)
- dispatch_specific "$@"
+ set_url_scheme_handler_xfce()
++{
++ exit_unimplemented_default_handler "$1"
++}
++
++# }}} xfce
++# {{{ mimeo
++
++get_url_scheme_handler_mimeo()
++{
++ exit_unimplemented_default_handler "$1"
++}
++
++check_url_scheme_handler_mimeo()
++{
++ exit_unimplemented_default_handler "$1"
++}
++
++set_url_scheme_handler_mimeo()
+ {
+ exit_unimplemented_default_handler "$1"
+ }
+@@ -771,6 +825,10 @@
+ dispatch_specific xfce "$@"
;;
++ mimeo)
++ dispatch_specific mimeo "$@"
++ ;;
++
+ generic)
+ dispatch_generic "$@"
+ ;;