summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrIng2015-12-09 12:43:51 +0100
committerCyrIng2015-12-09 12:43:51 +0100
commit6fec56df14a2a94b020d01e584079a273066be32 (patch)
treea6de8c366db92ea5d7855d0c45c3b03972e77e99
parentcb9bcf60228240dc18d795ed36e8c98361875070 (diff)
downloadaur-6fec56df14a2a94b020d01e584079a273066be32.tar.gz
[CTRL] + [Button3] pressed on window title close the selected window.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--twm-xfreq.rc9
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ded26e9e257..8e149acb95f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = xdm-xfreq
pkgdesc = A customized XDM for XFreq
- pkgver = 0.8
- pkgrel = 3
+ pkgver = 0.9
+ pkgrel = 1
url = http://github.com/cyring/xdm-xfreq
install = xdm-xfreq.install
arch = any
license = GPL
+ depends = xfreq-git
depends = xorg-xdm
depends = xorg-xclock
depends = xorg-xmessage
depends = xorg-xdpyinfo
depends = gawk
- optdepends = xfreq-git
optdepends = scrot
optdepends = imagemagick
optdepends = xorg-xsetroot
diff --git a/PKGBUILD b/PKGBUILD
index d391354f802c..89a50b0b5157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: CyrIng <xfreq[at]cyring[dot]fr>
# Contributor: CyrIng <xfreq[at]cyring[dot]fr>
pkgname=xdm-xfreq
-pkgver=0.8
-pkgrel=3
+pkgver=0.9
+pkgrel=1
pkgdesc="A customized XDM for XFreq"
arch=(any)
license=('GPL')
url="http://github.com/cyring/xdm-xfreq"
-depends=('xorg-xdm' 'xorg-xclock' 'xorg-xmessage' 'xorg-xdpyinfo' 'gawk')
-optdepends=('xfreq-git' 'scrot' 'imagemagick' 'xorg-xsetroot' 'xorg-twm' 'numlockx' 'xdg-utils')
+depends=('xfreq-git' 'xorg-xdm' 'xorg-xclock' 'xorg-xmessage' 'xorg-xdpyinfo' 'gawk')
+optdepends=('scrot' 'imagemagick' 'xorg-xsetroot' 'xorg-twm' 'numlockx' 'xdg-utils')
backup=(etc/xdm-xfreq/Xresources
etc/xdm-xfreq/xdm-xfreq.rc
etc/xdm-xfreq/xdm-config
diff --git a/twm-xfreq.rc b/twm-xfreq.rc
index 76edd9c15dc8..d697bd821b04 100644
--- a/twm-xfreq.rc
+++ b/twm-xfreq.rc
@@ -36,7 +36,7 @@ Color
BorderColor "chocolate"
{
# "Clock" "#dfdfdf"
- "PopUp" "#2a0308"
+# "PopUp" "#2a0308"
"TWM Icon Manager" "#2a0308"
}
BorderTileBackground "#2a0308"
@@ -88,6 +88,7 @@ Button3 = m : window|icon : f.function "move-or-raise"
Button1 = : title : f.function "move-or-raise"
Button2 = : title : f.raiselower
+Button3 = c : title : f.delete
Button1 = : icon : f.function "move-or-iconify"
Button2 = : icon : f.iconify
@@ -133,9 +134,9 @@ menu "sysops"
"Hibernate" f.exec "systemctl hibernate"
"Hybrid-sleep" f.exec "systemctl hybrid-sleep"
"" f.nop
-"Rescue" f.exec "(xmessage -buttons Rescue:11,Cancel:99 -default Cancel -timeout 30 -fg '#dfdfdf' -bg '#2a0308' -bd chocolate -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp 'Enter rescue mode ?';if [[ $? == 11 ]]; then systemctl rescue; fi) &"
-"Reboot" f.exec "(xmessage -buttons Reboot:11,Cancel:99 -default Cancel -timeout 30 -fg '#dfdfdf' -bg '#2a0308' -bd chocolate -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp 'Shut down and reboot the system ?';if [[ $? == 11 ]]; then systemctl reboot; fi) &"
-"PowerOff" f.exec "(xmessage -buttons PowerOff:11,Cancel:99 -default Cancel -timeout 30 -fg '#dfdfdf' -bg '#2a0308' -bd chocolate -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp 'Shut down and power-off the system ?';if [[ $? == 11 ]]; then systemctl poweroff; fi) &"
+"Rescue" f.exec "(xmessage -buttons Rescue:11,Cancel:99 -default Cancel -timeout 30 -fg '#dfdfdf' -bg '#2a0308' -bd '#dfdfdf' -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp 'Enter rescue mode ?';if [[ $? == 11 ]]; then systemctl rescue; fi) &"
+"Reboot" f.exec "(xmessage -buttons Reboot:11,Cancel:99 -default Cancel -timeout 30 -fg '#dfdfdf' -bg '#2a0308' -bd '#dfdfdf' -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp 'Shut down and reboot the system ?';if [[ $? == 11 ]]; then systemctl reboot; fi) &"
+"PowerOff" f.exec "(xmessage -buttons PowerOff:11,Cancel:99 -default Cancel -timeout 30 -fg '#dfdfdf' -bg '#2a0308' -bd '#dfdfdf' -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp 'Shut down and power-off the system ?';if [[ $? == 11 ]]; then systemctl poweroff; fi) &"
"" f.nop
}