summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrIng2015-12-10 21:14:00 +0100
committerCyrIng2015-12-10 21:14:00 +0100
commitca8c02f529b926c2fb9df92e4ab949da25a6155a (patch)
tree1554ca89a44777c0d97d89bdd63a22c81541f1ad
parente015ee4702bfa7b76d3e8f2c3d577473801e8c55 (diff)
downloadaur-ca8c02f529b926c2fb9df92e4ab949da25a6155a.tar.gz
Autoraise Windows. Notifications.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xXsetup2
-rw-r--r--twm-xfreq.rc20
-rwxr-xr-xxdm-xfreq.rc5
5 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52389d1f4943..1217167728b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xdm-xfreq
pkgdesc = A customized XDM for XFreq
- pkgver = 0.10
+ pkgver = 0.11
pkgrel = 1
url = http://github.com/cyring/xdm-xfreq
install = xdm-xfreq.install
diff --git a/PKGBUILD b/PKGBUILD
index e233a3e6648d..6541e7c07728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: CyrIng <xfreq[at]cyring[dot]fr>
# Contributor: CyrIng <xfreq[at]cyring[dot]fr>
pkgname=xdm-xfreq
-pkgver=0.10
+pkgver=0.11
pkgrel=1
pkgdesc="A customized XDM for XFreq"
arch=(any)
diff --git a/Xsetup b/Xsetup
index 6294715c10da..1a07aed9b5ad 100755
--- a/Xsetup
+++ b/Xsetup
@@ -40,7 +40,7 @@ if [[ -v XDM_XFREQ_BUTTONS_PATH ]]; then
case $RC in
11)
if [[ -v XDM_XFREQ_SCREENSHOT_PATH ]]; then
- $XDM_XFREQ_SCREENSHOT_PATH $XDM_XFREQ_SCREENSHOT_ARGS &
+ $XDM_XFREQ_SCREENSHOT_PATH $XDM_XFREQ_SCREENSHOT_ARGS -e "$XDM_XFREQ_NOTIFY_PATH $XDM_XFREQ_NOTIFY_ARGS '' \$f" &
fi
;;
20|21|22|23|24|25)
diff --git a/twm-xfreq.rc b/twm-xfreq.rc
index 48589a6cfda4..5b3a50694daf 100644
--- a/twm-xfreq.rc
+++ b/twm-xfreq.rc
@@ -1,4 +1,5 @@
#
+AutoRaise { "TWM Icon Manager" "Clock" "PopUp" "Terminal" "Print" "Dialog" "Navigator" "Mail" "Msgcompose" "XFreq-Gui" "chromium" "filezilla" "vlc" "skype" }
BorderWidth 1
ButtonIndent 2
# ClientBorderWidth
@@ -69,7 +70,14 @@ Function "move-or-iconify" { f.move f.deltastop f.iconify }
Function "raise-and-focus" { f.raise f.focus }
Function "raise-and-move" { f.raise f.move }
Function "raise-and-resize" { f.raise f.resize }
-Function "run-app" { f.exec "dmenu_run -b -nb '#2a0308' -nf white -sb chocolate" }
+Function "run-app"
+{
+ f.exec "dmenu_run -b -nb '#2a0308' -nf white -sb chocolate"
+}
+Function "screenshot-root"
+{
+ f.exec "scrot --silent --delay 1 --exec 'xmessage -buttons Close -timeout 15 -fg \"#dfdfdf\" -bg \"#2a0308\" -bd \"#dfdfdf\" -geometry -16-32 -fn -misc-fixed-*-*-*-*-15-*-*-*-*-*-*-* -name PopUp $f &' '/tmp/%Y%m%d-%H%M%S-\$wx\$h.png'"
+}
#
# Mouse buttons bindings.
@@ -96,15 +104,15 @@ Button2 = : icon : f.iconify
Button1 = : iconmgr : f.iconify
Button2 = : iconmgr : f.iconify
-Button1 = : frame : f.function "raise-and-move"
-Button1 = c : frame : f.function "raise-and-resize"
+Button1 = : frame|frame : f.function "raise-and-move"
+Button1 = c : frame|frame : f.function "raise-and-resize"
#
# Keyboard bindings.
#
-"F1" = : all : f.function "run-app"
-"r" = c : all : f.function "run-app"
-"p" = c : all : f.exec "scrot /tmp/%Y%m%d-%H%M%S-\$wx\$h.png"
+"F1" = : root : f.function "run-app"
+"r" = c : root : f.function "run-app"
+"p" = c : root : f.function "screenshot-root"
#
# Menus
diff --git a/xdm-xfreq.rc b/xdm-xfreq.rc
index dae5ddab43fc..0bf5f79009c5 100755
--- a/xdm-xfreq.rc
+++ b/xdm-xfreq.rc
@@ -23,7 +23,7 @@ XDM_XFREQ_CLOCK_PATH=xclock
XDM_XFREQ_CLOCK_ARGS="-geometry 256x32-0-0 -twentyfour"
XDM_XFREQ_CLOCK_PID="/var/run/xdm-xfreq-clock.pid"
-# Buttons settings
+# Buttons and Notify settings
XDM_XFREQ_BUTTONS_PATH=xmessage
XDM_XFREQ_BUTTONS_ARGS="-geometry $(( $WIDTH - 256 ))x32+0-0"
XDM_XFREQ_BUTTONS_PID="/var/run/xdm-xfreq-buttons.pid"
@@ -34,6 +34,9 @@ XDM_XFREQ_BUTTONS_REBOOT="-buttons Reboot?:11,Cancel?:12 -default Cancel? -timeo
XDM_XFREQ_BUTTONS_RESCUE="-buttons Rescue?:11,Cancel?:12 -default Cancel? -timeout 6"
XDM_XFREQ_BUTTONS_SUBMENU="-buttons \<\<:99,Screenshot:11,ScreenSaver=5min:20,ScreenSaver=7min:21,ScreenSaver=10min:22,ScreenSaver=12min:23,ScreenSaver=15min:24,ScreenSaver=20min:25"
+XDM_XFREQ_NOTIFY_PATH=xmessage
+XDM_XFREQ_NOTIFY_ARGS="-geometry +24-64 -timeout 15 -buttons"
+
# Screenshot
XDM_XFREQ_SCREENSHOT_PATH=scrot
XDM_XFREQ_SCREENSHOT_ARGS="-d 6 /tmp/%Y%m%d-%H%M%S-\$wx\$h.png"