summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgamingdoom2021-07-19 20:57:51 -0700
committergamingdoom2021-07-19 20:57:51 -0700
commit84084e99bfd4799a16a2adb328f8326e48e9fb73 (patch)
treefa17659d1438fa95518d65dd8eb0d9f886b28301
downloadaur-84084e99bfd4799a16a2adb328f8326e48e9fb73.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc7f767dec7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = xdotoolhelper-git
+ pkgdesc = A simple shell script to generate xdotool scripts.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/gamingdoom/xdotoolhelper
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = git+https://github.com/gamingdoom/xdotoolhelper.git
+ sha256sums = SKIP
+
+pkgname = xdotoolhelper-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a97a4ea377d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Cat2048 <xdotoolhelper@outlook.com>
+pkgname=xdotoolhelper-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A simple shell script to generate xdotool scripts."
+arch=('any')
+url="https://github.com/gamingdoom/xdotoolhelper"
+license=('GPL3')
+depends=()
+makedepends=('git')
+source=('git+https://github.com/gamingdoom/xdotoolhelper.git')
+noextract=()
+sha256sums=('SKIP')
+
+package() {
+ ls
+ cd "xdotoolhelper"
+ cp -v xdotoolhelper.sh xdotoolhelper
+ chmod 755 xdotoolhelper
+ install -Dt "$pkgdir"/usr/bin xdotoolhelper
+}