summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2016-02-24 23:59:32 +1100
committerJoshua Hardy2016-02-24 23:59:32 +1100
commit49e9c6e18bf2148e58bea448d6506621f6eb7cc7 (patch)
treef6a2fcbda0bdd4853fa96ec57cccde11e9e82827
downloadaur-49e9c6e18bf2148e58bea448d6506621f6eb7cc7.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..288810bab05b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 12:54:46 UTC 2016
+pkgbase = xds
+ pkgdesc = X-ray Detector Software for processing single-crystal monochromatic diffraction data recorded by the rotation method.
+ pkgver = 20160930
+ pkgrel = 1
+ url = http://xds.mpimf-heidelberg.mpg.de/
+ arch = x86_64
+ license = CCPL:cc-by-nc-nd-3.0
+ makedepends = prelink
+ depends = bash
+ optdepends = xdsgui
+ optdepends = xds-viewer
+ optdepends = xdsstat
+ source = ftp://ftp.mpimf-heidelberg.mpg.de/pub/kabsch/XDS-INTEL64_Linux_x86_64.tar.gz
+ md5sums = fe5ccdc8bc7ed1d20abe3166eeb98f93
+
+pkgname = xds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b411339863f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joshua Hardy joshinsilico
+pkgname=xds
+pkgver=20160930
+pkgrel=1
+pkgdesc="X-ray Detector Software for processing single-crystal monochromatic diffraction data recorded by the rotation method."
+arch=(x86_64)
+url="http://xds.mpimf-heidelberg.mpg.de/"
+license=('CCPL:cc-by-nc-nd-3.0')
+depends=('bash')
+makedepends=('prelink')
+optdepends=('xdsgui' 'xds-viewer' 'xdsstat')
+source=("ftp://ftp.mpimf-heidelberg.mpg.de/pub/kabsch/XDS-INTEL64_Linux_x86_64.tar.gz")
+md5sums=('fe5ccdc8bc7ed1d20abe3166eeb98f93')
+build() {
+ cd "${srcdir}"/XDS-INTEL64_Linux_x86_64/
+ execstack -c mintegrate_par
+ execstack -c xds_par
+ execstack -c mcolspot_par
+ execstack -c xscale_par
+}
+package() {
+ install -d "${pkgdir}"/usr "${pkgdir}"/usr/bin
+ install -D -m755 "${srcdir}"/XDS-INTEL64_Linux_x86_64/* "${pkgdir}"/usr/bin/.
+}