summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2023-05-14 06:34:49 +1200
committerVaporeon2023-05-14 06:34:49 +1200
commit37ec597330eb9cfe35199324f7d378ab78f2d316 (patch)
tree4d8bdea8896d59234368953107194bf0168d1030
downloadaur-37ec597330eb9cfe35199324f7d378ab78f2d316.tar.gz
Package xdvdfs
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e19570106b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xdvdfs
+ pkgdesc = A collection of tools for interacting with XDVDFS/XISO images.
+ pkgver = 0.5.0.rc1
+ pkgrel = 1
+ url = https://github.com/antangelo/xdvdfs
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ depends = gcc-libs
+ options = !lto
+ source = xdvdfs-0.5.0-rc1.tar.gz::https://github.com/antangelo/xdvdfs/archive/v0.5.0-rc1.tar.gz
+ sha256sums = a9ba17382086b495a4128c066bc22178963a9ddd4b24230e8e0bb4cbf3e4f9a4
+
+pkgname = xdvdfs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5d6330c95cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=xdvdfs
+pkgver=0.5.0.rc1
+_pkgver=0.5.0-rc1
+pkgrel=1
+pkgdesc="A collection of tools for interacting with XDVDFS/XISO images."
+arch=(x86_64)
+url="https://github.com/antangelo/xdvdfs"
+license=('MIT')
+depends=('gcc-libs')
+options=('!lto')
+makedepends=('rust')
+source=("$pkgname-$_pkgver.tar.gz::https://github.com/antangelo/${pkgname}/archive/v${_pkgver}.tar.gz")
+sha256sums=('a9ba17382086b495a4128c066bc22178963a9ddd4b24230e8e0bb4cbf3e4f9a4')
+
+build() {
+ cd "$pkgname-$_pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$_pkgver"
+
+ install -Dm755 target/release/xdvdfs "$pkgdir/usr/bin/xdvdfs"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}