summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroslik2016-03-13 01:02:22 +0300
committeroslik2016-03-13 01:02:22 +0300
commit52ff49007a5ff07570a3630c2c3a39bfe6df6367 (patch)
tree9ef3dd75cae9d3a96e3eab6c3b1bad615d6204c9
downloadaur-xdxf_makedict-git.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--xdxf_makedict.patch26
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d139a23847fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xdxf_makedict-git
+ pkgdesc = XDXF dictionary format and "makedict" dictionary converting software
+ pkgver = 0.3.1beta1
+ pkgrel = 1
+ url = https://github.com/soshial/xdxf_makedict/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = git://github.com/soshial/xdxf_makedict.git
+ source = xdxf_makedict.patch
+ md5sums = SKIP
+ md5sums = 4999f8084679d8a5fcb95a60439ebe9e
+
+pkgname = xdxf_makedict-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0a2c22363e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: <oslik@dragon>
+pkgname=xdxf_makedict-git
+_srcname=xdxf_makedict
+pkgver=0.3.1beta1
+pkgrel=1
+epoch=
+pkgdesc="XDXF dictionary format and \"makedict\" dictionary converting software"
+arch=('i686' 'x86_64')
+url="https://github.com/soshial/xdxf_makedict/"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git://github.com/soshial/$_srcname.git"
+ "$_srcname.patch")
+noextract=()
+md5sums=('SKIP' "4999f8084679d8a5fcb95a60439ebe9e")
+
+prepare() {
+ cd "$srcdir/$_srcname/src"
+ patch -i "$srcdir/$_srcname.patch"
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "../$_srcname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xdxf_makedict.patch b/xdxf_makedict.patch
new file mode 100644
index 000000000000..7f7a3e3d3cad
--- /dev/null
+++ b/xdxf_makedict.patch
@@ -0,0 +1,26 @@
+--- log.old.cpp 2016-03-13 00:32:24.210852190 +0300
++++ log.cpp 2016-03-13 00:33:04.384183674 +0300
+@@ -68,6 +68,7 @@
+ g_log_set_default_handler(log, this);
+ }
+
++#ifndef g_info
+ void g_info(const gchar *fmt, ...)
+ {
+ va_list va;
+@@ -76,3 +77,4 @@
+ g_logv(G_LOG_DOMAIN, G_LOG_LEVEL_INFO, fmt, va);
+ va_end(va);
+ }
++#endif
+--- log.old.hpp 2016-03-13 00:35:42.544176395 +0300
++++ log.hpp 2016-03-13 00:35:47.154176180 +0300
+@@ -19,6 +19,8 @@
+ gpointer user_data);
+ };
+
++#ifndef g_info
+ extern void g_info(const gchar *fmt, ...);
++#endif
+
+ #endif//!_LOG_HPP_