summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-07-06 19:07:52 +0000
committerAntonio Rojas2017-07-06 19:07:52 +0000
commitd5d0afda8d1351d4d7c905f61324a365b1a46475 (patch)
treebec6fc4fc10e7d10758a91737a56f965c58294bc
downloadaur-d5d0afda8d1351d4d7c905f61324a365b1a46475.tar.gz
Drop from repos
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD76
-rw-r--r--ip_address.patch16
-rw-r--r--proc-xen.mount9
-rw-r--r--tmpfile1
-rw-r--r--xe-daemon.service12
-rw-r--r--xe-linux-distribution.service11
7 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c1cc5d87b53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = xe-guest-utilities
+ pkgdesc = Citrix XenServer Tools
+ pkgver = 6.2.0
+ pkgrel = 2
+ url = http://citrix.com/English/ps2/products/product.asp?contentID=683148&ntref=hp_nav_US
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = python2
+ options = staticlibs
+ source = https://sources.archlinux.org/other/community/xe-guest-utilities/xe-guest-utilities_6.2.0-1120.tar.gz
+ source = ip_address.patch
+ source = xe-linux-distribution.service
+ source = xe-daemon.service
+ source = proc-xen.mount
+ source = tmpfile
+ md5sums = 98644da204b18b695ede0ba45f4df22d
+ md5sums = 9bd39e95384056069f7faa870a28413a
+ md5sums = 95064a7d8a32cd3aaca14e3b48c69599
+ md5sums = 173fed74c76817702b062ed653002db0
+ md5sums = 3252fa21362fd55246f9d8b923070151
+ md5sums = cadad1eb5b1fa6d5fe463a1a0fd82fff
+
+pkgname = xe-guest-utilities
+ depends = xenstore
+ depends = bash
+ depends = lsb-release
+
+pkgname = xenstore
+ depends = bzip2
+ depends = lzo
+ depends = zlib
+ depends = xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e888e6b1d06a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# $Id: PKGBUILD 127137 2015-02-04 23:02:34Z bluewind $
+# Maintainer: Daniel Wallace <danielwallace at code gtmanfred com>
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# Contributor: Krzysztof Raczkowski <raczkow@gnu-tech.pl>
+
+pkgbase=xe-guest-utilities
+pkgname=('xe-guest-utilities' 'xenstore')
+pkgver=6.2.0
+pkgrel=2
+pkgdesc="Citrix XenServer Tools"
+arch=('i686' 'x86_64')
+url="http://citrix.com/English/ps2/products/product.asp?contentID=683148&ntref=hp_nav_US"
+license=('GPL' 'LGPL')
+makedepends=(python2)
+options=(staticlibs)
+source=("https://sources.archlinux.org/other/community/$pkgbase/${pkgbase}_${pkgver}-1120.tar.gz"
+ 'ip_address.patch'
+ 'xe-linux-distribution.service'
+ 'xe-daemon.service'
+ 'proc-xen.mount'
+ 'tmpfile')
+md5sums=('98644da204b18b695ede0ba45f4df22d'
+ '9bd39e95384056069f7faa870a28413a'
+ '95064a7d8a32cd3aaca14e3b48c69599'
+ '173fed74c76817702b062ed653002db0'
+ '3252fa21362fd55246f9d8b923070151'
+ 'cadad1eb5b1fa6d5fe463a1a0fd82fff')
+
+prepare(){
+ patch -d $srcdir/$pkgname-$pkgver -Np1 -i $srcdir/ip_address.patch
+ bsdtar xf "$srcdir/$pkgname-$pkgver/xenstore-sources.tar.bz2"
+}
+
+build() {
+ export CC=gcc
+ CFLAGS='-Wall -Wstrict-prototypes -Wno-unused-local-typedefs -Wno-sizeof-pointer-memaccess'
+ export CFLAGS
+ export PYTHON=python2
+ cd "$srcdir/uclibc-sources"
+ make -C tools/include
+ make -C tools/libxc
+ make -C tools/xenstore
+}
+
+package_xenstore() {
+ depends=(bzip2 lzo zlib xz)
+ export CFLAGS+='-Wall -Wstrict-prototypes -Wno-unused-local-typedefs -Wno-sizeof-pointer-memaccess'
+ if [[ $CARCH == x86_64 ]]; then
+ export LIBLEAFDIR_x86_64=lib
+ fi
+ for f in include libxc xenstore; do
+ [[ ! -d "$srcdir"/uclibc-sources/tools/$f ]] && continue
+ make -C ""$srcdir"/uclibc-sources/tools/$f" DESTDIR="$pkgdir" SBINDIR=/usr/bin install
+ done
+ cd "$srcdir/$pkgbase-$pkgver"
+ install -Dm644 "COPYING.LGPL" "$pkgdir/usr/share/licenses/$pkgname/COPYING.LGPL"
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 $srcdir/proc-xen.mount "$pkgdir/usr/lib/systemd/system/proc-xen.mount"
+ install -Dm644 $srcdir/tmpfile "$pkgdir/usr/lib/tmpfiles.d/30-xenstored.conf"
+ rm -r "$pkgdir"/var
+}
+
+package_xe-guest-utilities(){
+ cd "$srcdir/$pkgname-$pkgver"
+ depends=('xenstore' 'bash' 'lsb-release')
+ install -Dm755 xe-linux-distribution "$pkgdir/usr/bin/xe-linux-distribution"
+ install -Dm755 xe-update-guest-attrs "$pkgdir/usr/bin/xe-update-guest-attrs"
+ install -Dm755 xe-daemon "$pkgdir/usr/bin/xe-daemon"
+ install -Dm644 xen-vcpu-hotplug.rules "$pkgdir/usr/lib/udev/rules.d/10-xen-vcpu-hotplug.rules"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 $srcdir/xe-daemon.service "$pkgdir/usr/lib/systemd/system/xe-daemon.service"
+ install -Dm644 $srcdir/xe-linux-distribution.service "$pkgdir/usr/lib/systemd/system/"
+ sed -i 's:sbin:bin:' $pkgdir/usr/bin/xe-daemon
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ip_address.patch b/ip_address.patch
new file mode 100644
index 000000000000..3142c3d6bdf9
--- /dev/null
+++ b/ip_address.patch
@@ -0,0 +1,16 @@
+diff -uNr a/xe-update-guest-attrs b/xe-update-guest-attrs
+--- a/xe-update-guest-attrs 2012-09-25 12:45:14.000000000 +0200
++++ b/xe-update-guest-attrs 2012-11-21 16:46:35.000000000 +0100
+@@ -177,9 +177,9 @@
+ # collisions:0 txqueuelen:0
+ # RX bytes:3604609 (3.4 MiB) TX bytes:3604609 (3.4 MiB)
+
+-ifs=`/sbin/ifconfig | sed -n -e 's/^\([a-z0-9]\+\).*/name \1/p' \
+- -e 's/.*inet addr:\('$IPADDR_RE'\) .*/ipv4 \1/p' \
+- -e 's+.*inet6 addr: \('$IPADDR6_RE'\)/.*+ipv6 \1+p' | \
++ifs=`ip addr show | sed -n -e 's/^[[:digit:]]*: \([a-z0-9]*\): .*/name \1 /gp;' \
++ -e 's/^[[:space:]]\{4\}inet \('${IPADDR_RE}'\)\/.*/ipv4 \1 /gp;' \
++ -e 's/^[[:space:]]\{4\}inet6 \('${IPADDR6_RE}'\)\/.*/ipv6 \1 /gp;' | \
+ while read tag value; do
+ case "${tag}" in
+ name)
diff --git a/proc-xen.mount b/proc-xen.mount
new file mode 100644
index 000000000000..0eaa59c5fab1
--- /dev/null
+++ b/proc-xen.mount
@@ -0,0 +1,9 @@
+[Unit]
+Description=Mount /proc/xen files
+ConditionPathExists=/proc/xen
+RefuseManualStop=true
+
+[Mount]
+What=xenfs
+Where=/proc/xen
+Type=xenfs
diff --git a/tmpfile b/tmpfile
new file mode 100644
index 000000000000..44337cf44589
--- /dev/null
+++ b/tmpfile
@@ -0,0 +1 @@
+d /run/xenstored 0755 - - -
diff --git a/xe-daemon.service b/xe-daemon.service
new file mode 100644
index 000000000000..0a5a6ee92610
--- /dev/null
+++ b/xe-daemon.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=xen daemon file
+After=xe-linux-distribution.service
+Requires=proc-xen.mount
+
+[Service]
+PIDFile=/run/xe-daemon.pid
+ExecStart=/usr/bin/xe-daemon -p /run/xe-daemon.pid
+ExecStop=/usr/bin/pkill -TERM -F /run/xe-daemon.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/xe-linux-distribution.service b/xe-linux-distribution.service
new file mode 100644
index 000000000000..eb0b32ff4807
--- /dev/null
+++ b/xe-linux-distribution.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=xen linux distribution service
+Before=xend.service
+
+[Service]
+Type=simple
+RemainAfterExit=yes
+ExecStart=/usr/bin/xe-linux-distribution /var/cache/xe-linux-distribution
+
+[Install]
+WantedBy=multi-user.target