summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2015-06-08 15:00:30 +0200
committerFrederic Bezies2015-06-08 15:00:30 +0200
commit00c1f705983355163084f9b9107be50875db295e (patch)
treec984bbebf54a77f4f35149b20f3a7db860d64523
downloadaur-00c1f705983355163084f9b9107be50875db295e.tar.gz
initial commit on aur4
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
-rw-r--r--xemeraldia.desktop8
-rw-r--r--xemeraldia.install7
-rw-r--r--xemeraldia.patch30
-rw-r--r--xemeraldia.pngbin0 -> 4533 bytes
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65f68b7bbac9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xemeraldia
+ pkgdesc = A Tetris-like falling blocks game
+ pkgver = 0.4.3
+ pkgrel = 3
+ url = http://www.reloco.com.ar/xemeraldia/
+ install = xemeraldia.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ source = http://www.reloco.com.ar/xemeraldia/xemeraldia-0.4.3.tar.gz
+ source = xemeraldia.patch
+ source = xemeraldia.png
+ source = xemeraldia.desktop
+ md5sums = 55cb4d5ea0564e535ba7f8cb48a915da
+ md5sums = 07bce1f57787d183ddff76a27ab0bf34
+ md5sums = dd3bd79c141edeb1f81675d07b5a7c1a
+ md5sums = 25c363a68262b112905dc59d0ad42909
+
+pkgname = xemeraldia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36fa34a2e788
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+
+pkgname=xemeraldia
+pkgver=0.4.3
+pkgrel=3
+pkgdesc="A Tetris-like falling blocks game"
+arch=('i686' 'x86_64')
+url="http://www.reloco.com.ar/xemeraldia/"
+license=('custom')
+depends=('gtk2')
+install="${pkgname}.install"
+source=("http://www.reloco.com.ar/xemeraldia/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.patch"
+ "${pkgname}.png"
+ "${pkgname}.desktop")
+md5sums=('55cb4d5ea0564e535ba7f8cb48a915da'
+ '07bce1f57787d183ddff76a27ab0bf34'
+ 'dd3bd79c141edeb1f81675d07b5a7c1a'
+ '25c363a68262b112905dc59d0ad42909')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i "../${pkgname}.patch"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Install game files
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -dm775 -g games "${pkgdir}/var/lib/${pkgname}"
+
+ # Install pixmap and .desktop file
+ install -Dm644 "../${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "../${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Install readme files and license
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 NEWS README* "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+
+ # Install translations
+ cd po
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/xemeraldia.desktop b/xemeraldia.desktop
new file mode 100644
index 000000000000..a43b11e622ec
--- /dev/null
+++ b/xemeraldia.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=XEmeraldia
+Comment=A Tetris-like falling blocks game
+Exec=xemeraldia
+Icon=xemeraldia.png
+Terminal=false
+Categories=Game;BlocksGame;
diff --git a/xemeraldia.install b/xemeraldia.install
new file mode 100644
index 000000000000..8ff19e052b76
--- /dev/null
+++ b/xemeraldia.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo " > You need to be in the 'games' group to use the scores file."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/xemeraldia.patch b/xemeraldia.patch
new file mode 100644
index 000000000000..5564693b3297
--- /dev/null
+++ b/xemeraldia.patch
@@ -0,0 +1,30 @@
+--- xemeraldia-0.4.3.orig/Makefile.in 2009-02-10 07:33:00.000000000 +0500
++++ xemeraldia-0.4.3/Makefile.in 2012-02-28 15:45:09.406143623 +0600
+@@ -242,7 +242,7 @@
+ ACLOCAL_AMFLAGS = -I m4
+ EXTRA_DIST = config.rpath NEWS README.jp xemeraldia.desktop.in TODO
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" \
+- -DHIGH_SCORE_TABLE=\"/var/games/xemeraldia.scores\"
++ -DHIGH_SCORE_TABLE=\"/var/lib/xemeraldia/xemeraldia.scores\"
+
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+--- xemeraldia-0.4.3.orig/graphics.c 2009-02-10 05:55:24.000000000 +0500
++++ xemeraldia-0.4.3/graphics.c 2012-02-28 15:44:48.346143504 +0600
+@@ -7,6 +7,7 @@
+ #endif
+
+ #include "games.h"
++#include "gtk-2.0/gtk/gtkprivate.h"
+
+ static gboolean animateTmpScore (void *);
+
+@@ -32,7 +33,7 @@
+
+ static void invalidate_area(GtkWidget *widget, gint x, gint y, gint w, gint h)
+ {
+- while(GTK_WIDGET_FLAGS(widget) & GTK_NO_WINDOW)
++ while(GTK_PRIVATE_FLAGS(widget) & GTK_NO_WINDOW)
+ {
+ x += widget->allocation.x;
+ y += widget->allocation.y;
diff --git a/xemeraldia.png b/xemeraldia.png
new file mode 100644
index 000000000000..e5854bf75c54
--- /dev/null
+++ b/xemeraldia.png
Binary files differ