summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-12-23 07:08:02 +0100
committerAlexandre Bouvier2023-12-23 07:08:02 +0100
commit0f74c2dd62691646fa91128fcc03440b9f302ec4 (patch)
treebac5ea3ab758a27e43c15ed7c6baf53a78d65919
parentd77992c3ef21ebe117fb3439024084fa37292932 (diff)
downloadaur-0f74c2dd62691646fa91128fcc03440b9f302ec4.tar.gz
update to 0.7.118.r0.g03f40b1d8e
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--use-system-libs.patch9
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c226e817cd84..b7cd63357f7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xemu-git
pkgdesc = Original Xbox emulator (fork of XQEMU)
- pkgver = 0.7.117.r1.g800eb468a4
+ pkgver = 0.7.118.r0.g03f40b1d8e
pkgrel = 1
url = https://xemu.app/
install = xemu.install
@@ -49,7 +49,7 @@ pkgbase = xemu-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = 66713ea21508daea5940a1dc0d761ecf449d31a825f2e24090d296ea4c127df80f961d13fe8d179bdad265441bad7174344c53db4202a23b910e9e0ca6c04e21
+ b2sums = 55fd67005d4fbfd0a068d91d33227c856b702e5d2616b11a33fcb83204024e5aa80eb7b9b501c85d192e79f93f5be5f0b8c78ff96dfa308746e807d3d278579b
pkgname = xemu-git
depends = dtc
diff --git a/PKGBUILD b/PKGBUILD
index a83fa5c43ed8..8a2027450446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=xemu
pkgname=$_pkgname-git
-pkgver=0.7.117.r1.g800eb468a4
+pkgver=0.7.118.r0.g03f40b1d8e
pkgrel=1
pkgdesc="Original Xbox emulator (fork of XQEMU)"
arch=('x86_64')
@@ -58,7 +58,7 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
- '66713ea21508daea5940a1dc0d761ecf449d31a825f2e24090d296ea4c127df80f961d13fe8d179bdad265441bad7174344c53db4202a23b910e9e0ca6c04e21'
+ '55fd67005d4fbfd0a068d91d33227c856b702e5d2616b11a33fcb83204024e5aa80eb7b9b501c85d192e79f93f5be5f0b8c78ff96dfa308746e807d3d278579b'
)
pkgver() {
diff --git a/use-system-libs.patch b/use-system-libs.patch
index bb4dba7dcc0c..ec33785674a9 100644
--- a/use-system-libs.patch
+++ b/use-system-libs.patch
@@ -21,7 +21,7 @@ index 761cd5e431..e8cca19248 100755
meson_options="$meson_options $(quote_sh "$1")"
}
diff --git a/meson.build b/meson.build
-index 0ae9c6f8a1..debb80c61d 100644
+index 38127c9809..b7fb0d9e16 100644
--- a/meson.build
+++ b/meson.build
@@ -1180,11 +1180,7 @@ if (have_system or have_tools) and (virgl.found() or opengl.found())
@@ -38,10 +38,10 @@ index 0ae9c6f8a1..debb80c61d 100644
genconfig = declare_dependency(include_directories: 'genconfig')
diff --git a/ui/thirdparty/meson.build b/ui/thirdparty/meson.build
-index 6b11d3a9c1..c2e80c99b7 100644
+index ad01b58932..11e37d9839 100644
--- a/ui/thirdparty/meson.build
+++ b/ui/thirdparty/meson.build
-@@ -60,5 +60,5 @@ endif
+@@ -60,8 +60,8 @@ endif
libfpng = static_library('fpng', sources: 'fpng/fpng.cpp', cpp_args: libfpng_cpp_args)
fpng = declare_dependency(include_directories: 'fpng', link_with: libfpng)
@@ -49,6 +49,9 @@ index 6b11d3a9c1..c2e80c99b7 100644
-httplib = declare_dependency(include_directories: 'httplib')
+json = dependency('nlohmann_json')
+httplib = dependency('httplib')
+
+ libfatx = static_library('fatx', sources: 'fatx/fatx.c')
+ fatx = declare_dependency(include_directories: 'fatx', link_with: libfatx)
diff --git a/ui/xui/reporting.cc b/ui/xui/reporting.cc
index 992d5da0a7..b9a538e07a 100644
--- a/ui/xui/reporting.cc