summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-02-14 16:08:09 +0100
committerAlexandre Bouvier2021-02-14 16:08:09 +0100
commit22e8160c8398aa29155bfef46c0a248ad7a2fab6 (patch)
treea9406b37bb926c69cd3f1c67fa30468e8ec84341
parent4f08c43a0f16a5f78bf73e234e989c780fdc521d (diff)
downloadaur-22e8160c8398aa29155bfef46c0a248ad7a2fab6.tar.gz
0.5.0.r42.g8326870f77
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--fix-no-pie.diff26
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85ba1004a698..268faab0226b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xemu-git
pkgdesc = Original Xbox emulator (fork of XQEMU)
- pkgver = 0.5.0.r2.g270310e603
+ pkgver = 0.5.0.r42.g8326870f77
pkgrel = 1
url = https://xemu.app/
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = xemu-git
provides = xemu
conflicts = xemu
source = xemu::git+https://github.com/mborgerson/xemu.git
+ source = fix-no-pie.diff
md5sums = SKIP
+ md5sums = 25fa6282b6c1a11eed44c9f1ab2c5ab7
pkgname = xemu-git
diff --git a/PKGBUILD b/PKGBUILD
index 9dab5a6322c3..8361071587ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck shell=bash disable=SC2034,SC2164
_pkgname=xemu
pkgname=$_pkgname-git
-pkgver=0.5.0.r2.g270310e603
+pkgver=0.5.0.r42.g8326870f77
pkgrel=1
pkgdesc="Original Xbox emulator (fork of XQEMU)"
arch=('x86_64')
@@ -12,14 +12,21 @@ depends=('glu' 'gtk3' 'libsamplerate' 'sdl2')
makedepends=('git' 'python')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/mborgerson/xemu.git")
-md5sums=('SKIP')
+source=("$_pkgname::git+https://github.com/mborgerson/xemu.git"
+ 'fix-no-pie.diff')
+md5sums=('SKIP'
+ '25fa6282b6c1a11eed44c9f1ab2c5ab7')
pkgver() {
cd $_pkgname
git describe --long | sed 's/^xemu-v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $_pkgname
+ patch -p1 < ../fix-no-pie.diff
+}
+
build() {
cd $_pkgname
./build.sh
diff --git a/fix-no-pie.diff b/fix-no-pie.diff
new file mode 100644
index 000000000000..620b31643418
--- /dev/null
+++ b/fix-no-pie.diff
@@ -0,0 +1,26 @@
+--- a/configure 2021-02-14 15:53:55.731291720 +0100
++++ b/configure 2021-02-14 15:52:34.968093261 +0100
+@@ -2192,7 +2192,6 @@
+ # Check we support --no-pie first; we will need this for building ROMs.
+ if compile_prog "-Werror -fno-pie" "-no-pie"; then
+ CFLAGS_NOPIE="-fno-pie"
+- LDFLAGS_NOPIE="-no-pie"
+ fi
+
+ if test "$static" = "yes"; then
+@@ -2208,7 +2207,6 @@
+ fi
+ elif test "$pie" = "no"; then
+ QEMU_CFLAGS="$CFLAGS_NOPIE $QEMU_CFLAGS"
+- QEMU_LDFLAGS="$LDFLAGS_NOPIE $QEMU_LDFLAGS"
+ elif compile_prog "-Werror -fPIE -DPIE" "-pie"; then
+ QEMU_CFLAGS="-fPIE -DPIE $QEMU_CFLAGS"
+ QEMU_LDFLAGS="-pie $QEMU_LDFLAGS"
+@@ -8081,7 +8079,6 @@
+ echo "QEMU_CFLAGS += -Wbitwise -Wno-transparent-union -Wno-old-initializer -Wno-non-pointer-null" >> $config_host_mak
+ fi
+ echo "QEMU_LDFLAGS=$QEMU_LDFLAGS" >> $config_host_mak
+-echo "LDFLAGS_NOPIE=$LDFLAGS_NOPIE" >> $config_host_mak
+ echo "LD_REL_FLAGS=$LD_REL_FLAGS" >> $config_host_mak
+ echo "LD_I386_EMULATION=$ld_i386_emulation" >> $config_host_mak
+ echo "LIBS+=$LIBS" >> $config_host_mak