summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-07-23 03:25:34 +0200
committerAlexandre Bouvier2023-07-23 03:25:57 +0200
commit7cb32845e1001a7151d15552521c16b8b90ba558 (patch)
tree8a88d14d02993168142c2a10ebeda7f1cd63ffaf
parentcbe4c78b1842fba57c9229f8e3f9c225b58b9a3d (diff)
downloadaur-7cb32845e1001a7151d15552521c16b8b90ba558.tar.gz
update to 0.7.103.r0.g93ab116e91
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--use-system-libs.patch64
3 files changed, 83 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f0be42cc6ea..202ac83ea97b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = xemu-git
pkgdesc = Original Xbox emulator (fork of XQEMU)
- pkgver = 0.7.99.r0.g158cc0d140
+ pkgver = 0.7.103.r0.g93ab116e91
pkgrel = 1
url = https://xemu.app/
install = xemu.install
arch = x86_64
license = GPL2
+ makedepends = cmake
+ makedepends = cpp-httplib
makedepends = git
makedepends = glib2
makedepends = glu
@@ -16,6 +18,7 @@ pkgbase = xemu-git
makedepends = libsamplerate
makedepends = libslirp
makedepends = meson
+ makedepends = nlohmann-json
makedepends = openssl
makedepends = pixman
makedepends = python-yaml
@@ -37,6 +40,7 @@ pkgbase = xemu-git
source = implot::git+https://github.com/epezent/implot.git
source = keycodemapdb::git+https://gitlab.com/qemu-project/keycodemapdb.git
source = nv2a_vsh_cpu::git+https://github.com/abaire/nv2a_vsh_cpu.git
+ source = use-system-libs.patch
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
@@ -45,6 +49,7 @@ pkgbase = xemu-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = 66713ea21508daea5940a1dc0d761ecf449d31a825f2e24090d296ea4c127df80f961d13fe8d179bdad265441bad7174344c53db4202a23b910e9e0ca6c04e21
pkgname = xemu-git
depends = dtc
@@ -53,15 +58,15 @@ pkgname = xemu-git
depends = hicolor-icon-theme
depends = sdl2
depends = zlib
- depends = libcrypto.so
depends = libepoxy.so
depends = libgdk-3.so
depends = libglib-2.0.so
depends = libgobject-2.0.so
depends = libgtk-3.so
+ depends = libhttplib.so
depends = libkeyutils.so
depends = libpcap.so
depends = libpixman-1.so
depends = libsamplerate.so
depends = libslirp.so
- depends = libssl.so
+ depends = libtomlplusplus.so
diff --git a/PKGBUILD b/PKGBUILD
index fb49bbd0a9f4..b4b19f89b07d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=xemu
pkgname=$_pkgname-git
-pkgver=0.7.99.r0.g158cc0d140
+pkgver=0.7.103.r0.g93ab116e91
pkgrel=1
pkgdesc="Original Xbox emulator (fork of XQEMU)"
arch=('x86_64')
@@ -9,6 +9,8 @@ url="https://xemu.app/"
license=('GPL2')
depends=('dtc' 'gcc-libs' 'glibc' 'hicolor-icon-theme' 'sdl2' 'zlib')
makedepends=(
+ 'cmake'
+ 'cpp-httplib'
'git'
'glib2'
'glu'
@@ -19,6 +21,7 @@ makedepends=(
'libsamplerate'
'libslirp'
'meson'
+ 'nlohmann-json'
'openssl'
'pixman'
'python-yaml'
@@ -37,6 +40,7 @@ source=(
'implot::git+https://github.com/epezent/implot.git'
'keycodemapdb::git+https://gitlab.com/qemu-project/keycodemapdb.git'
'nv2a_vsh_cpu::git+https://github.com/abaire/nv2a_vsh_cpu.git'
+ 'use-system-libs.patch'
)
b2sums=(
'SKIP'
@@ -47,6 +51,7 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
+ '66713ea21508daea5940a1dc0d761ecf449d31a825f2e24090d296ea4c127df80f961d13fe8d179bdad265441bad7174344c53db4202a23b910e9e0ca6c04e21'
)
pkgver() {
@@ -64,7 +69,8 @@ prepare() {
git config submodule.ui/thirdparty/imgui.url ../imgui
git config submodule.ui/thirdparty/implot.url ../implot
git -c protocol.file.allow=always submodule update
- mkdir ../build tomlplusplus/include
+ mkdir -p ../build
+ patch -Np1 < ../use-system-libs.patch
python scripts/gen-license.py > XEMU_LICENSE
}
@@ -75,25 +81,25 @@ build() {
--disable-debug-info \
--extra-cflags="-DXBOX=1" \
--ninja="$NINJA" \
- --target-list=i386-softmmu \
+ --target-list="i386-softmmu" \
--with-git-submodules=ignore
make qemu-system-i386
}
package() {
depends+=(
- 'libcrypto.so'
'libepoxy.so'
'libgdk-3.so'
'libglib-2.0.so'
'libgobject-2.0.so'
'libgtk-3.so'
+ 'libhttplib.so'
'libkeyutils.so'
'libpcap.so'
'libpixman-1.so'
'libsamplerate.so'
'libslirp.so'
- 'libssl.so'
+ 'libtomlplusplus.so'
)
cd $_pkgname
# shellcheck disable=SC2154
diff --git a/use-system-libs.patch b/use-system-libs.patch
new file mode 100644
index 000000000000..bb4dba7dcc0c
--- /dev/null
+++ b/use-system-libs.patch
@@ -0,0 +1,64 @@
+diff --git a/configure b/configure
+index 761cd5e431..e8cca19248 100755
+--- a/configure
++++ b/configure
+@@ -574,7 +574,7 @@ case "$cpu" in
+ # ??? Only extremely old AMD cpus do not have cmpxchg16b.
+ # If we truly care, we should simply detect this case at
+ # runtime and generate the fallback to serial emulation.
+- CPU_CFLAGS="-m64 -mcx16" ;;
++ CPU_CFLAGS="" ;;
+
+ mips*)
+ cpu="mips" ;;
+@@ -664,7 +664,7 @@ meson_option_build_array() {
+
+ . "$source_path/scripts/meson-buildoptions.sh"
+
+-meson_options=
++meson_options="--buildtype=plain"
+ meson_option_add() {
+ meson_options="$meson_options $(quote_sh "$1")"
+ }
+diff --git a/meson.build b/meson.build
+index 0ae9c6f8a1..debb80c61d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1180,11 +1180,7 @@ if (have_system or have_tools) and (virgl.found() or opengl.found())
+ endif
+ have_vhost_user_gpu = have_vhost_user_gpu and virgl.found() and opengl.found() and gbm.found()
+
+-tomllib = static_library('tomlpp', sources: files('toml.cpp'),
+- include_directories: 'tomlplusplus/include')
+-toml = declare_dependency(compile_args: ['-DTOML_HEADER_ONLY=0'],
+- include_directories: 'tomlplusplus/include',
+- link_with: tomllib)
++toml = dependency('tomlplusplus')
+
+ genconfig = declare_dependency(include_directories: 'genconfig')
+
+diff --git a/ui/thirdparty/meson.build b/ui/thirdparty/meson.build
+index 6b11d3a9c1..c2e80c99b7 100644
+--- a/ui/thirdparty/meson.build
++++ b/ui/thirdparty/meson.build
+@@ -60,5 +60,5 @@ endif
+ libfpng = static_library('fpng', sources: 'fpng/fpng.cpp', cpp_args: libfpng_cpp_args)
+ fpng = declare_dependency(include_directories: 'fpng', link_with: libfpng)
+
+-json = declare_dependency(include_directories: 'json')
+-httplib = declare_dependency(include_directories: 'httplib')
++json = dependency('nlohmann_json')
++httplib = dependency('httplib')
+diff --git a/ui/xui/reporting.cc b/ui/xui/reporting.cc
+index 992d5da0a7..b9a538e07a 100644
+--- a/ui/xui/reporting.cc
++++ b/ui/xui/reporting.cc
+@@ -24,7 +24,7 @@
+ #include "reporting.hh"
+ #define CPPHTTPLIB_OPENSSL_SUPPORT 1
+ #include <httplib.h>
+-#include <json.hpp>
++#include <nlohmann/json.hpp>
+ using json = nlohmann::json;
+
+ #define DEBUG_COMPAT_SERVICE 0