summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-07-17 15:48:25 +0200
committerAlexandre Bouvier2021-07-17 15:48:25 +0200
commitaf04f1789e20b310abac3ccc758e66f10c4142d5 (patch)
treef98a91e2f3e694ab6f7f8318adfd68d7089731a8
parent857cb64642c80e1b271601757a21ddb11b2cadbe (diff)
downloadaur-af04f1789e20b310abac3ccc758e66f10c4142d5.tar.gz
unbundle xxhash
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--unbundle-xxhash.patch13
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 055d424d9818..0fac381ef735 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,23 +19,24 @@ pkgbase = xemu-git
makedepends = openssl
makedepends = pixman
makedepends = python
+ makedepends = xxhash
depends = sdl2
provides = xemu
conflicts = xemu
- source = git+https://github.com/Cyan4973/xxHash.git
source = git+https://github.com/epezent/implot.git
source = git+https://github.com/mborgerson/xemu.git
source = git+https://github.com/ocornut/imgui.git
source = git+https://gitlab.com/qemu-project/berkeley-softfloat-3.git
source = git+https://gitlab.com/qemu-project/berkeley-testfloat-3.git
source = git+https://gitlab.com/qemu-project/keycodemapdb.git
+ source = unbundle-xxhash.patch
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = SKIP
+ b2sums = 61cd11e6d3a50df9f885155a5847dc4c9b4e8c3a2fd3fb6cd2c207374554a849e49cda3cf80ac700c32d4638925fb715895238ac5d9963a4e9ff67999e54f713
pkgname = xemu-git
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 492d5bf00837..ae2b215cfe3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,18 +8,18 @@ arch=('x86_64')
url="https://xemu.app/"
license=('GPL2')
depends=('sdl2')
-makedepends=('git' 'glib2' 'glu' 'gtk3' 'libepoxy' 'libpcap' 'libsamplerate' 'libslirp' 'meson' 'ninja' 'openssl' 'pixman' 'python')
+makedepends=('git' 'glib2' 'glu' 'gtk3' 'libepoxy' 'libpcap' 'libsamplerate' 'libslirp' 'meson' 'ninja' 'openssl' 'pixman' 'python' 'xxhash')
provides=("$_pkgname")
conflicts=("$_pkgname")
install=$_pkgname.install
source=(
- 'git+https://github.com/Cyan4973/xxHash.git'
'git+https://github.com/epezent/implot.git'
'git+https://github.com/mborgerson/xemu.git'
'git+https://github.com/ocornut/imgui.git'
'git+https://gitlab.com/qemu-project/berkeley-softfloat-3.git'
'git+https://gitlab.com/qemu-project/berkeley-testfloat-3.git'
'git+https://gitlab.com/qemu-project/keycodemapdb.git'
+ 'unbundle-xxhash.patch'
)
b2sums=(
'SKIP'
@@ -28,7 +28,7 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
+ '61cd11e6d3a50df9f885155a5847dc4c9b4e8c3a2fd3fb6cd2c207374554a849e49cda3cf80ac700c32d4638925fb715895238ac5d9963a4e9ff67999e54f713'
)
pkgver() {
@@ -38,14 +38,14 @@ pkgver() {
prepare() {
cd $_pkgname
- git submodule init hw/xbox/nv2a/xxHash tests/fp/berkeley-{soft,test}float-3 ui/{imgui,implot,keycodemapdb}
- git config submodule.hw/xbox/nv2a/xxHash.url ../xxHash
+ git submodule init tests/fp/berkeley-{soft,test}float-3 ui/{imgui,implot,keycodemapdb}
git config submodule.tests/fp/berkeley-softfloat-3.url ../berkeley-softfloat-3
git config submodule.tests/fp/berkeley-testfloat-3.url ../berkeley-testfloat-3
git config submodule.ui/imgui.url ../imgui
git config submodule.ui/implot.url ../implot
git config submodule.ui/keycodemapdb.url ../keycodemapdb
git submodule update
+ patch -Np1 < ../unbundle-xxhash.patch
python scripts/gen-license.py > XEMU_LICENSE
}
diff --git a/unbundle-xxhash.patch b/unbundle-xxhash.patch
new file mode 100644
index 000000000000..7f64eec59b33
--- /dev/null
+++ b/unbundle-xxhash.patch
@@ -0,0 +1,13 @@
+diff --git a/hw/xbox/nv2a/pgraph.c b/hw/xbox/nv2a/pgraph.c
+index c388cc4..124d552 100644
+--- a/hw/xbox/nv2a/pgraph.c
++++ b/hw/xbox/nv2a/pgraph.c
+@@ -20,7 +20,7 @@
+ */
+
+ #include "nv2a_int.h"
+-#include "xxHash/xxh3.h"
++#include <xxh3.h>
+ #include "s3tc.h"
+
+ #define DBG_SURFACES 0