summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-07-29 22:45:27 +0200
committerAlexandre Bouvier2021-07-29 22:45:27 +0200
commitdc97cf3630d0bf6ed0d00519098baadbb854bc1b (patch)
treee7c9c9c4f295d529e912fbcefefa69cbe3772295
parent4bc3ab14fd65f42e5cbb182878af4b7e38fda434 (diff)
downloadaur-dc97cf3630d0bf6ed0d00519098baadbb854bc1b.tar.gz
replace xxhash patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--unbundle-xxhash.patch13
3 files changed, 2 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcc9fe0a31fb..a565378578e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,14 +29,12 @@ pkgbase = xemu-git
source = git+https://gitlab.com/qemu-project/berkeley-softfloat-3.git
source = git+https://gitlab.com/qemu-project/berkeley-testfloat-3.git
source = git+https://gitlab.com/qemu-project/keycodemapdb.git
- source = unbundle-xxhash.patch
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = 61cd11e6d3a50df9f885155a5847dc4c9b4e8c3a2fd3fb6cd2c207374554a849e49cda3cf80ac700c32d4638925fb715895238ac5d9963a4e9ff67999e54f713
pkgname = xemu-git
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 32c059690bb4..6dcba96d9573 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,6 @@ source=(
'git+https://gitlab.com/qemu-project/berkeley-softfloat-3.git'
'git+https://gitlab.com/qemu-project/berkeley-testfloat-3.git'
'git+https://gitlab.com/qemu-project/keycodemapdb.git'
- 'unbundle-xxhash.patch'
)
b2sums=(
'SKIP'
@@ -43,7 +42,6 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
- '61cd11e6d3a50df9f885155a5847dc4c9b4e8c3a2fd3fb6cd2c207374554a849e49cda3cf80ac700c32d4638925fb715895238ac5d9963a4e9ff67999e54f713'
)
pkgver() {
@@ -60,8 +58,9 @@ prepare() {
git config submodule.ui/implot.url ../implot
git config submodule.ui/keycodemapdb.url ../keycodemapdb
git submodule update
- patch -Np1 < ../unbundle-xxhash.patch
python scripts/gen-license.py > XEMU_LICENSE
+ # unbundle xxhash
+ sed -i 's/"xxHash\/xxh3\.h"/<xxh3.h>/' hw/xbox/nv2a/pgraph.c
}
build() {
diff --git a/unbundle-xxhash.patch b/unbundle-xxhash.patch
deleted file mode 100644
index 7f64eec59b33..000000000000
--- a/unbundle-xxhash.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/hw/xbox/nv2a/pgraph.c b/hw/xbox/nv2a/pgraph.c
-index c388cc4..124d552 100644
---- a/hw/xbox/nv2a/pgraph.c
-+++ b/hw/xbox/nv2a/pgraph.c
-@@ -20,7 +20,7 @@
- */
-
- #include "nv2a_int.h"
--#include "xxHash/xxh3.h"
-+#include <xxh3.h>
- #include "s3tc.h"
-
- #define DBG_SURFACES 0