summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-04-25 18:47:14 +0200
committerAlexandre Bouvier2022-04-25 18:47:14 +0200
commitffa0cce56e7c78b81ba1a7eb610635834bc4f9e3 (patch)
treef85644798f93a30be13fbfe1f9434030cdb40c48
parent01854131ab5d0a6c1868ce9ab20a3b0e648aae5d (diff)
downloadaur-ffa0cce56e7c78b81ba1a7eb610635834bc4f9e3.tar.gz
update to 0.6.3.r0.g87919cfb13
* add genconfig * unbundle tomlplusplus
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65f579b75953..0c720d4a4dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xemu-git
pkgdesc = Original Xbox emulator (fork of XQEMU)
- pkgver = 0.6.2.r90.g6f507c80af
+ pkgver = 0.6.3.r0.g87919cfb13
pkgrel = 1
url = https://xemu.app/
install = xemu.install
@@ -17,15 +17,17 @@ pkgbase = xemu-git
makedepends = meson
makedepends = openssl
makedepends = pixman
- makedepends = python
+ makedepends = python-yaml
makedepends = samurai
- makedepends = xxhash
+ makedepends = tomlplusplus>=3.0.1.r11
+ makedepends = xxhash>=0.7.4.r137
depends = sdl2
provides = xemu
conflicts = xemu
source = xemu::git+https://github.com/mborgerson/xemu.git
source = berkeley-softfloat-3::git+https://gitlab.com/qemu-project/berkeley-softfloat-3.git
source = berkeley-testfloat-3::git+https://gitlab.com/qemu-project/berkeley-testfloat-3.git
+ source = genconfig::git+https://github.com/mborgerson/genconfig.git
source = imgui::git+https://github.com/ocornut/imgui.git
source = implot::git+https://github.com/epezent/implot.git
source = keycodemapdb::git+https://gitlab.com/qemu-project/keycodemapdb.git
@@ -35,6 +37,7 @@ pkgbase = xemu-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = SKIP
pkgname = xemu-git
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index db7bba9ff502..7cf189fc7660 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=xemu
pkgname=$_pkgname-git
-pkgver=0.6.2.r90.g6f507c80af
+pkgver=0.6.3.r0.g87919cfb13
pkgrel=1
pkgdesc="Original Xbox emulator (fork of XQEMU)"
arch=('x86_64')
@@ -20,9 +20,10 @@ makedepends=(
'meson'
'openssl'
'pixman'
- 'python'
+ 'python-yaml'
'samurai'
- 'xxhash'
+ 'tomlplusplus>=3.0.1.r11'
+ 'xxhash>=0.7.4.r137'
)
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -31,6 +32,7 @@ source=(
"$_pkgname::git+https://github.com/mborgerson/xemu.git"
'berkeley-softfloat-3::git+https://gitlab.com/qemu-project/berkeley-softfloat-3.git'
'berkeley-testfloat-3::git+https://gitlab.com/qemu-project/berkeley-testfloat-3.git'
+ 'genconfig::git+https://github.com/mborgerson/genconfig.git'
'imgui::git+https://github.com/ocornut/imgui.git'
'implot::git+https://github.com/epezent/implot.git'
'keycodemapdb::git+https://gitlab.com/qemu-project/keycodemapdb.git'
@@ -42,6 +44,7 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
pkgver() {
@@ -51,7 +54,8 @@ pkgver() {
prepare() {
cd $_pkgname
- git submodule init tests/fp/berkeley-{soft,test}float-3 ui/{imgui,implot,keycodemapdb}
+ git submodule init genconfig tests/fp/berkeley-{soft,test}float-3 ui/{imgui,implot,keycodemapdb}
+ git config submodule.genconfig.url ../genconfig
git config submodule.tests/fp/berkeley-softfloat-3.url ../berkeley-softfloat-3
git config submodule.tests/fp/berkeley-testfloat-3.url ../berkeley-testfloat-3
git config submodule.ui/imgui.url ../imgui
@@ -59,6 +63,8 @@ prepare() {
git config submodule.ui/keycodemapdb.url ../keycodemapdb
git submodule update
python scripts/gen-license.py > XEMU_LICENSE
+ # unbundle tomlplusplus
+ sed -i 's/<toml\.hpp>/<toml++\/toml.h>/' genconfig/cnode.h toml.cpp ui/xemu-settings.cc
# unbundle xxhash
sed -i 's/"util\/xxHash\/xxh3\.h"/<xxh3.h>/' util/fast-hash.c
}