summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2021-10-24 20:18:58 +0100
committerEric Engestrom2021-10-24 20:18:58 +0100
commite28dd5db428c048d67f80af7f57c31f8b9919d54 (patch)
treeaaca851bfedfc1f3d26749f17ceba0af63e80b9f
downloadaur-e28dd5db428c048d67f80af7f57c31f8b9919d54.tar.gz
initial commit - v1.1.0-2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD60
-rw-r--r--xencelabs.install11
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5117e84ec2eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xencelabs
+ pkgdesc = Driver for the Xencelabs Pen Tablets
+ pkgver = 1.1.0.2
+ pkgrel = 1
+ url = https://www.xencelabs.com
+ install = xencelabs.install
+ arch = x86_64
+ license = LGPL3
+ depends = qt5-base
+ depends = qt5-x11extras
+ depends = icu
+ source_x86_64 = https://www.xencelabs.com/wp-content/uploads/2021/10/Linux-1.1.0-2-driver.zip
+ sha256sums_x86_64 = 7063c441cd594f7200f6a14c25505f25c1a129749a017478b802915f8df1b226
+
+pkgname = xencelabs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc67b0b4d0bf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcbe7448d557
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Eric Engestrom <aur@engestrom.ch>
+
+_TARBALL_PKGVER=1.1.0-2
+_UPLOAD_YEAR=2021
+_UPLOAD_MONTH=10
+
+pkgname=xencelabs
+pkgver=${_TARBALL_PKGVER/-/.}
+pkgrel=1
+#FIXME: find somewhere where they have a better description than in their .desktop file
+pkgdesc='Driver for the Xencelabs Pen Tablets'
+arch=(x86_64)
+url='https://www.xencelabs.com'
+license=(LGPL3)
+depends=(qt5-base qt5-x11extras icu)
+install=$pkgname.install
+source_x86_64=("$url/wp-content/uploads/$_UPLOAD_YEAR/$_UPLOAD_MONTH/Linux-$_TARBALL_PKGVER-driver.zip")
+sha256sums_x86_64=('7063c441cd594f7200f6a14c25505f25c1a129749a017478b802915f8df1b226')
+
+prepare() {
+ rm -rf $pkgname-$_TARBALL_PKGVER.$CARCH
+ tar xf $pkgname-$_TARBALL_PKGVER.$CARCH.tar.gz
+}
+
+build() {
+ cd $pkgname-$_TARBALL_PKGVER.$CARCH/App
+
+ # provided by the `licenses` package
+ rm usr/lib/xencelabs/LGPL
+
+ # fix FSH to match Arch's
+ mv lib/*/ usr/lib/
+ rmdir lib
+
+ # Replace xencelabs.desktop copy with symlink
+ ln -sf ../../../usr/share/applications/xencelabs.desktop \
+ etc/xdg/autostart/xencelabs.desktop
+
+ # provided by package dependencies
+ rm usr/lib/xencelabs/lib/libQt5*
+ rm usr/lib/xencelabs/platforms/libqxcb.so
+ rm usr/lib/xencelabs/lib/libicu*
+
+ # make sure it's empty, so that if some other lib is added in a future
+ # release we notice it right away.
+ rmdir usr/lib/xencelabs/lib/
+ rmdir usr/lib/xencelabs/platforms/
+
+ # Now that we use the sytem libs, the wrapper doesn't do anything anymore
+ mkdir usr/bin
+ mv usr/lib/xencelabs/xencelabs usr/bin/xencelabs
+ rm usr/lib/xencelabs/xencelabs.sh
+ sed s,/usr/lib/xencelabs/xencelabs.sh,xencelabs,g -i \
+ usr/share/applications/xencelabs.desktop
+}
+
+package() {
+ cp -r --no-preserve=ownership,mode $pkgname-$_TARBALL_PKGVER.$CARCH/App/* "$pkgdir"
+ chmod +x "$pkgdir"/usr/bin/xencelabs
+}
diff --git a/xencelabs.install b/xencelabs.install
new file mode 100644
index 000000000000..acd6a5712a84
--- /dev/null
+++ b/xencelabs.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "--------------------------------------------------------------------------------"
+ echo "WARNING: Make sure you create the folder ~/.local/share/xencelabs/"
+ echo "WARNING: and copy the contents of /usr/lib/xencelabs/config/ into it."
+ echo "WARNING: xencelabs will not work unless you do this."
+ echo "--------------------------------------------------------------------------------"
+}
+
+post_upgrade() {
+ post_install
+}