summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2018-01-27 15:37:50 -0800
committerSandy Carter2018-01-27 18:19:21 -0800
commit47682613cc97cd4f463dcc50ba58423197b61752 (patch)
tree8c81140ee2e8798f5680a13cc8859fb8519c5e91
downloadaur-47682613cc97cd4f463dcc50ba58423197b61752.tar.gz
initial commit
-rw-r--r--.SRCINFO52
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD97
3 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a491ab338925
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+# Generated by mksrcinfo v8
+# Sun Jan 28 02:16:54 UTC 2018
+pkgbase = xenia-git
+ pkgdesc = Xenia is an experimental emulator for the Xbox 360.
+ pkgver = r4124.5477b1e4
+ pkgrel = 1
+ url = http://xenia.jp
+ arch = x86_64
+ license = BSD
+ makedepends = python
+ makedepends = clang
+ makedepends = vulkan-headers
+ makedepends = git
+ makedepends = clang
+ makedepends = libc++abi
+ depends = gtk3
+ depends = lz4
+ depends = glew
+ depends = libx11
+ provides = xenia
+ conflicts = xenia
+ source = git+https://github.com/benvanik/xenia.git
+ source = git+https://github.com/benvanik/binutils-ppc-cygwin
+ source = git+https://github.com/xenia-project/capstone.git
+ source = git+https://github.com/catchorg/Catch2
+ source = git+https://github.com/benvanik/gflags.git
+ source = git+https://github.com/ocornut/imgui.git
+ source = git+https://github.com/xenia-project/libav.git
+ source = git+https://github.com/xenia-project/premake-core.git
+ source = git+https://github.com/xenia-project/premake-export-compile-commands.git
+ source = git+https://github.com/xenia-project/snappy.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers
+ source = git+https://github.com/xenia-project/SPIRV-Tools.git
+ source = git+https://github.com/xenia-project/xbyak.git
+ source = git+https://github.com/jbeder/yaml-cpp.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = xenia-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..60e614546d8f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+src/
+pkg/
+
+xenia/
+Catch2/
+SPIRV-Headers/
+SPIRV-Tools/
+binutils-ppc-cygwin/
+capstone/
+gflags/
+imgui/
+libav/
+premake-core/
+premake-export-compile-commands/
+snappy/
+xbyak/
+yaml-cpp/
+
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3b51f7fe448
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+pkgname=xenia-git
+pkgver=r4124.5477b1e4
+pkgrel=1
+pkgdesc="Xenia is an experimental emulator for the Xbox 360."
+arch=('x86_64')
+url="http://xenia.jp"
+license=('BSD')
+depends=('gtk3' 'lz4' 'glew' 'libx11' )
+# TODO use installed premake5 instead of building it
+# premake: powerpc patch added
+makedepends=('python' 'clang' 'vulkan-headers' 'git' 'clang' 'libc++abi')
+provides=('xenia')
+conflicts=('xenia')
+# TODO: Use system installed deps for non-forked libs
+source=("git+https://github.com/benvanik/xenia.git"
+ "git+https://github.com/benvanik/binutils-ppc-cygwin"
+ "git+https://github.com/xenia-project/capstone.git"
+ "git+https://github.com/catchorg/Catch2" # catch-git
+ "git+https://github.com/benvanik/gflags.git"
+ "git+https://github.com/ocornut/imgui.git"
+ "git+https://github.com/xenia-project/libav.git"
+ "git+https://github.com/xenia-project/premake-core.git"
+ "git+https://github.com/xenia-project/premake-export-compile-commands.git"
+ "git+https://github.com/xenia-project/snappy.git"
+ "git+https://github.com/KhronosGroup/SPIRV-Headers" # spirv-headers or glslang
+ "git+https://github.com/xenia-project/SPIRV-Tools.git"
+ "git+https://github.com/xenia-project/xbyak.git"
+ "git+https://github.com/jbeder/yaml-cpp.git") # yaml-cpp
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+ git submodule init
+ git config submodule.third_party/binutils-ppc-cygwin.url $srcdir/binutils-ppc-cygwin
+ git config submodule.third_party/capstone.url $srcdir/capstone
+ git config submodule.third_party/catch.url $srcdir/Catch2
+ git config submodule.third_party/gflags.url $srcdir/gflags
+ git config submodule.third_party/imgui.url $srcdir/imgui
+ git config submodule.third_party/libav.url $srcdir/libav
+ git config submodule.third_party/premake-core.url $srcdir/premake-core
+ git config submodule.third_party/premake-export-compile-commands.url $srcdir/premake-export-compile-commands
+ git config submodule.third_party/snappy.url $srcdir/snappy
+ git config submodule.third_party/spirv-headers.url $srcdir/SPIRV-Headers
+ git config submodule.third_party/spirv-tools.url $srcdir/SPIRV-Tools
+ git config submodule.third_party/xbyak.url $srcdir/xbyak
+ git config submodule.third_party/yaml-cpp.url $srcdir/yaml-cpp
+ git submodule update
+
+ # FIXME: Currently the default /etc/makepkg.conf treat unused
+ # results as warnings which causes build to fail
+ sed -i 's,"FatalWarnings",--"FatalWarnings",g' premake5.lua
+
+ # Manual submodule assign should make this line unnecessary
+ # If package fails, it might be due to new submodule added
+ # In that case, this line should be able to fetch it
+ # python xenia-build setup
+}
+
+# FIXME: Currently xenia does not compile on linux with the
+# default /etc/makepkg.conf LDFLAGS, particularily --as-needed
+LDFLAGS="-Wl,-O1,--sort-common,-z,relro,-z,now"
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ CC=clang CXX=clang++ python xenia-build premake
+ CC=clang CXX=clang++ python xenia-build build --no_premake
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+
+ install -m755 -d ${pkgdir}/usr/bin
+ install -m755 build/bin/Linux/Debug/* ${pkgdir}/usr/bin
+ rm ${pkgdir}/usr/bin/*.a
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: