summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTailRed2018-09-09 16:35:48 +0100
committerTailRed2018-09-09 16:35:48 +0100
commitecc6630bd716dd04f4b8e86beaae090a552450e9 (patch)
tree9f25f681f91fa876ae036c40b235c2de45f6d6a0
parentb48387c62f4cb564d40dea1d329399f6afd1944e (diff)
downloadaur-ecc6630bd716dd04f4b8e86beaae090a552450e9.tar.gz
Update pkgbuild to reflect new repository structure
-rw-r--r--PKGBUILD61
-rw-r--r--xenlism-wildfire.install26
2 files changed, 43 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f86da06388d..31709b7acd0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,40 @@
-# Maintainer: Nattapong Pullkhow <exenatt at gmail dot com>
-# Contributor: Nattapong Pullkhow <exenatt at gmail dot com>
-# Updated for AUR by Robbie <zoqaeski at gmail dot com>
+# Maintainer: TailRed <callum at twintailsare dot moe>
+# Maintainer (Original package): Nattapong Pullkhow <ixenatt at gmail dot com>
+# Contributor: Nattapong Pullkhow <ixenatt at gmail dot com>
+# Contributor: Robbie <zoqaeski at gmail dot com>
pkgname=xenlism-wildfire-icon-theme-git
-_pkgname=xenlism-wildfire-icon-theme
-pkgver=146.39d6443
+_themename=wildfire
+pkgver=2018.05beta1.r26.g77c43c2
pkgrel=1
-pkgdesc="Minimalism And Realism Mix and match, Meego And iOS icon Style"
-url="https://xenlism.github.io/wildfire"
depends=('gtk-update-icon-cache')
makedepends=('git')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-replaces=("${_pkgname}")
-arch=('any')
-license=('GPL')
-source=(${_pkgname}::'git+https://github.com/xenlism/wildfire.git')
+pkgdesc="Minimalism And Realism Mix and match, Meego And iOS icon Style"
+url="https://xenlism.github.io/wildfire"
+arch=("any")
+license=('GPL3')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=("${pkgname}")
install=xenlism-wildfire.install
-sha256sums=('SKIP')
+source=(${pkgname}'::git+https://github.com/xenlism/wildfire.git')
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
pkgver() {
- cd ${srcdir}/${_pkgname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+# Git, no tags available
+ cd ${srcdir}/${pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- install -dm755 "${pkgdir}/usr/share/icons"
- cd "${srcdir}/${_pkgname}/icons/"
- cp -r * "${pkgdir}/usr/share/icons/";
- find "${pkgdir}/usr/share/icons" -type d -exec chmod 755 '{}' \;
- find "${pkgdir}/usr/share/icons" -type f -exec chmod 644 '{}' \;
- install -dm755 "${pkgdir}/usr/share/backgrounds/gnome/"
- cd "${srcdir}/${_pkgname}/wallpapers/";
- install -dm755 "${pkgdir}/usr/share/backgrounds/xenlism/";
- cp -r * "${pkgdir}/usr/share/backgrounds/xenlism/";
- find "${pkgdir}/usr/share/backgrounds/xenlism/" -type d -exec chmod 755 '{}' \;
- find "${pkgdir}/usr/share/backgrounds/xenlism/" -type f -exec chmod 644 '{}' \;
- cd "${srcdir}/${_pkgname}/background-properties/";
- install -dm755 "${pkgdir}/usr/share/gnome-background-properties/";
- cp -r * "${pkgdir}/usr/share/gnome-background-properties/";
- find "${pkgdir}/usr/share/gnome-background-properties/" -type d -exec chmod 755 '{}' \;
- find "${pkgdir}/usr/share/gnome-background-properties/" -type f -exec chmod 644 '{}' \;
+ cd "$srcdir/$pkgname"
+ install -d "${pkgdir}/usr/share/icons/"
+ cp -r icons $pkgdir/usr/share/
+ find "${pkgdir}/usr/share/icons" -type d -exec chmod 755 '{}' \;
+ find "${pkgdir}/usr/share/icons" -type f -exec chmod 644 '{}' \;
+ #Install License
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/Xenlism-Widfire/LICENSE"
}
-
diff --git a/xenlism-wildfire.install b/xenlism-wildfire.install
index 1f610e7f6753..da6961d9faec 100644
--- a/xenlism-wildfire.install
+++ b/xenlism-wildfire.install
@@ -1,15 +1,19 @@
post_install() {
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-Day
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-FriDay
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-MidNight
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-MonDay
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-Night
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-SaturDay
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-SunDay
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-ThursDay
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-TuesDay
- gtk-update-icon-cache -q -t -f /usr/share/icons/Xenlism-Wildfire-WednesDay
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-FriDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-FriDay-Night'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-MonDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-MonDay-Night'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-SaturDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-SaturDay-Night'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-SunDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-SunDay-Night'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-ThursDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-ThursDay-Night'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-TuesDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-TuesDay-Night'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-WednesDay'
+ gtk-update-icon-cache -f '/usr/share/icons/Xenlism-Wildfire-WednesDay-Night'
}