summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2019-12-07 12:18:42 +0100
committermorguldir2019-12-07 12:18:42 +0100
commit04320c4280bd20a537ad503cecccf0295a0c5d3d (patch)
treeb88479201c11734102ce0825c67c6ccb4827f13a
parente03defef3de904b8a64dc55e7b10ca6451b874ef (diff)
downloadaur-04320c4280bd20a537ad503cecccf0295a0c5d3d.tar.gz
Bump version to 0.6.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--icons.patch52
-rw-r--r--resizable.patch53
4 files changed, 7 insertions, 122 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f79c240ab4c..3c923565fe54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xenontrade
pkgdesc = Path of Exile trading overlay
- pkgver = 0.6.3
- pkgrel = 3
+ pkgver = 0.6.7
+ pkgrel = 1
url = https://github.com/klayveR/xenontrade
arch = x86_64
license = MIT
@@ -16,14 +16,10 @@ pkgbase = xenontrade
depends = nss
depends = wmctrl
provides = xenontrade
- source = git+https://github.com/und3rdg/xenontrade#tag=v0.6.3
+ source = git+https://github.com/und3rdg/xenontrade#tag=v0.6.7
source = xenontrade.sh
- source = resizable.patch
- source = icons.patch
sha256sums = SKIP
sha256sums = 4050ea55730e76bdd90ab183bf687f5a614ee6ea303556400bd803ab7d01a2e7
- sha256sums = d7903f0185ed41a5b6702b583f2c8858d7d650bf9052d24e561b8ba9d1b4a6c3
- sha256sums = 2fc1a8590778a68a8e436ae5d941ebdd694a71149752b2d6a700c9686956fd7f
pkgname = xenontrade
diff --git a/PKGBUILD b/PKGBUILD
index f01d82981fa3..e85c3ff31cad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: morguldir <morguldir@protonmail.com>
pkgname=xenontrade
-pkgver=0.6.3
-pkgrel=3
+pkgver=0.6.7
+pkgrel=1
pkgdesc='Path of Exile trading overlay'
arch=(x86_64)
license=(MIT)
@@ -11,19 +11,13 @@ depends=(gtk3 gdk-pixbuf2 libxtst nss wmctrl)
makedepends=(git node-gyp nodejs-lts-carbon python yarn)
provides=(xenontrade)
source=("git+https://github.com/und3rdg/xenontrade#tag=v$pkgver"
- "xenontrade.sh"
- "resizable.patch"
- "icons.patch")
+ "xenontrade.sh")
sha256sums=('SKIP'
- '4050ea55730e76bdd90ab183bf687f5a614ee6ea303556400bd803ab7d01a2e7'
- 'd7903f0185ed41a5b6702b583f2c8858d7d650bf9052d24e561b8ba9d1b4a6c3'
- '2fc1a8590778a68a8e436ae5d941ebdd694a71149752b2d6a700c9686956fd7f')
+ '4050ea55730e76bdd90ab183bf687f5a614ee6ea303556400bd803ab7d01a2e7')
prepare()
{
cd "$srcdir/$pkgname"
- git apply "$srcdir"/resizable.patch
- git apply "$srcdir"/icons.patch
yarn install
}
diff --git a/icons.patch b/icons.patch
deleted file mode 100644
index e2fd01daa2f2..000000000000
--- a/icons.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From ca50fb74a0dfe07e470514ce627745f608311d11 Mon Sep 17 00:00:00 2001
-From: morguldir <morguldir@protonmail.com>
-Date: Sun, 3 Nov 2019 04:35:37 +0100
-Subject: [PATCH] Add icons for hideout, buy, and logout
-
----
- src/index.html | 18 ++++++++----------
- 1 file changed, 8 insertions(+), 10 deletions(-)
-
-diff --git a/src/index.html b/src/index.html
-index ea5144c..8ba2ed5 100644
---- a/src/index.html
-+++ b/src/index.html
-@@ -15,13 +15,11 @@
- <div class="left">
- <div class="button" data-button="settings">
- <i class="fas fa-cog grey"
-- title="Settings"
-- ></i>
-+ title="Settings"></i>
- </div>
- <div class="button" data-button="update">
- <i class="fas fa-sync-alt grey"
-- title="Update prices on poe.ninja"
-- ></i>
-+ title="Update prices on poe.ninja"></i>
- </div>
- <div class="button" data-button="close-all">
- <i class="fas fa-times-circle grey"
-@@ -34,16 +32,16 @@
- </div>
- <div class="middle">
- <div class="button" data-button="buy">
-- <i class="fas fa-buy grey"
-- title="Paste clipboard content to game chat." >🛒</i>
-+ <i class="fas fa-shopping-cart grey"
-+ title="Paste clipboard content to game chat."></i>
- </div>
- <div class="button" data-button="hideout">
-- <i class="fas fa-hideout grey"
-- title="Go back to your hideout." >🏕</i>
-+ <i class="fas fa-home grey"
-+ title="Go back to your hideout."></i>
- </div>
- <div class="button" data-button="logout">
-- <i class="fas fa-logout red"
-- title="Emergency! Go back to character screen." >🛑</i>
-+ <i class="fas fa-sign-out-alt red"
-+ title="Emergency! Go back to character screen."></i>
- </div>
- </div>
- <div class="right">
diff --git a/resizable.patch b/resizable.patch
deleted file mode 100644
index 87740cc189e4..000000000000
--- a/resizable.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 1b9c595b86b122c51efc29c21cd2ca805c7503d1 Mon Sep 17 00:00:00 2001
-From: morguldir <morguldir@protonmail.com>
-Date: Sat, 2 Nov 2019 21:33:32 +0100
-Subject: [PATCH 1/2] Set resizable to false again
-
-It already is resizable by using the scale factor, and it messes
-up my i3wm system because then it automatically changes the
-size to fit with the other windows. It also doesn't actually resize.
-I assume this is the reason it was put there in the first place.
-
-I'm guessing this was put here to scale to a full
-monitor, which should be further looked at.
----
- src/main.js | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main.js b/src/main.js
-index c5a5739..6a55ea5 100644
---- a/src/main.js
-+++ b/src/main.js
-@@ -36,7 +36,7 @@ function createWindow() {
- 'show': false,
- 'transparent': true,
- 'maximizable': false,
-- 'resizable': true,
-+ 'resizable': false,
- 'fullscreenable': false,
- 'alwaysOnTop': true
- });
-
-From cfde457957d149e7d230d29efd594d57ba54ecac Mon Sep 17 00:00:00 2001
-From: morguldir <morguldir@protonmail.com>
-Date: Mon, 4 Nov 2019 21:45:06 +0100
-Subject: [PATCH 2/2] Use setContentSize() instead of setSize() when resizing
-
-setContentSize() still works when resizable is false
----
- src/main.js | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main.js b/src/main.js
-index 6a55ea5..329c128 100644
---- a/src/main.js
-+++ b/src/main.js
-@@ -148,7 +148,7 @@ ipcMain.on("resize", function (ev, width, height) {
- let windowPosition = win.getPosition();
-
- // Set new window size
-- win.setSize(Math.round(width), Math.round(height));
-+ win.setContentSize(Math.round(width), Math.round(height));
-
- // Apply previous position again to fix up- and downwards resize on some Linux distros
- if(os.platform() === "linux") {