summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2019-11-04 23:01:40 +0100
committermorguldir2019-11-04 23:03:04 +0100
commite03defef3de904b8a64dc55e7b10ca6451b874ef (patch)
treea50c86fff4db20b5a51f740330a6bcb785e97fa0
parentd578bbe0cd78479ce1ab415faafd1e4f2144dcf6 (diff)
downloadaur-e03defef3de904b8a64dc55e7b10ca6451b874ef.tar.gz
Add patch for icons and fix window using more space than it needs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--icons.patch52
-rw-r--r--resizable.patch26
4 files changed, 87 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20b23065b64d..4f79c240ab4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xenontrade
pkgdesc = Path of Exile trading overlay
pkgver = 0.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/klayveR/xenontrade
arch = x86_64
license = MIT
@@ -19,9 +19,11 @@ pkgbase = xenontrade
source = git+https://github.com/und3rdg/xenontrade#tag=v0.6.3
source = xenontrade.sh
source = resizable.patch
+ source = icons.patch
sha256sums = SKIP
sha256sums = 4050ea55730e76bdd90ab183bf687f5a614ee6ea303556400bd803ab7d01a2e7
- sha256sums = f0f3c36f24181723fa612b6f937adb46a305b1187797cd14c4bb302a52d83289
+ sha256sums = d7903f0185ed41a5b6702b583f2c8858d7d650bf9052d24e561b8ba9d1b4a6c3
+ sha256sums = 2fc1a8590778a68a8e436ae5d941ebdd694a71149752b2d6a700c9686956fd7f
pkgname = xenontrade
diff --git a/PKGBUILD b/PKGBUILD
index 162d1a2e0089..f01d82981fa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xenontrade
pkgver=0.6.3
-pkgrel=2
+pkgrel=3
pkgdesc='Path of Exile trading overlay'
arch=(x86_64)
license=(MIT)
@@ -12,15 +12,18 @@ makedepends=(git node-gyp nodejs-lts-carbon python yarn)
provides=(xenontrade)
source=("git+https://github.com/und3rdg/xenontrade#tag=v$pkgver"
"xenontrade.sh"
- "resizable.patch")
+ "resizable.patch"
+ "icons.patch")
sha256sums=('SKIP'
'4050ea55730e76bdd90ab183bf687f5a614ee6ea303556400bd803ab7d01a2e7'
- 'f0f3c36f24181723fa612b6f937adb46a305b1187797cd14c4bb302a52d83289')
+ 'd7903f0185ed41a5b6702b583f2c8858d7d650bf9052d24e561b8ba9d1b4a6c3'
+ '2fc1a8590778a68a8e436ae5d941ebdd694a71149752b2d6a700c9686956fd7f')
prepare()
{
cd "$srcdir/$pkgname"
git apply "$srcdir"/resizable.patch
+ git apply "$srcdir"/icons.patch
yarn install
}
diff --git a/icons.patch b/icons.patch
new file mode 100644
index 000000000000..e2fd01daa2f2
--- /dev/null
+++ b/icons.patch
@@ -0,0 +1,52 @@
+From ca50fb74a0dfe07e470514ce627745f608311d11 Mon Sep 17 00:00:00 2001
+From: morguldir <morguldir@protonmail.com>
+Date: Sun, 3 Nov 2019 04:35:37 +0100
+Subject: [PATCH] Add icons for hideout, buy, and logout
+
+---
+ src/index.html | 18 ++++++++----------
+ 1 file changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/src/index.html b/src/index.html
+index ea5144c..8ba2ed5 100644
+--- a/src/index.html
++++ b/src/index.html
+@@ -15,13 +15,11 @@
+ <div class="left">
+ <div class="button" data-button="settings">
+ <i class="fas fa-cog grey"
+- title="Settings"
+- ></i>
++ title="Settings"></i>
+ </div>
+ <div class="button" data-button="update">
+ <i class="fas fa-sync-alt grey"
+- title="Update prices on poe.ninja"
+- ></i>
++ title="Update prices on poe.ninja"></i>
+ </div>
+ <div class="button" data-button="close-all">
+ <i class="fas fa-times-circle grey"
+@@ -34,16 +32,16 @@
+ </div>
+ <div class="middle">
+ <div class="button" data-button="buy">
+- <i class="fas fa-buy grey"
+- title="Paste clipboard content to game chat." >🛒</i>
++ <i class="fas fa-shopping-cart grey"
++ title="Paste clipboard content to game chat."></i>
+ </div>
+ <div class="button" data-button="hideout">
+- <i class="fas fa-hideout grey"
+- title="Go back to your hideout." >🏕</i>
++ <i class="fas fa-home grey"
++ title="Go back to your hideout."></i>
+ </div>
+ <div class="button" data-button="logout">
+- <i class="fas fa-logout red"
+- title="Emergency! Go back to character screen." >🛑</i>
++ <i class="fas fa-sign-out-alt red"
++ title="Emergency! Go back to character screen."></i>
+ </div>
+ </div>
+ <div class="right">
diff --git a/resizable.patch b/resizable.patch
index caee605aca35..87740cc189e4 100644
--- a/resizable.patch
+++ b/resizable.patch
@@ -1,7 +1,7 @@
From 1b9c595b86b122c51efc29c21cd2ca805c7503d1 Mon Sep 17 00:00:00 2001
From: morguldir <morguldir@protonmail.com>
Date: Sat, 2 Nov 2019 21:33:32 +0100
-Subject: [PATCH] Set resizable to false again
+Subject: [PATCH 1/2] Set resizable to false again
It already is resizable by using the scale factor, and it messes
up my i3wm system because then it automatically changes the
@@ -27,3 +27,27 @@ index c5a5739..6a55ea5 100644
'fullscreenable': false,
'alwaysOnTop': true
});
+
+From cfde457957d149e7d230d29efd594d57ba54ecac Mon Sep 17 00:00:00 2001
+From: morguldir <morguldir@protonmail.com>
+Date: Mon, 4 Nov 2019 21:45:06 +0100
+Subject: [PATCH 2/2] Use setContentSize() instead of setSize() when resizing
+
+setContentSize() still works when resizable is false
+---
+ src/main.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/main.js b/src/main.js
+index 6a55ea5..329c128 100644
+--- a/src/main.js
++++ b/src/main.js
+@@ -148,7 +148,7 @@ ipcMain.on("resize", function (ev, width, height) {
+ let windowPosition = win.getPosition();
+
+ // Set new window size
+- win.setSize(Math.round(width), Math.round(height));
++ win.setContentSize(Math.round(width), Math.round(height));
+
+ // Apply previous position again to fix up- and downwards resize on some Linux distros
+ if(os.platform() === "linux") {