summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuero2023-07-24 06:55:31 +0000
committerfuero2023-07-24 06:55:31 +0000
commitb531f40f01b1e197a17e12441cbb990411c8101a (patch)
tree5f16b3af52d971cb04ca7815ab87a01789c86907
downloadaur-b531f40f01b1e197a17e12441cbb990411c8101a.tar.gz
Make unit test completion optional
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD38
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f55ad34325ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xeol
+ pkgdesc = An End Of Life (EOL) package scannner for container images and filesystems.
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://github.com/noqcks/xeol
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = go
+ makedepends = podman-docker
+ options = !lto
+ source = xeol-v0.4.3.tar.gz::https://github.com/noqcks/xeol/archive/refs/tags/v0.4.3.tar.gz
+ sha256sums = d913c460a2b5180223a3512da3880c32b7f4c0e613caa3a8e163bf756d2ab395
+
+pkgname = xeol
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..509d8709b797
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.toptal.com/developers/gitignore/api/archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.toptal.com/developers/gitignore/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b26129e1bd97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Fuero <fuerob@gmail.com>
+pkgname=xeol
+# renovate: datasource=github-releases depName=noqcks/xeol
+pkgver=0.4.3
+_pkgver=v${pkgver}
+pkgrel=1
+pkgdesc='An End Of Life (EOL) package scannner for container images and filesystems.'
+arch=(x86_64)
+url='https://github.com/noqcks/xeol'
+license=(APACHE)
+makedepends=(git go podman-docker)
+options=('!lto')
+source=("${pkgname}-${_pkgver}.tar.gz::${url}/archive/refs/tags/${_pkgver}.tar.gz")
+sha256sums=('d913c460a2b5180223a3512da3880c32b7f4c0e613caa3a8e163bf756d2ab395')
+options=('!lto')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ make VERSION=$pkgver xeol
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # Dies on building inside a container. Beware!
+ make unit || true
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 "${pkgname}/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}