summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-09-20 01:35:11 -0700
committerxiota2023-09-20 01:35:11 -0700
commite1f0b64ebc2a7bc02d294d71ccafa1635f863ad9 (patch)
treed9072388daca9d0540f02b70ca7c42b59a8fb09f
parentcad4d74d53e0d61f94b271de221671fcb9e30d2d (diff)
downloadaur-e1f0b64ebc2a7bc02d294d71ccafa1635f863ad9.tar.gz
remove replaces directive
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b277c20ede70..e9cfa65c4b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,17 +4,15 @@ pkgbase = xerces2-java
pkgrel = 1
url = https://xml.apache.org/xerces2-j
arch = any
- license = APACHE
+ license = Apache
depends = java-runtime
depends = java-resolver
provides = java-xerces2=2.12.2
conflicts = java-xerces2
- replaces = java-xerces2
source = https://dlcdn.apache.org/xerces/j/binaries/Xerces-J-bin.2.12.2.tar.gz
source = https://dlcdn.apache.org/xerces/j/binaries/Xerces-J-bin.2.12.2.tar.gz.asc
validpgpkeys = 4D8FB572FB6ADCFD69CBFE0D7B2586A6B5E25C3D
- sha512sums = de3a32258a53a044bf6dcf4f63553be588face141e018fd49b41b91013f941208714b7e21cdba419bd69166ef949253fad1ec937cb84b13a815fe66b91154c38
- sha512sums = SKIP
+ sha256sums = 1ad48949b2c7f0df91668f058d6ec773871adb5527b0b5c73dc2160ab5d162e2
+ sha256sums = SKIP
pkgname = xerces2-java
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index d7d5e8128585..aa03e9bcfcfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+# Maintainer: xiota / aur.chaotic.cx
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Guillaume ALAUX <guillaume@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=xerces2-java
+_pkgname="xerces2-java"
+pkgname="$_pkgname"
pkgver=2.12.2
pkgrel=1
pkgdesc="High performance fully compliant Java XML parser"
arch=('any')
url="https://xml.apache.org/xerces2-j"
-license=('APACHE')
+license=('Apache')
+
depends=('java-runtime' 'java-resolver')
+
provides=("java-xerces2=${pkgver}")
conflicts=('java-xerces2')
-replaces=('java-xerces2')
-source=(https://dlcdn.apache.org/xerces/j/binaries/Xerces-J-bin.$pkgver.tar.gz{,.asc})
-sha512sums=('de3a32258a53a044bf6dcf4f63553be588face141e018fd49b41b91013f941208714b7e21cdba419bd69166ef949253fad1ec937cb84b13a815fe66b91154c38'
- 'SKIP')
+
+source=(
+ https://dlcdn.apache.org/xerces/j/binaries/Xerces-J-bin.$pkgver.tar.gz{,.asc}
+)
+sha256sums=(
+ '1ad48949b2c7f0df91668f058d6ec773871adb5527b0b5c73dc2160ab5d162e2'
+ 'SKIP'
+)
validpgpkeys=('4D8FB572FB6ADCFD69CBFE0D7B2586A6B5E25C3D') # Mukul Gandhi (CODE SIGNING KEY) <mukulg@apache.org>
package() {