summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Bodi2017-06-22 14:39:41 +0900
committerGuillaume Bodi2017-06-22 14:39:41 +0900
commit000019348a03b123abdd98f2848ef209d7557b02 (patch)
tree6e27d562e4a9d4d832097d98b23987b63e487b65
downloadaur-000019348a03b123abdd98f2848ef209d7557b02.tar.gz
Initial release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..910fa72a7a0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xerox-docucentre-driver
+ pkgdesc = Driver for the Fuji-Xerox DocuCentre series. Also supports ApeosPort and DocuPrint series.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.fujixerox.co.jp/download/docuprint/download/p450d/linux64/
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ depends = cups
+ source = http://download.fujixerox.co.jp/pub/exe/docuprint/p450d/fxlinuxprint-1.1.2-1.x86_64.rpm
+ md5sums = 79ec7134ec48d839b916b654331d53ca
+
+pkgname = xerox-docucentre-driver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78916ae95159
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Guillaume Bodi <bodi.giyomu at gmail.com>
+
+pkgname=xerox-docucentre-driver
+pkgver=1.0
+_pkgver=1.1.2-1
+pkgrel=1
+pkgdesc="Driver for the Fuji-Xerox DocuCentre series. Also supports ApeosPort and DocuPrint series."
+url="https://www.fujixerox.co.jp/download/docuprint/download/p450d/linux64/"
+license=('custom')
+arch=('x86_64')
+depends=(cups)
+makedepends=('rpmextract')
+source=(http://download.fujixerox.co.jp/pub/exe/docuprint/p450d/fxlinuxprint-${_pkgver}.x86_64.rpm)
+md5sums=('79ec7134ec48d839b916b654331d53ca')
+
+package() {
+ cd "${srcdir}"
+ rpmextract.sh fxlinuxprint-${_pkgver}.x86_64.rpm
+
+ rm -rf "${srcdir}"/usr/lib64
+ cp -R "${srcdir}"/usr "${pkgdir}"
+}
+
+