summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-12-05 00:05:45 +0100
committerFabioLolix2018-12-05 00:05:45 +0100
commite8d6662b5127d3fa75bdf4772db00d4897e0bdc9 (patch)
treed14663e9caf73472d010e1ad6a2ac7c54707d92c
parent1af3a43b01b4984cdebde52c06f34636b5687254 (diff)
downloadaur-e8d6662b5127d3fa75bdf4772db00d4897e0bdc9.tar.gz
Revision
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 22 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1a052a0d767..b5b300ca124c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = xerox-phaser-6000-6010
pkgdesc = Driver for Xerox Phaser 6000/6010 color laser printer
- pkgver = 1.01
- pkgrel = 3
+ pkgver = 1.01_20110222
+ pkgrel = 1
url = http://www.support.xerox.com/support/phaser-6000/downloads/engb.html?operatingSystem=linux&fileLanguage=en_GB
arch = i686
arch = x86_64
license = custom:"XeroxEULA"
- makedepends = rpmextract
- makedepends = libtool
- makedepends = dialog
depends = cups
- source = 6000_6010_rpm_1.01_20110222.zip::http://www.support.xerox.com/support/phaser-6000/file-redirect/enus.html?operatingSystem=linux&fileLanguage=en&contentId=116070
+ source = xerox-phaser-6000-6010-1.01_20110222.zip::http://www.support.xerox.com/support/phaser-6000/file-redirect/enus.html?operatingSystem=linux&fileLanguage=en&contentId=116070
md5sums = f19dfec3afec150b797b773bbbe0eefe
+ depends_i686 = libcups
+ depends_i686 = libstdc++5
+ depends_i686 = libtiff
+ depends_i686 = libpng
+ depends_x86_64 = lib32-libcups
+ depends_x86_64 = lib32-libstdc++5
+ depends_x86_64 = lib32-libtiff
+ depends_x86_64 = lib32-libpng
pkgname = xerox-phaser-6000-6010
diff --git a/PKGBUILD b/PKGBUILD
index 7d34e04f5716..1c957178b6d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,22 @@
-#Maintainer: Archydan <daniel at dragusanu dot net>
+#Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
+#Contributor: Archydan <daniel at dragusanu dot net>
#Contributor: Guglielmo De Concini <guglielmo dot deconcini at gmail dot com>
-_dirname=rpm_1.01_20110222
-_rpmname=Xerox-Phaser_6000_6010-1.0-1.i686.rpm
-
pkgname=xerox-phaser-6000-6010
-pkgver=1.01
-pkgrel=3
+pkgver=1.01_20110222
+pkgrel=1
pkgdesc="Driver for Xerox Phaser 6000/6010 color laser printer"
url="http://www.support.xerox.com/support/phaser-6000/downloads/engb.html?operatingSystem=linux&fileLanguage=en_GB"
license=('custom:"XeroxEULA"')
-arch=('i686' 'x86_64')
-depends=('cups')
-if test "$CARCH" == x86_64; then
- depends=("${depends}" lib32-libcups lib32-libstdc++5 lib32-libtiff lib32-libpng)
-fi
-if test "$CARCH" == i686; then
- depends=("${depends}" libcups libstdc++5 libtiff libpng)
-fi
-makedepends=('rpmextract' 'libtool' 'dialog')
-source=("6000_6010_rpm_1.01_20110222.zip::http://www.support.xerox.com/support/phaser-6000/file-redirect/enus.html?operatingSystem=linux&fileLanguage=en&contentId=116070")
+arch=(i686 x86_64)
+depends=(cups)
+depends_i686=(libcups libstdc++5 libtiff libpng)
+depends_x86_64=(lib32-libcups lib32-libstdc++5 lib32-libtiff lib32-libpng)
+source=("${pkgname}-${pkgver}.zip::http://www.support.xerox.com/support/phaser-6000/file-redirect/enus.html?operatingSystem=linux&fileLanguage=en&contentId=116070")
md5sums=('f19dfec3afec150b797b773bbbe0eefe')
-prepare() {
- dialog --title "End User License Agreement" --scrollbar --exit-label "Next"\
- --textbox ${startdir}/XeroxEULA \
- 200 100
-
-if dialog --title "EULA ACCEPTANCE" --yesno "Do you accept the End User License Agreement?" 5 50; then
- echo "You have accepted the EULA. Install continues..."
-else
- echo "You must accept the EULA to continue. Aborting!"
- rm -r ${srcdir}
- rm ${startdir}/6000_6010_rpm_1.01_20110222.zip
- exit
-fi
-}
-
-
-build() {
- cd ${srcdir}/${_dirname}
- rpmextract.sh ${_rpmname}
-}
-
package() {
- cd ${srcdir}/${_dirname}
- cp -r usr ${pkgdir}
+ cd "rpm_${pkgver}"
+ bsdtar -xf Xerox-Phaser_6000_6010-1.0-1.i686.rpm -C ${pkgdir}
install -D -m644 ${startdir}/XeroxEULA "${pkgdir}/usr/share/licenses/${pkgname}/XeroxEULA"
}