summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Gsänger2020-10-08 11:28:47 +0200
committerSebastian Gsänger2020-10-08 11:28:47 +0200
commit3313ddd22e2410f5c5d0283ae2007db73b9ef773 (patch)
tree670d9d8e124b6d044649058fd42f76555f7674ea
parent515eba2aec83a5dd5ffa3e3cfc7fca495fc2595f (diff)
downloadaur-3313ddd22e2410f5c5d0283ae2007db73b9ef773.tar.gz
fix dependencies
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD7
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74f5220670b9..ccf42ab3cfc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xeus-cling
pkgdesc = A C++ jupyter kernel based on xeus and cling
pkgver = 0.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jupyter-xeus/xeus-cling
arch = x86_64
license = BSD
@@ -12,6 +12,8 @@ pkgbase = xeus-cling
depends = jupyter
depends = jupyter-widgetsnbextension
depends = cling-dev
+ depends = pugixml
+ depends = cxxopts
source = https://github.com/jupyter-xeus/xeus-cling/archive/0.10.0.tar.gz
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 682335b7677c..d5d3efa5ee4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Sebastian Gsänger <sebastian_gsaenger@web.de>
pkgname=xeus-cling
pkgver=0.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="A C++ jupyter kernel based on xeus and cling"
arch=('x86_64')
url="https://github.com/jupyter-xeus/xeus-cling"
license=('BSD')
depends=('xtl' 'xproperty' 'xeus' 'nlohmann-json'
'jupyter' 'jupyter-widgetsnbextension'
- 'cling-dev')
+ 'cling-dev' 'pugixml' 'cxxopts')
makedepends=()
source=("https://github.com/jupyter-xeus/$pkgname/archive/$pkgver.tar.gz"
"0001-Rename-kernels.patch"
@@ -32,11 +32,10 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- mkdir build
+ mkdir -p build
cd build
cmake \
- -GNinja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DClang_DIR=/opt/cling/lib/cmake/clang \