summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchn2021-09-15 01:02:08 +0800
committerchn2021-09-15 01:02:08 +0800
commit5982d2f3e099575a30119da4fade1da71af79ca4 (patch)
treeb2051ec6bbb90c404e8f8ac67f7208666152ba31
parentaf750af049baa189921f1acec3c4a4995d638de8 (diff)
downloadaur-5982d2f3e099575a30119da4fade1da71af79ca4.tar.gz
update to 0.13.0
-rw-r--r--.SRCINFO9
-rw-r--r--0004-fix-build.patch47
-rw-r--r--PKGBUILD10
3 files changed, 58 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0413dcfa12d..a22b83c8f038 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xeus-cling
pkgdesc = A C++ jupyter kernel based on xeus and cling
- pkgver = 0.12.1
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/jupyter-xeus/xeus-cling
arch = x86_64
@@ -16,14 +16,15 @@ pkgbase = xeus-cling
depends = cling
depends = pugixml
depends = cxxopts
- source = https://github.com/jupyter-xeus/xeus-cling/archive/0.12.1.tar.gz
+ source = https://github.com/jupyter-xeus/xeus-cling/archive/0.13.0.tar.gz
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
source = 0003-put-config-file-at-etc.patch
- md5sums = 8831c891c059428b24148435d2305172
+ source = 0004-fix-build.patch
+ md5sums = 8d99920a167b1ca6b2ff4a3ef0bd1ded
md5sums = e03c81c3701e4f0dea249955051c2ddf
md5sums = 30e86ddf8e4996352eb456e12ec686bb
md5sums = fb1bf5fdaa53af1c010b9da9d29f63b6
+ md5sums = c492a7955f6bd8315fd8a100e2457744
pkgname = xeus-cling
-
diff --git a/0004-fix-build.patch b/0004-fix-build.patch
new file mode 100644
index 000000000000..922bfdc1f725
--- /dev/null
+++ b/0004-fix-build.patch
@@ -0,0 +1,47 @@
+# from https://github.com/jupyter-xeus/xeus-cling/issues/400
+diff -Naur xeus-cling-0.12.1.orig/src/xmagics/executable.cpp xeus-cling-0.12.1/src/xmagics/executable.cpp
+--- xeus-cling-0.12.1.orig/src/xmagics/executable.cpp 2021-03-16 14:48:10.000000000 +0000
++++ xeus-cling-0.12.1/src/xmagics/executable.cpp 2021-04-29 12:10:03.955599380 +0000
+@@ -131,7 +131,7 @@
+
+ // Generate relocations suitable for dynamic linking.
+ auto CodeGenOpts = CI->getCodeGenOpts();
+- CodeGenOpts.RelocationModel = "pic";
++ CodeGenOpts.RelocationModel = llvm::Reloc::PIC_;
+
+ // Enable debug information if requested.
+ if (EnableDebugInfo)
+@@ -187,7 +187,7 @@
+ llvm::sys::path::append(Compiler, "bin", "clang++");
+
+ // Construct arguments to linker command.
+- llvm::SmallVector<const char*, 16> Args;
++ llvm::SmallVector<llvm::StringRef, 16> Args;
+ Args.push_back(Compiler.c_str());
+ Args.push_back(ObjectFile.c_str());
+ for (auto& O : LinkerOptions)
+@@ -196,7 +196,7 @@
+ }
+ Args.push_back("-o");
+ Args.push_back(ExeFile.c_str());
+- Args.push_back(NULL);
++ // Args.push_back(NULL);
+
+ // Redirect output and error streams from linker.
+ llvm::SmallString<64> OutputFile, ErrorFile;
+@@ -207,11 +207,11 @@
+
+ llvm::StringRef OutputFileStr(OutputFile);
+ llvm::StringRef ErrorFileStr(ErrorFile);
+- const llvm::StringRef* Redirects[] = {nullptr, &OutputFileStr,
+- &ErrorFileStr};
+-
++ //const llvm::StringRef* Redirects[] = {nullptr, &OutputFileStr,
++ // &ErrorFileStr};
++ const clang::Optional<llvm::StringRef> Redirects[] = {llvm::NoneType::None, OutputFileStr, ErrorFileStr};
+ // Finally run the linker.
+- int ret = llvm::sys::ExecuteAndWait(Compiler, Args.data(), nullptr,
++ int ret = llvm::sys::ExecuteAndWait(Compiler, Args, llvm::NoneType::None,
+ Redirects);
+
+ // Read back output and error streams. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index f110a0cd0af9..afe6567c5d27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: chn <g897331845@gmail.com>
pkgname=xeus-cling
-pkgver=0.12.1
+pkgver=0.13.0
pkgrel=1
pkgdesc="A C++ jupyter kernel based on xeus and cling"
arch=('x86_64')
@@ -15,11 +15,13 @@ makedepends=('cmake' 'cppzmq')
source=("https://github.com/jupyter-xeus/$pkgname/archive/$pkgver.tar.gz"
"0001-Rename-kernels.patch"
"0002-Use-llvm-from-cling.patch"
- "0003-put-config-file-at-etc.patch")
-md5sums=('8831c891c059428b24148435d2305172'
+ "0003-put-config-file-at-etc.patch"
+ "0004-fix-build.patch")
+md5sums=('8d99920a167b1ca6b2ff4a3ef0bd1ded'
'e03c81c3701e4f0dea249955051c2ddf'
'30e86ddf8e4996352eb456e12ec686bb'
- 'fb1bf5fdaa53af1c010b9da9d29f63b6')
+ 'fb1bf5fdaa53af1c010b9da9d29f63b6'
+ 'c492a7955f6bd8315fd8a100e2457744')
prepare() {
cd "$pkgname-$pkgver"