summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchn2021-04-28 10:12:37 +0800
committerchn2021-04-28 10:12:55 +0800
commitaf750af049baa189921f1acec3c4a4995d638de8 (patch)
tree8e0cbf5b965a0b60e751739d1778e0f76e83ffc0
parentb563be0c1537c10e4fd52232d8ae98e9ed9823f8 (diff)
downloadaur-af750af049baa189921f1acec3c4a4995d638de8.tar.gz
0.12.1
-rw-r--r--.SRCINFO12
-rw-r--r--0003-put-config-file-at-etc.patch12
-rw-r--r--PKGBUILD24
3 files changed, 37 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ea50124582d..b0413dcfa12d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xeus-cling
pkgdesc = A C++ jupyter kernel based on xeus and cling
- pkgver = 0.10.0
- pkgrel = 3
+ pkgver = 0.12.1
+ pkgrel = 1
url = https://github.com/jupyter-xeus/xeus-cling
arch = x86_64
license = BSD
@@ -13,15 +13,17 @@ pkgbase = xeus-cling
depends = nlohmann-json
depends = jupyter
depends = jupyter-widgetsnbextension
- depends = cling-dev
+ depends = cling
depends = pugixml
depends = cxxopts
- source = https://github.com/jupyter-xeus/xeus-cling/archive/0.10.0.tar.gz
+ source = https://github.com/jupyter-xeus/xeus-cling/archive/0.12.1.tar.gz
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
- md5sums = f81624ee2777dacfa5507bd448c174b5
+ source = 0003-put-config-file-at-etc.patch
+ md5sums = 8831c891c059428b24148435d2305172
md5sums = e03c81c3701e4f0dea249955051c2ddf
md5sums = 30e86ddf8e4996352eb456e12ec686bb
+ md5sums = fb1bf5fdaa53af1c010b9da9d29f63b6
pkgname = xeus-cling
diff --git a/0003-put-config-file-at-etc.patch b/0003-put-config-file-at-etc.patch
new file mode 100644
index 000000000000..4f4b09a89baf
--- /dev/null
+++ b/0003-put-config-file-at-etc.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text xeus-cling-0.12.1/CMakeLists.txt xeus-cling-0.12.1-fixed/CMakeLists.txt
+--- xeus-cling-0.12.1/CMakeLists.txt 2021-03-16 22:48:10.000000000 +0800
++++ xeus-cling-0.12.1-fixed/CMakeLists.txt 2021-04-23 08:48:47.772221440 +0800
+@@ -371,7 +371,7 @@
+ # Configuration and data directories for jupyter and xeus-cling
+ set(XJUPYTER_DATA_DIR "share/jupyter" CACHE STRING "Jupyter data directory")
+ set(XEUS_CLING_DATA_DIR "share/xeus-cling" CACHE STRING "xeus-cling data directory")
+-set(XEUS_CLING_CONF_DIR "etc/xeus-cling" CACHE STRING "xeus-cling configuration directory")
++set(XEUS_CLING_CONF_DIR "../etc/xeus-cling" CACHE STRING "xeus-cling configuration directory")
+
+ # Install xcpp headers
+ install(FILES ${XCPP_HEADERS}
diff --git a/PKGBUILD b/PKGBUILD
index 2331444ff235..f110a0cd0af9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Maintainer: Sebastian Gsänger <sebastian_gsaenger@web.de>
+# Maintainer: chn <g897331845@gmail.com>
+
pkgname=xeus-cling
-pkgver=0.10.0
-pkgrel=3
+pkgver=0.12.1
+pkgrel=1
pkgdesc="A C++ jupyter kernel based on xeus and cling"
arch=('x86_64')
url="https://github.com/jupyter-xeus/xeus-cling"
license=('BSD')
depends=('xtl' 'xproperty' 'xeus' 'nlohmann-json'
'jupyter' 'jupyter-widgetsnbextension'
- 'cling-dev' 'pugixml' 'cxxopts')
+ 'cling' 'pugixml' 'cxxopts')
makedepends=('cmake' 'cppzmq')
source=("https://github.com/jupyter-xeus/$pkgname/archive/$pkgver.tar.gz"
"0001-Rename-kernels.patch"
- "0002-Use-llvm-from-cling.patch")
-md5sums=('f81624ee2777dacfa5507bd448c174b5'
+ "0002-Use-llvm-from-cling.patch"
+ "0003-put-config-file-at-etc.patch")
+md5sums=('8831c891c059428b24148435d2305172'
'e03c81c3701e4f0dea249955051c2ddf'
- '30e86ddf8e4996352eb456e12ec686bb')
+ '30e86ddf8e4996352eb456e12ec686bb'
+ 'fb1bf5fdaa53af1c010b9da9d29f63b6')
prepare() {
cd "$pkgname-$pkgver"
@@ -31,6 +35,14 @@ prepare() {
}
build() {
+
+ if [ -z $CPLUS_INCLUDE_PATH ]
+ then
+ export CPLUS_INCLUDE_PATH=/opt/cling/include
+ else
+ export CPLUS_INCLUDE_PATH=$CPLUS_INCLUDE_PATH:/opt/cling/include
+ fi
+
cd "$pkgname-$pkgver"
mkdir -p build
cd build