summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-07-21 21:28:50 -0500
committerCarlos Aznarán Laos2023-07-21 21:28:50 -0500
commitb9f64964e8c3375e90648d55bc704887a1545e51 (patch)
tree320fbaeb85b065b04ca55cd8e7a0171079b48436
parent86dc2d70a33b7901d50c923d2e4a30b331acd048 (diff)
downloadaur-b9f64964e8c3375e90648d55bc704887a1545e51.tar.gz
Bump version to 0.15.2
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Rename-kernels.patch36
-rw-r--r--0002-Use-llvm-from-cling.patch15
-rw-r--r--0003-put-config-file-at-etc.patch8
-rw-r--r--PKGBUILD15
5 files changed, 44 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 560616939137..0158b3a7a5e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xeus-cling
pkgdesc = A C++ jupyter kernel based on xeus and cling
- pkgver = 0.15.1
+ pkgver = 0.15.2
pkgrel = 1
url = https://github.com/jupyter-xeus/xeus-cling
arch = x86_64
@@ -11,18 +11,18 @@ pkgbase = xeus-cling
depends = xproperty
depends = xeus
depends = nlohmann-json
- depends = jupyter-widgetsnbextension
+ depends = jupyterlab
depends = cling
depends = pugixml
depends = argparse
depends = xeus-zmq
- source = xeus-cling-0.15.1.tar.gz::https://github.com/jupyter-xeus/xeus-cling/archive/0.15.1.tar.gz
+ source = xeus-cling-0.15.2.tar.gz::https://github.com/jupyter-xeus/xeus-cling/archive/0.15.2.tar.gz
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
source = 0003-put-config-file-at-etc.patch
- sha512sums = 25716e6313e71cbc1cb78657674658788ff2eb399aad5ad8f11da448dac6a5df3ef8cc26d7aa72f2ba2ac5ae001c6d901dc2a1552a12f35b9f801c8d6765f2b2
- sha512sums = 22286216ec59354374fa42245fc2b58c689f206a26da415bb2c922b6a79b466455a4f72ad013d1e56e30e0194de31c958ec787d411a141edc25c961cbdcd439a
- sha512sums = 2fa2258c80ed7a7785441f7e03a8f14fd4fe24dce7c1506c2c592dc6173fdf689e05565e7a0e841df7cdee93bd105e66f6ab49664ebb97f4bf52b312ddad6427
- sha512sums = b5249f0c68301d12ae8aaf347eb9bf26971fb90286597e813aa67bd4258a75eeac86f059638357b0fb63a9da583eeb63ddf24c49060e4c2f4a7890257ccd9b44
+ sha512sums = 7b444a83a6a4d35f4664133def2207976f2e8c903b773d8a42be3da6b0c2b88337adb3b93efd0dbeaa8aae267d1086f11fdeaa2ed3171061f50051a92130e636
+ sha512sums = 6f77266a0784afc7daeb5910dd18d3bfcfd65d71f746b9d3165cdfa7a0541e4f1bf1a243aea1063209d329643904636b9f92d7bc59b643adfda9b960d3e69dfc
+ sha512sums = 33040a9045c8c2f100c245ff3dffe41a3185d3ca94f332256bc6cd557c61282775023400a6a044825b664181e27b1e1cda1270491de41f65657c4a69d692784d
+ sha512sums = b672c421b0efc96e93063c399f75133016dfe3c4b33bf44c089ce451394435fa59c2b562e86f6fd7c546f1a562249f0a5c48f7446312f65426533c8c39b62382
pkgname = xeus-cling
diff --git a/0001-Rename-kernels.patch b/0001-Rename-kernels.patch
index b00b83d5abd6..438154801b50 100644
--- a/0001-Rename-kernels.patch
+++ b/0001-Rename-kernels.patch
@@ -1,30 +1,30 @@
-diff --unified --recursive --text xeus-cling-0.10.0/share/jupyter/kernels/xcpp11/kernel.json.in xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp11/kernel.json.in
---- xeus-cling-0.10.0/share/jupyter/kernels/xcpp11/kernel.json.in 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp11/kernel.json.in 2020-09-23 17:42:44.849674536 +0200
+diff --color --unified --recursive --text xeus-cling-0.15.2/share/jupyter/kernels/xcpp11/kernel.json.in ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp11/kernel.json.in
+--- xeus-cling-0.15.2/share/jupyter/kernels/xcpp11/kernel.json.in 2023-07-21 20:43:33.937264855 -0500
++++ ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp11/kernel.json.in 2023-07-12 10:01:11.000000000 -0500
@@ -1,5 +1,5 @@
{
-- "display_name": "C++11",
-+ "display_name": "C++11 (xeus)",
+- "display_name": "C++11 (xeus)",
++ "display_name": "C++11",
"argv": [
- "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/xcpp",
+ "@XEUS_CLING_KERNELSPEC_PATH@/xcpp",
"-f",
-diff --unified --recursive --text xeus-cling-0.10.0/share/jupyter/kernels/xcpp14/kernel.json.in xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp14/kernel.json.in
---- xeus-cling-0.10.0/share/jupyter/kernels/xcpp14/kernel.json.in 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp14/kernel.json.in 2020-09-23 17:42:54.722971891 +0200
+diff --color --unified --recursive --text xeus-cling-0.15.2/share/jupyter/kernels/xcpp14/kernel.json.in ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp14/kernel.json.in
+--- xeus-cling-0.15.2/share/jupyter/kernels/xcpp14/kernel.json.in 2023-07-21 20:43:44.530579755 -0500
++++ ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp14/kernel.json.in 2023-07-12 10:01:11.000000000 -0500
@@ -1,5 +1,5 @@
{
-- "display_name": "C++14",
-+ "display_name": "C++14 (xeus)",
+- "display_name": "C++14 (xeus)",
++ "display_name": "C++14",
"argv": [
- "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/xcpp",
+ "@XEUS_CLING_KERNELSPEC_PATH@/xcpp",
"-f",
-diff --unified --recursive --text xeus-cling-0.10.0/share/jupyter/kernels/xcpp17/kernel.json.in xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp17/kernel.json.in
---- xeus-cling-0.10.0/share/jupyter/kernels/xcpp17/kernel.json.in 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp17/kernel.json.in 2020-09-23 17:43:03.549606392 +0200
+diff --color --unified --recursive --text xeus-cling-0.15.2/share/jupyter/kernels/xcpp17/kernel.json.in ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp17/kernel.json.in
+--- xeus-cling-0.15.2/share/jupyter/kernels/xcpp17/kernel.json.in 2023-07-21 20:43:52.657232094 -0500
++++ ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp17/kernel.json.in 2023-07-12 10:01:11.000000000 -0500
@@ -1,5 +1,5 @@
{
-- "display_name": "C++17",
-+ "display_name": "C++17 (xeus)",
+- "display_name": "C++17 (xeus)",
++ "display_name": "C++17",
"argv": [
- "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/xcpp",
+ "@XEUS_CLING_KERNELSPEC_PATH@/xcpp",
"-f",
diff --git a/0002-Use-llvm-from-cling.patch b/0002-Use-llvm-from-cling.patch
index 7a2d45985063..b463fd81bc12 100644
--- a/0002-Use-llvm-from-cling.patch
+++ b/0002-Use-llvm-from-cling.patch
@@ -1,9 +1,10 @@
---- xeus-cling-0.15.0/CMakeLists.txt 2023-01-30 21:26:07.000000000 +0100
-+++ xeus-cling-0.15.0-fixed/CMakeLists.txt 2023-02-01 18:35:36.914901732 +0100
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/CMakeLists.txt xeus-cling-0.15.2/CMakeLists.txt
+--- ../xeus-cling-0.15.2-fixed/CMakeLists.txt 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/CMakeLists.txt 2023-07-21 21:05:07.308285729 -0500
@@ -50,59 +50,6 @@
"${CMAKE_CURRENT_SOURCE_DIR}/share/jupyter/kernels/xcpp17/kernel.json"
)
-
+
-#######################
-# Rely on llvm-config #
-#######################
@@ -63,20 +64,20 @@
@@ -112,8 +59,10 @@
find_package(xeus-zmq ${xeus-zmq_REQUIRED_VERSION} REQUIRED)
find_package(pugixml REQUIRED)
-
+
-find_package(Clang REQUIRED)
find_package(Cling REQUIRED)
+find_package(Clang REQUIRED)
+find_package(LLVM REQUIRED)
+add_definitions(-DLLVM_DIR="${LLVM_INSTALL_PREFIX}")
find_package(argparse REQUIRED)
-
+
#########
@@ -219,6 +168,7 @@
-
+
target_include_directories(xeus-cling
PUBLIC
-+ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
++ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
$<BUILD_INTERFACE:${XEUS_CLING_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include>)
target_link_libraries(xeus-cling PUBLIC clingInterpreter clingMetaProcessor clingUtils xeus-zmq pugixml argparse::argparse)
diff --git a/0003-put-config-file-at-etc.patch b/0003-put-config-file-at-etc.patch
index 4f4b09a89baf..cb15a306d621 100644
--- a/0003-put-config-file-at-etc.patch
+++ b/0003-put-config-file-at-etc.patch
@@ -1,7 +1,7 @@
-diff --unified --recursive --text xeus-cling-0.12.1/CMakeLists.txt xeus-cling-0.12.1-fixed/CMakeLists.txt
---- xeus-cling-0.12.1/CMakeLists.txt 2021-03-16 22:48:10.000000000 +0800
-+++ xeus-cling-0.12.1-fixed/CMakeLists.txt 2021-04-23 08:48:47.772221440 +0800
-@@ -371,7 +371,7 @@
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/CMakeLists.txt xeus-cling-0.15.2/CMakeLists.txt
+--- ../xeus-cling-0.15.2-fixed/CMakeLists.txt 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/CMakeLists.txt 2023-07-21 20:58:34.801675991 -0500
+@@ -364,7 +364,7 @@
# Configuration and data directories for jupyter and xeus-cling
set(XJUPYTER_DATA_DIR "share/jupyter" CACHE STRING "Jupyter data directory")
set(XEUS_CLING_DATA_DIR "share/xeus-cling" CACHE STRING "xeus-cling data directory")
diff --git a/PKGBUILD b/PKGBUILD
index 66cac474ba4b..4773cf215101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,22 @@
# Contributor: Gregor Kaelin <kaelingre at gmail dot com>
pkgname=xeus-cling
-pkgver=0.15.1
+pkgver=0.15.2
pkgrel=1
pkgdesc="A C++ jupyter kernel based on xeus and cling"
arch=('x86_64')
url="https://github.com/jupyter-xeus/${pkgname}"
license=('custom:BSD-3-clause')
-depends=(xtl xproperty xeus nlohmann-json jupyter-widgetsnbextension
- cling pugixml argparse xeus-zmq)
+depends=(xtl xproperty xeus nlohmann-json jupyterlab cling pugixml argparse xeus-zmq)
makedepends=(cmake cppzmq)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/jupyter-xeus/${pkgname}/archive/${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
"0001-Rename-kernels.patch"
"0002-Use-llvm-from-cling.patch"
"0003-put-config-file-at-etc.patch")
-sha512sums=('25716e6313e71cbc1cb78657674658788ff2eb399aad5ad8f11da448dac6a5df3ef8cc26d7aa72f2ba2ac5ae001c6d901dc2a1552a12f35b9f801c8d6765f2b2'
- '22286216ec59354374fa42245fc2b58c689f206a26da415bb2c922b6a79b466455a4f72ad013d1e56e30e0194de31c958ec787d411a141edc25c961cbdcd439a'
- '2fa2258c80ed7a7785441f7e03a8f14fd4fe24dce7c1506c2c592dc6173fdf689e05565e7a0e841df7cdee93bd105e66f6ab49664ebb97f4bf52b312ddad6427'
- 'b5249f0c68301d12ae8aaf347eb9bf26971fb90286597e813aa67bd4258a75eeac86f059638357b0fb63a9da583eeb63ddf24c49060e4c2f4a7890257ccd9b44')
+sha512sums=('7b444a83a6a4d35f4664133def2207976f2e8c903b773d8a42be3da6b0c2b88337adb3b93efd0dbeaa8aae267d1086f11fdeaa2ed3171061f50051a92130e636'
+ '6f77266a0784afc7daeb5910dd18d3bfcfd65d71f746b9d3165cdfa7a0541e4f1bf1a243aea1063209d329643904636b9f92d7bc59b643adfda9b960d3e69dfc'
+ '33040a9045c8c2f100c245ff3dffe41a3185d3ca94f332256bc6cd557c61282775023400a6a044825b664181e27b1e1cda1270491de41f65657c4a69d692784d'
+ 'b672c421b0efc96e93063c399f75133016dfe3c4b33bf44c089ce451394435fa59c2b562e86f6fd7c546f1a562249f0a5c48f7446312f65426533c8c39b62382')
prepare() {
cd ${pkgname}-${pkgver}