summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-19 11:11:15 -0500
committerCarlos Aznarán Laos2023-05-19 11:11:15 -0500
commitc5ee85b10c359d7cecd0e35da5cc7ee4acafb32b (patch)
treeeadc9d4531d215bdb749a2389d2f9fd428c482b1
parent1b85abbeab4fe5ec69aeb75c7ecb19511f28a26f (diff)
downloadaur-c5ee85b10c359d7cecd0e35da5cc7ee4acafb32b.tar.gz
Update patch
-rw-r--r--.SRCINFO4
-rw-r--r--0002-Use-llvm-from-cling.patch30
-rw-r--r--0004-fix-build.patch47
-rw-r--r--PKGBUILD8
4 files changed, 19 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87dd72bd53db..60424445f00b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,11 +20,9 @@ pkgbase = xeus-cling
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
source = 0003-put-config-file-at-etc.patch
- source = 0004-fix-build.patch
md5sums = 8d99920a167b1ca6b2ff4a3ef0bd1ded
md5sums = e03c81c3701e4f0dea249955051c2ddf
- md5sums = 30e86ddf8e4996352eb456e12ec686bb
+ md5sums = a5e1fb609303da1710a125e440f2c9a8
md5sums = fb1bf5fdaa53af1c010b9da9d29f63b6
- md5sums = c492a7955f6bd8315fd8a100e2457744
pkgname = xeus-cling
diff --git a/0002-Use-llvm-from-cling.patch b/0002-Use-llvm-from-cling.patch
index d23a03be7294..7a2d45985063 100644
--- a/0002-Use-llvm-from-cling.patch
+++ b/0002-Use-llvm-from-cling.patch
@@ -1,10 +1,9 @@
-diff --unified --recursive --text xeus-cling-0.10.0/CMakeLists.txt xeus-cling-0.10.0-fixed/CMakeLists.txt
---- xeus-cling-0.10.0/CMakeLists.txt 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/CMakeLists.txt 2020-09-23 17:00:45.525608638 +0200
-@@ -46,58 +46,6 @@
+--- xeus-cling-0.15.0/CMakeLists.txt 2023-01-30 21:26:07.000000000 +0100
++++ xeus-cling-0.15.0-fixed/CMakeLists.txt 2023-02-01 18:35:36.914901732 +0100
+@@ -50,59 +50,6 @@
"${CMAKE_CURRENT_SOURCE_DIR}/share/jupyter/kernels/xcpp17/kernel.json"
)
-
+
-#######################
-# Rely on llvm-config #
-#######################
@@ -57,26 +56,27 @@ diff --unified --recursive --text xeus-cling-0.10.0/CMakeLists.txt xeus-cling-0.
-include_directories(${LLVM_MAIN_INCLUDE_DIR})
-link_directories(${LLVM_LIBRARY_DIR})
-add_definitions(-DLLVM_DIR="${LLVM_BINARY_DIR}")
-
+-
################
# Dependencies #
-@@ -110,8 +58,10 @@
- find_package(cppzmq ${cppzmq_REQUIRED_VERSION} REQUIRED)
+ ################
+@@ -112,8 +59,10 @@
+ find_package(xeus-zmq ${xeus-zmq_REQUIRED_VERSION} REQUIRED)
find_package(pugixml REQUIRED)
-
+
-find_package(Clang REQUIRED)
find_package(Cling REQUIRED)
+find_package(Clang REQUIRED)
+find_package(LLVM REQUIRED)
+add_definitions(-DLLVM_DIR="${LLVM_INSTALL_PREFIX}")
- find_package(cxxopts REQUIRED)
-
+ find_package(argparse REQUIRED)
+
#########
-@@ -228,6 +178,7 @@
-
+@@ -219,6 +168,7 @@
+
target_include_directories(xeus-cling
PUBLIC
-+ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
++ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
$<BUILD_INTERFACE:${XEUS_CLING_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include>)
- target_link_libraries(xeus-cling PUBLIC clingInterpreter clingMetaProcessor clingUtils xeus pugixml cxxopts::cxxopts)
+ target_link_libraries(xeus-cling PUBLIC clingInterpreter clingMetaProcessor clingUtils xeus-zmq pugixml argparse::argparse)
diff --git a/0004-fix-build.patch b/0004-fix-build.patch
deleted file mode 100644
index 922bfdc1f725..000000000000
--- a/0004-fix-build.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-# from https://github.com/jupyter-xeus/xeus-cling/issues/400
-diff -Naur xeus-cling-0.12.1.orig/src/xmagics/executable.cpp xeus-cling-0.12.1/src/xmagics/executable.cpp
---- xeus-cling-0.12.1.orig/src/xmagics/executable.cpp 2021-03-16 14:48:10.000000000 +0000
-+++ xeus-cling-0.12.1/src/xmagics/executable.cpp 2021-04-29 12:10:03.955599380 +0000
-@@ -131,7 +131,7 @@
-
- // Generate relocations suitable for dynamic linking.
- auto CodeGenOpts = CI->getCodeGenOpts();
-- CodeGenOpts.RelocationModel = "pic";
-+ CodeGenOpts.RelocationModel = llvm::Reloc::PIC_;
-
- // Enable debug information if requested.
- if (EnableDebugInfo)
-@@ -187,7 +187,7 @@
- llvm::sys::path::append(Compiler, "bin", "clang++");
-
- // Construct arguments to linker command.
-- llvm::SmallVector<const char*, 16> Args;
-+ llvm::SmallVector<llvm::StringRef, 16> Args;
- Args.push_back(Compiler.c_str());
- Args.push_back(ObjectFile.c_str());
- for (auto& O : LinkerOptions)
-@@ -196,7 +196,7 @@
- }
- Args.push_back("-o");
- Args.push_back(ExeFile.c_str());
-- Args.push_back(NULL);
-+ // Args.push_back(NULL);
-
- // Redirect output and error streams from linker.
- llvm::SmallString<64> OutputFile, ErrorFile;
-@@ -207,11 +207,11 @@
-
- llvm::StringRef OutputFileStr(OutputFile);
- llvm::StringRef ErrorFileStr(ErrorFile);
-- const llvm::StringRef* Redirects[] = {nullptr, &OutputFileStr,
-- &ErrorFileStr};
--
-+ //const llvm::StringRef* Redirects[] = {nullptr, &OutputFileStr,
-+ // &ErrorFileStr};
-+ const clang::Optional<llvm::StringRef> Redirects[] = {llvm::NoneType::None, OutputFileStr, ErrorFileStr};
- // Finally run the linker.
-- int ret = llvm::sys::ExecuteAndWait(Compiler, Args.data(), nullptr,
-+ int ret = llvm::sys::ExecuteAndWait(Compiler, Args, llvm::NoneType::None,
- Redirects);
-
- // Read back output and error streams. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 11c5e568327a..ca7884824940 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,13 +15,11 @@ makedepends=('cmake' 'cppzmq')
source=("https://github.com/jupyter-xeus/$pkgname/archive/$pkgver.tar.gz"
"0001-Rename-kernels.patch"
"0002-Use-llvm-from-cling.patch"
- "0003-put-config-file-at-etc.patch"
- "0004-fix-build.patch")
+ "0003-put-config-file-at-etc.patch")
md5sums=('8d99920a167b1ca6b2ff4a3ef0bd1ded'
'e03c81c3701e4f0dea249955051c2ddf'
- '30e86ddf8e4996352eb456e12ec686bb'
- 'fb1bf5fdaa53af1c010b9da9d29f63b6'
- 'c492a7955f6bd8315fd8a100e2457744')
+ 'a5e1fb609303da1710a125e440f2c9a8'
+ 'fb1bf5fdaa53af1c010b9da9d29f63b6')
prepare() {
cd "$pkgname-$pkgver"