summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-19 12:36:14 -0500
committerCarlos Aznarán Laos2023-05-19 12:36:14 -0500
commited414c5c28b743d5461b4e0c455d1e86e79e7be3 (patch)
tree2ed38f02117829f7eef04cf39ac1d859d6ebaf2d
parentc5ee85b10c359d7cecd0e35da5cc7ee4acafb32b (diff)
downloadaur-ed414c5c28b743d5461b4e0c455d1e86e79e7be3.tar.gz
Bump version to 0.15.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD100
2 files changed, 56 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60424445f00b..560616939137 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
pkgbase = xeus-cling
pkgdesc = A C++ jupyter kernel based on xeus and cling
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.15.1
+ pkgrel = 1
url = https://github.com/jupyter-xeus/xeus-cling
arch = x86_64
- license = BSD
+ license = custom:BSD-3-clause
makedepends = cmake
makedepends = cppzmq
depends = xtl
depends = xproperty
depends = xeus
depends = nlohmann-json
- depends = jupyter-notebook
depends = jupyter-widgetsnbextension
depends = cling
depends = pugixml
- depends = cxxopts
- source = https://github.com/jupyter-xeus/xeus-cling/archive/0.13.0.tar.gz
+ depends = argparse
+ depends = xeus-zmq
+ source = xeus-cling-0.15.1.tar.gz::https://github.com/jupyter-xeus/xeus-cling/archive/0.15.1.tar.gz
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
source = 0003-put-config-file-at-etc.patch
- md5sums = 8d99920a167b1ca6b2ff4a3ef0bd1ded
- md5sums = e03c81c3701e4f0dea249955051c2ddf
- md5sums = a5e1fb609303da1710a125e440f2c9a8
- md5sums = fb1bf5fdaa53af1c010b9da9d29f63b6
+ sha512sums = 25716e6313e71cbc1cb78657674658788ff2eb399aad5ad8f11da448dac6a5df3ef8cc26d7aa72f2ba2ac5ae001c6d901dc2a1552a12f35b9f801c8d6765f2b2
+ sha512sums = 22286216ec59354374fa42245fc2b58c689f206a26da415bb2c922b6a79b466455a4f72ad013d1e56e30e0194de31c958ec787d411a141edc25c961cbdcd439a
+ sha512sums = 2fa2258c80ed7a7785441f7e03a8f14fd4fe24dce7c1506c2c592dc6173fdf689e05565e7a0e841df7cdee93bd105e66f6ab49664ebb97f4bf52b312ddad6427
+ sha512sums = b5249f0c68301d12ae8aaf347eb9bf26971fb90286597e813aa67bd4258a75eeac86f059638357b0fb63a9da583eeb63ddf24c49060e4c2f4a7890257ccd9b44
pkgname = xeus-cling
diff --git a/PKGBUILD b/PKGBUILD
index ca7884824940..791cdca382b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,59 @@
-# Maintainer: Sebastian Gsänger <sebastian_gsaenger@web.de>
-# Maintainer: chn <g897331845@gmail.com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Sebastian Gsänger <sebastian_gsaenger@web.de>
+# Contributor: chn <g897331845@gmail.com>
+# Contributor: Gregor Kaelin <kaelingre at gmail dot com>
pkgname=xeus-cling
-pkgver=0.13.0
-pkgrel=2
+pkgver=0.15.1
+pkgrel=1
pkgdesc="A C++ jupyter kernel based on xeus and cling"
arch=('x86_64')
-url="https://github.com/jupyter-xeus/xeus-cling"
-license=('BSD')
-depends=('xtl' 'xproperty' 'xeus' 'nlohmann-json'
- 'jupyter-notebook' 'jupyter-widgetsnbextension'
- 'cling' 'pugixml' 'cxxopts')
-makedepends=('cmake' 'cppzmq')
-source=("https://github.com/jupyter-xeus/$pkgname/archive/$pkgver.tar.gz"
- "0001-Rename-kernels.patch"
- "0002-Use-llvm-from-cling.patch"
- "0003-put-config-file-at-etc.patch")
-md5sums=('8d99920a167b1ca6b2ff4a3ef0bd1ded'
- 'e03c81c3701e4f0dea249955051c2ddf'
- 'a5e1fb609303da1710a125e440f2c9a8'
- 'fb1bf5fdaa53af1c010b9da9d29f63b6')
+url="https://github.com/jupyter-xeus/${pkgname}"
+license=('custom:BSD-3-clause')
+depends=(xtl xproperty xeus nlohmann-json jupyter-widgetsnbextension
+ cling pugixml argparse xeus-zmq)
+makedepends=(cmake cppzmq)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/jupyter-xeus/${pkgname}/archive/${pkgver}.tar.gz"
+ "0001-Rename-kernels.patch"
+ "0002-Use-llvm-from-cling.patch"
+ "0003-put-config-file-at-etc.patch")
+sha512sums=('25716e6313e71cbc1cb78657674658788ff2eb399aad5ad8f11da448dac6a5df3ef8cc26d7aa72f2ba2ac5ae001c6d901dc2a1552a12f35b9f801c8d6765f2b2'
+ '22286216ec59354374fa42245fc2b58c689f206a26da415bb2c922b6a79b466455a4f72ad013d1e56e30e0194de31c958ec787d411a141edc25c961cbdcd439a'
+ '2fa2258c80ed7a7785441f7e03a8f14fd4fe24dce7c1506c2c592dc6173fdf689e05565e7a0e841df7cdee93bd105e66f6ab49664ebb97f4bf52b312ddad6427'
+ 'b5249f0c68301d12ae8aaf347eb9bf26971fb90286597e813aa67bd4258a75eeac86f059638357b0fb63a9da583eeb63ddf24c49060e4c2f4a7890257ccd9b44')
prepare() {
- cd "$pkgname-$pkgver"
-
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- echo "Applying patch $src..."
- patch -Np1 < "../$src"
- done
+ cd ${pkgname}-${pkgver}
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 <"../$src"
+ done
}
build() {
-
- if [ -z $CPLUS_INCLUDE_PATH ]
- then
- export CPLUS_INCLUDE_PATH=/opt/cling/include
- else
- export CPLUS_INCLUDE_PATH=$CPLUS_INCLUDE_PATH:/opt/cling/include
- fi
-
- cd "$pkgname-$pkgver"
- mkdir -p build
- cd build
-
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DClang_DIR=/opt/cling/lib/cmake/clang \
- ..
-
- cmake --build .
+ if [ -z $CPLUS_INCLUDE_PATH ]; then
+ export CPLUS_INCLUDE_PATH=/opt/cling/include
+ else
+ export CPLUS_INCLUDE_PATH=$CPLUS_INCLUDE_PATH:/opt/cling/include
+ fi
+
+ cmake \
+ -S ${pkgname}-${pkgver} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=TRUE \
+ -DCMAKE_CXX_STANDARD=17 \
+ -DClang_DIR=/opt/cling/lib/cmake/clang
+ cmake --build build --target all
}
package() {
- cd "$pkgname-$pkgver"
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- cd "build"
-
- DESTDIR="$pkgdir" cmake --build . -t install
+ DESTDIR="${pkgdir}" cmake --build build-cmake --target install
+ install -Dm 644 ${pkgname}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}