summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Riches2015-08-09 10:22:52 +0100
committerJoseph Riches2015-08-09 10:22:52 +0100
commitdb1be152fdb945b41777b2176c12e6583a12442b (patch)
treed2c05c224384221f05435eb16c55c658a4bdbcf2
downloadaur-db1be152fdb945b41777b2176c12e6583a12442b.tar.gz
xf86-input-cmt-setup: initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--xf86-input-cmt-setup.install17
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb4fa8b6395d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xf86-input-cmt-setup
+ pkgdesc = A script to install the correct device specific conf files for the xf86-input-cmt driver
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/joebonrichie/xf86-input-cmt-conf
+ install = xf86-input-cmt-setup.install
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = dmidecode
+ provides = xf86-input-cmt=1
+ source = xf86-input-cmt-conf::git+https://github.com/joebonrichie/xf86-input-cmt-conf.git
+ md5sums = SKIP
+
+pkgname = xf86-input-cmt-setup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720bda3ca6fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Submitter: Joseph Riches
+
+pkgname=xf86-input-cmt-setup
+pkgdesc="A script to install the correct device specific conf files for the xf86-input-cmt driver"
+pkgver=1
+pkgrel=1
+arch=(any)
+url="https://github.com/joebonrichie/xf86-input-cmt-conf"
+_gitname=("xf86-input-cmt-conf")
+license=('GPLv3')
+provides=("xf86-input-cmt=$pkgver")
+install=${pkgname}.install
+depends=('dmidecode')
+makedepends=('git')
+
+source=("$_gitname::git+https://github.com/joebonrichie/xf86-input-cmt-conf.git")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p $pkgdir/usr/bin/
+ mv cmt-post-install.sh cmt-post-install
+ cp cmt-post-install $pkgdir/usr/bin/cmt-post-install
+}
diff --git a/xf86-input-cmt-setup.install b/xf86-input-cmt-setup.install
new file mode 100644
index 000000000000..e9653813415b
--- /dev/null
+++ b/xf86-input-cmt-setup.install
@@ -0,0 +1,17 @@
+msg_blue() {
+ printf "${blue}=>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}=>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${blue}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+pre_remove() {
+ msg_blue "Removing no longer needed symlinks for xf86-input-cmt"
+ sudo cmt-post-install.sh remove
+}