summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Lange2017-03-23 21:54:30 +0000
committerNikita 'CryptoManiac' Sivakov2017-04-27 14:12:36 +1000
commit079a8048fa92789419ffcd8602cb08f8f4cdbaef (patch)
treeef064732cb26fc2d27e936c147b37fe48ccad4ef
parentff1ab1e11ffef88a3886980406a1d5310bed3bd7 (diff)
downloadaur-079a8048fa92789419ffcd8602cb08f8f4cdbaef.tar.gz
Added build instructions for armv7h (RPi2)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 35 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86c11fde7b65..88f57ea4de54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Wed Mar 9 12:16:02 UTC 2016
+# Thu Apr 27 04:12:07 UTC 2017
pkgbase = xf86-input-egalax
pkgdesc = Touchscreen driver for eGalax (eeti) devices
pkgver = 2.5.5814
- pkgrel = 2
+ pkgrel = 3
url = http://home.eeti.com.tw/drivers_Linux.html
install = xf86-input-egalax.install
arch = i686
arch = x86_64
+ arch = armv7h
groups = xorg-input-drivers
license = custom:EULA
depends = linux
@@ -17,14 +18,18 @@ pkgbase = xf86-input-egalax
depends = hicolor-icon-theme
optdepends = xorg-server
backup = etc/eGTouchL.ini
- source = eGTouch_v2.5.5814.L-x.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/20151022/eGTouch_v2.5.5814.L-x.tar.gz
source = eGalaxConfig.desktop
source = eGTouchD.service
source = eGTouchD.conf
- md5sums = fb29252cd9ebf3a4ebd1530e4946f092
md5sums = 0ee99c83fd74bdb8357427eae9b2dc7d
md5sums = a52c4c1682ee196a6bbffe4768154a92
md5sums = c9284fbcf2bdaec8d3eea21f6b7be34d
+ source_i686 = eGTouch_v2.5.5814.L-x.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/20151022/eGTouch_v2.5.5814.L-x.tar.gz
+ md5sums_i686 = fb29252cd9ebf3a4ebd1530e4946f092
+ source_x86_64 = eGTouch_v2.5.5814.L-x.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/20151022/eGTouch_v2.5.5814.L-x.tar.gz
+ md5sums_x86_64 = fb29252cd9ebf3a4ebd1530e4946f092
+ source_armv7h = eGTouch_v2.5.5814.L-ma.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/20151022/eGTouch_v2.5.5814.L-ma.tar.gz
+ md5sums_armv7h = 4d53599a89dd7653d6587279cef5a25c
pkgname = xf86-input-egalax
diff --git a/PKGBUILD b/PKGBUILD
index 2ff51ff0ea37..1148ffa88d3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,41 @@
pkgname=xf86-input-egalax
pkgver=2.5.5814
-pkgrel=2
+pkgrel=3
_reldate=20151022
pkgdesc="Touchscreen driver for eGalax (eeti) devices"
arch=('i686'
- 'x86_64')
+ 'x86_64'
+ 'armv7h')
url="http://home.eeti.com.tw/drivers_Linux.html"
license=('custom:EULA')
groups=('xorg-input-drivers')
depends=('linux'
'libpng12'
'gksu'
- 'alsa-lib'
+ 'alsa-lib'
'hicolor-icon-theme')
optdepends=('xorg-server')
backup=(etc/eGTouchL.ini)
install='xf86-input-egalax.install'
-#http://home.eeti.com.tw/touch_driver/Linux/20141009/eGTouch_v2.5.4330.L-x.zip
-source=("eGTouch_v${pkgver}.L-x.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/${_reldate}/eGTouch_v${pkgver}.L-x.tar.gz"
- "eGalaxConfig.desktop"
+
+source_armv7h=("eGTouch_v${pkgver}.L-ma.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/${_reldate}/eGTouch_v${pkgver}.L-ma.tar.gz")
+source_i686=("eGTouch_v${pkgver}.L-x.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/${_reldate}/eGTouch_v${pkgver}.L-x.tar.gz")
+source_x86_64=("eGTouch_v${pkgver}.L-x.tar.gz::http://home.eeti.com.tw/touch_driver/Linux/${_reldate}/eGTouch_v${pkgver}.L-x.tar.gz")
+source=("eGalaxConfig.desktop"
"eGTouchD.service"
"eGTouchD.conf")
-md5sums=('fb29252cd9ebf3a4ebd1530e4946f092'
- '0ee99c83fd74bdb8357427eae9b2dc7d'
+md5sums=('0ee99c83fd74bdb8357427eae9b2dc7d'
'a52c4c1682ee196a6bbffe4768154a92'
'c9284fbcf2bdaec8d3eea21f6b7be34d')
-
+md5sums_i686=('fb29252cd9ebf3a4ebd1530e4946f092')
+md5sums_x86_64=('fb29252cd9ebf3a4ebd1530e4946f092')
+md5sums_armv7h=('4d53599a89dd7653d6587279cef5a25c')
+
_architect="32"
+_archshort="L-x"
[ "$CARCH" = "x86_64" ] && _architect="64"
+[ "$CARCH" = "armv7h" ] && _architect="ARMhf" && _archshort="L-ma"
package() {
if [ -d /etc/modules-load.d ]; then
@@ -49,26 +56,29 @@ package() {
"$pkgdir/usr/share/licenses/$pkgname" \
"$pkgdir/usr/bin" || return 1
- cd $srcdir/eGTouch_v${pkgver}.L-x/eGTouch${_architect}/eGTouch${_architect}withX
+ cd $srcdir/eGTouch_v${pkgver}.${_archshort}/eGTouch${_architect}/eGTouch${_architect}withX
- install -D -m755 eGTouchU $pkgdir/usr/bin
+ if [ "$CARCH" != "armv7h" ]; then
+ install -D -m755 eGTouchU $pkgdir/usr/bin
+ fi
install -D -m755 eGTouchD $pkgdir/usr/bin
install -D -m755 eCalib $pkgdir/usr/bin
install -D -m755 eGTouchL.ini $pkgdir/etc
- cd $srcdir/eGTouch_v${pkgver}.L-x/Rule
+ cd $srcdir/eGTouch_v${pkgver}.${_archshort}/Rule
+ if [ "$CARCH" != "armv7h" ]; then
+ install -D -m644 eGTouchU.png $pkgdir/usr/share/icons/hicolor/scalable/apps
+ fi
install -D -m644 52-egalax-virtual.conf $pkgdir/etc/X11/xorg.conf.d
- install -D -m644 eGTouchU.png $pkgdir/usr/share/icons/hicolor/scalable/apps
-
install -D -m755 serio_raw.sh $pkgdir/usr/share/eGTouch/sample
- cd $srcdir/eGTouch_v${pkgver}.L-x
+ cd $srcdir/eGTouch_v${pkgver}.${_archshort}
install -D -m644 EULA.pdf $pkgdir/usr/share/licenses/$pkgname
install -D -m644 "EETI_Declaration_and_Disclaimer.pdf" $pkgdir/usr/share/licenses/$pkgname
- cd $srcdir/eGTouch_v${pkgver}.L-x/Guide
+ cd $srcdir/eGTouch_v${pkgver}.${_archshort}/Guide
# install -D -m644 "EETI_eGTouch_Utility_Guide_for Linux_v1.03.pdf" $pkgdir/usr/share/eGTouch
# install -D -m644 "EETI_eGTouch_Linux_Programming_Guide_v2.5h.pdf" $pkgdir/usr/share/eGTouch