summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Menelkir2021-06-14 03:34:37 -0300
committerDaniel Menelkir2021-06-14 03:34:37 -0300
commit8eacb68a22e6152f28b8ebe022313f9f5998d19b (patch)
tree2398983a6f10418dcddac735279f613d4add4e43
parent7ac013b4af13cb0dc36404060693e2dc7ba49e76 (diff)
downloadaur-8eacb68a22e6152f28b8ebe022313f9f5998d19b.tar.gz
Added more configurations to /usr/share/doc/xf86-input-mtrack
-rw-r--r--.SRCINFO7
-rw-r--r--10-mtrack-advanced.conf72
-rw-r--r--10-mtrack-apple-magic-trackpad.conf62
-rw-r--r--PKGBUILD19
4 files changed, 153 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70096fe1a71f..082b8ea0ef49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xf86-input-mtrack
pkgdesc = An Xorg driver for multitouch trackpads and clickpads
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/p2rkw/xf86-input-mtrack
arch = i686
arch = x86_64
@@ -13,9 +13,12 @@ pkgbase = xf86-input-mtrack
depends = libxss
backup = etc/X11/xorg.conf.d/10-mtrack.conf
source = 10-mtrack.conf
+ source = 10-mtrack-advanced.conf
+ source = 10-mtrack-apple-magic-trackpad.conf
source = git+https://github.com/p2rkw/xf86-input-mtrack#tag=124b80f3913e44cc7fdc1ac36a639252f7c4bf1b
sha256sums = 5e0bc6ee814165be31e0265842f066c290b544757451d15c7e6eb370d4c0e356
+ sha256sums = 050cc4c654c91ac8332f55dff5ebbda8e85a665ed37da4fa98e7050aa48ff43e
+ sha256sums = 3554eae21a367886212fba32d21e82972ada939b82105e133beeb69b2129e8d8
sha256sums = SKIP
pkgname = xf86-input-mtrack
-
diff --git a/10-mtrack-advanced.conf b/10-mtrack-advanced.conf
new file mode 100644
index 000000000000..810fdb2b01d2
--- /dev/null
+++ b/10-mtrack-advanced.conf
@@ -0,0 +1,72 @@
+# Install mtrack driver 0.5.0++
+# Save this file to /usr/share/X11/xorg.conf.d/50-mtrack.conf
+# This config is specialized for MacBook Air 2012 (5,2)
+Section "InputClass"
+ MatchIsTouchpad "on"
+ Identifier "Touchpads"
+ MatchDevicePath "/dev/input/event*"
+ Driver "mtrack"
+ # The faster you move, the more distance pointer will travel, using "polynomial" profile
+ Option "AccelerationProfile" "2"
+ # Tweak cursor movement speed with this
+ Option "Sensitivity" "0.08"
+ # Pressure at which a finger is detected as a touch
+ Option "FingerHigh" "5"
+ # Pressure at which a finger is detected as a release
+ Option "FingerLow" "5"
+ # I often use thumb to press down the physical button, so let's not ignore it
+ Option "IgnoreThumb" "true"
+ Option "ThumbRatio" "70"
+ Option "ThumbSize" "25"
+ # Ignore palm, with palm takes up to 30% of your touch pad
+ Option "IgnorePalm" "true"
+ Option "PalmSize" "30"
+ # Trigger mouse button when tap: 1 finger - left click, 2 finger - right click, 3 - middle click
+ Option "TapButton1" "1"
+ Option "TapButton2" "3"
+ Option "TapButton3" "2"
+ Option "TapButton4" "0"
+ Option "ClickTime" "25"
+ # Disable tap-to-drag, we're using three finger drag instead
+ Option "TapDragEnable" "false"
+ # While touching the touch pad with # fingers, press the touchpad physical click button
+ Option "ClickFinger1" "1"
+ Option "ClickFinger2" "3"
+ Option "ClickFinger3" "2"
+ Option "ButtonMoveEmulate" "false"
+ Option "ButtonIntegrated" "true"
+ # The momentum after scroll fingers released
+ Option "ScrollCoastDuration" "300"
+ Option "ScrollCoastEnableSpeed" ".1"
+ # Natural scrolling with two fingers
+ Option "ScrollSmooth" "true"
+ Option "ScrollUpButton" "5"
+ Option "ScrollDownButton" "4"
+ Option "ScrollLeftButton" "6"
+ Option "ScrollRightButton" "7"
+ # Tweak scroll sensitivity with ScrollDistance, don't touch ScrollSensitivity
+ Option "ScrollDistance" "250"
+ Option "ScrollClickTime" "10"
+ # Three finger drag
+ Option "SwipeDistance" "1"
+ Option "SwipeLeftButton" "1"
+ Option "SwipeRightButton" "1"
+ Option "SwipeUpButton" "1"
+ Option "SwipeDownButton" "1"
+ Option "SwipeClickTime" "0"
+ Option "SwipeSensitivity" "1500"
+ # Four finger swipe, 8 & 9 are for browsers navigating back and forth respectively
+ Option "Swipe4LeftButton" "9"
+ Option "Swipe4RightButton" "8"
+ # Mouse button >= 10 are not used by Xorg, so we'll map them with xbindkeys and xdotool later
+ Option "Swipe4UpButton" "11"
+ Option "Swipe4DownButton" "10"
+ # Mouse buttons triggered by 2-finger pinching gesture
+ Option "ScaleDistance" "300"
+ Option "ScaleUpButton" "12"
+ Option "ScaleDownButton" "13"
+ # Mouse buttons trigger by 2-finger rotating gesture, disabled to enhance the pinch gesture
+ Option "RotateLeftButton" "0"
+ Option "RotateRightButton" "0"
+EndSection
+
diff --git a/10-mtrack-apple-magic-trackpad.conf b/10-mtrack-apple-magic-trackpad.conf
new file mode 100644
index 000000000000..fbac3000e3e3
--- /dev/null
+++ b/10-mtrack-apple-magic-trackpad.conf
@@ -0,0 +1,62 @@
+# Configuration for fine-tuning only the Apple Magic Trackpad (mtrack).
+#
+# Source: https://shellscreen.blogspot.com/2014/11/apple-magic-trackpad-on-kde.html
+Section "InputClass"
+ Identifier "Apple Magic Trackpad"
+ Driver "mtrack"
+# Match only the Apple Magic Trackpad
+ MatchUSBID "05ac:030e"
+ MatchIsTouchpad "on"
+# Set resolution tweaks for better response
+
+# Tap
+Option "TapButton1" "1"
+Option "TapButton2" "3"
+Option "TapButton3" "8"
+Option "TapButton4" "9"
+# Click
+Option "ClickFinger1" "1"
+Option "ClickFinger2" "3"
+Option "ClickFinger3" "2"
+# Two finger swipe
+Option "ScrollDistance" "15"
+Option "ScrollUpButton" "4"
+Option "ScrollDownButton" "5"
+Option "ScrollLeftButton" "6"
+Option "ScrollRightButton" "7"
+# Three finger swipe
+Option "SwipeDistance" "180"
+Option "SwipeUpButton" "34"
+Option "SwipeDownButton" "35"
+Option "SwipeLeftButton" "8"
+Option "SwipeRightButton" "9"
+# Four finger swipe
+Option "Swipe4Distance" "200"
+Option "Swipe4UpButton" "20"
+Option "Swipe4DownButton" "21"
+Option "Swipe4LeftButton" "23"
+Option "Swipe4RightButton" "22"
+# Scaling
+Option "ScaleDistance" "40"
+Option "ScaleUpButton" "12"
+Option "ScaleDownButton" "13"
+# Rotate
+Option "RotateDistance" "40"
+Option "RotateLeftButton" "14"
+Option "RotateRightButton" "14"
+
+Option "TapDragEnable" "true"
+Option "TapDragTime" "350"
+Option "TapDragWait" "40"
+Option "TapDragDist" "200"
+
+Option "Sensitivity" "0.85"
+Option "FingerHigh" "5"
+Option "FingerLow" "5"
+Option "IgnoreThumb" "true"
+Option "IgnorePalm" "true"
+
+# Option "ButtonMoveEmulate" "false"
+Option "ButtonIntegrated" "true"
+
+EndSection
diff --git a/PKGBUILD b/PKGBUILD
index a142866d3541..b6408a323835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xf86-input-mtrack
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="An Xorg driver for multitouch trackpads and clickpads"
arch=('i686' 'x86_64')
url="https://github.com/p2rkw/$pkgname"
@@ -11,12 +11,16 @@ depends=('mtdev' 'libxss')
makedepends=('xorg-server-devel' 'xorgproto' 'pixman')
backup=('etc/X11/xorg.conf.d/10-mtrack.conf')
source=(10-mtrack.conf
+ 10-mtrack-advanced.conf
+ 10-mtrack-apple-magic-trackpad.conf
"git+https://github.com/p2rkw/xf86-input-mtrack#tag=124b80f3913e44cc7fdc1ac36a639252f7c4bf1b")
sha256sums=('5e0bc6ee814165be31e0265842f066c290b544757451d15c7e6eb370d4c0e356'
+ '050cc4c654c91ac8332f55dff5ebbda8e85a665ed37da4fa98e7050aa48ff43e'
+ '3554eae21a367886212fba32d21e82972ada939b82105e133beeb69b2129e8d8'
'SKIP')
build() {
- cd "$srcdir"/$pkgname
+ cd "$srcdir"/"$pkgname"
mkdir -p m4
@@ -26,9 +30,14 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname
-
+ cd "$srcdir"/"$pkgname"
make DESTDIR="$pkgdir"/ install
- install -Dm644 "$srcdir"/10-mtrack.conf "$pkgdir"/etc/X11/xorg.conf.d/10-mtrack.conf
+ mkdir -p "$pkgdir"/usr/share/doc/"$pkgname"/
+ cp "$srcdir"/"$pkgname"/README.md "$pkgdir"/usr/share/doc/"$pkgname"
+ cp "$srcdir"/10-mtrack.conf "$pkgdir"/usr/share/doc/"$pkgname"
+ cp "$srcdir"/10-mtrack-advanced.conf "$pkgdir"/usr/share/doc/"$pkgname"
+ cp "$srcdir"/10-mtrack-apple-magic-trackpad.conf "$pkgdir"/usr/share/doc/"$pkgname"
+ echo ""
+ echo "Use one of the examples in /usr/share/doc/xf86-input-mtrack"
}