summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2021-11-28 00:45:26 +0100
committerroot2021-11-28 00:45:26 +0100
commit2e445d757aa9a54d30485f3d554ad0642d651216 (patch)
tree444f10f45da04c7512facd744fb182d50376d8b3
downloadaur-2e445d757aa9a54d30485f3d554ad0642d651216.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD97
2 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3435747f7ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xf86-input-wacom-nosystemd-git
+ pkgdesc = X.Org Wacom tablet driver. Without systemd dependency. Git checkout.
+ pkgver = 0.40.0.23+r2038.20211122.ef209bc
+ pkgrel = 1
+ url = https://github.com/linuxwacom/xf86-input-wacom
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = xorg-server-devel
+ depends = libudev.so
+ depends = libxi
+ depends = libxinerama
+ depends = libxrandr
+ provides = xf86-input-wacom=0.40.0.23+r2038.20211122.ef209bc
+ provides = xf86-input-wacom-nosystemd=0.40.0.23+r2038.20211122.ef209bc
+ provides = xf86-input-wacom-git=0.40.0.23+r2038.20211122.ef209bc
+ conflicts = xf86-input-wacom
+ source = xf86-input-wacom::git+git://github.com/linuxwacom/xf86-input-wacom.git
+ sha256sums = SKIP
+
+pkgname = xf86-input-wacom-nosystemd-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac98859307c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+# Maintainer: Dreieck
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: M Rawash <mrawash@gmail.com>
+
+
+_pkgname='xf86-input-wacom'
+_pkgvariantsuffix='-nosystemd'
+_vcssuffix='-git'
+pkgname="${_pkgname}${_pkgvariantsuffix}${_vcssuffix}"
+pkgver=0.40.0.23+r2038.20211122.ef209bc
+pkgrel=1
+pkgdesc="X.Org Wacom tablet driver. Without systemd dependency. Git checkout."
+arch=(
+ 'i686'
+ 'x86_64'
+)
+url="https://github.com/linuxwacom/xf86-input-wacom"
+license=('GPL2')
+depends=(
+ 'libudev.so'
+ 'libxi'
+ 'libxinerama'
+ 'libxrandr'
+)
+makedepends=(
+ 'git'
+ 'xorg-server-devel'
+)
+conflicts=(
+ "${_pkgname}"
+)
+provides=(
+ "${_pkgname}=${pkgver}"
+ "${_pkgname}${_pkgvariantsuffix}=${pkgver}"
+ "${_pkgname}${_vcssuffix}=${pkgver}"
+)
+source=(
+ "${_pkgname}::git+git://github.com/linuxwacom/xf86-input-wacom.git" # Official upstream source
+ # "${_pkgname}::git+git://github.com/whot/xf86-input-wacom.git#branch=wip/detect-tool-changes" # Contains fixes for eraser issue with lenovo m14t: https://github.com/linuxwacom/xf86-input-wacom/issues/186, see https://github.com/linuxwacom/xf86-input-wacom/pull/188
+)
+sha256sums=(
+ 'SKIP'
+ # 'SKIP'
+)
+
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ _ver="$(git describe --tags | sed 's|^xf86-input-wacom-||' | sed 's|-[^-]*$||' | tr '-' '.')"
+ _rev="$(git rev-list --count HEAD)"
+ _date="$(git log -1 --date=format:"%Y%m%d" --format="%ad")"
+ _hash="$(git rev-parse --short HEAD)"
+
+ if [ -z "${_ver}" ]; then
+ error "Version could not be determined."
+ return 1
+ else
+ printf '%s' "${_ver}+r${_rev}.${_date}.${_hash}"
+ fi
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --enable-shared \
+ --enable-fuzz-interface \
+ --enable-unit-tests
+
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+
+ make check
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 -v AUTHORS "${pkgdir}/usr/share/doc/${_pkgname}/AUTHORS"
+ install -D -m644 -v README.md "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -D -m644 -v GPL "${pkgdir}/usr/share/licenses/${pkgname}/GPL2"
+}