summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMateusz Lemusisk2015-06-15 15:27:03 +0200
committerMateusz Lemusisk2015-06-15 15:27:03 +0200
commit6cdc1b41ae41d9b635d4461627f4695b6f3ad9d4 (patch)
tree88211f225599219f65b301eb4c6f3195ffaf6c89
downloadaur-6cdc1b41ae41d9b635d4461627f4695b6f3ad9d4.tar.gz
initial
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD45
-rw-r--r--xf86-video-ati-git.install8
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3de5c858059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = xf86-video-ati-git
+ pkgdesc = X.org ati video driver. Git version
+ pkgver = 7.5.0.r75.gafab783
+ pkgrel = 1
+ url = http://xorg.freedesktop.org/
+ install = xf86-video-ati-git.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = xorg-server-devel
+ makedepends = X-ABI-VIDEODRV_VERSION=19
+ depends = libdrm>=2.4.41
+ depends = systemd
+ depends = mesa
+ provides = xf86-video-ati
+ conflicts = xorg-server<1.16.0
+ conflicts = xf86-video-ati
+ conflicts = X-ABI-VIDEODRV_VERSION<19
+ conflicts = X-ABI-VIDEODRV_VERSION>=20
+ source = xf86-video-ati::git://anongit.freedesktop.org/xorg/driver/xf86-video-ati#branch=master
+ md5sums = SKIP
+
+pkgname = xf86-video-ati-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b239de8d2482
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: jcsiv <siviter dot jamie at gmx dot co dot uk>
+# Contributor: Riccardo Berto <riccardobrt@gmail.com>
+# Contributor: vbmithr
+# Contributor: Flamelab <panosfilip at gmail dot com>
+# Contributor: Dan Ziemba <zman0900@gmail.com>
+
+pkgname=xf86-video-ati-git
+_realpkgname=xf86-video-ati
+pkgver=7.5.0.r75.gafab783
+pkgrel=1
+pkgdesc="X.org ati video driver. Git version"
+arch=('i686' 'x86_64')
+url="http://xorg.freedesktop.org/"
+provides=("${_realpkgname}")
+depends=('libdrm>=2.4.41' 'systemd' 'mesa')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=19' )
+conflicts=('xorg-server<1.16.0' 'xf86-video-ati' 'X-ABI-VIDEODRV_VERSION<19' 'X-ABI-VIDEODRV_VERSION>=20')
+license=('custom')
+install=xf86-video-ati-git.install
+
+source=('xf86-video-ati::git://anongit.freedesktop.org/xorg/driver/xf86-video-ati#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/xf86-video-ati"
+ ( set -o pipefail
+ git describe --long | sed 's/^xf86-video-ati-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ )
+}
+
+build() {
+ cd "${srcdir}/xf86-video-ati"
+
+ ./autogen.sh --prefix=/usr \
+ --enable-glamor
+ make
+}
+
+package() {
+ cd "${srcdir}/xf86-video-ati"
+
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/xf86-video-ati-git.install b/xf86-video-ati-git.install
new file mode 100644
index 000000000000..0108c3893c29
--- /dev/null
+++ b/xf86-video-ati-git.install
@@ -0,0 +1,8 @@
+post_install()
+{
+ echo ":: This works best(or sometimes at all) with the rest of the graphics stack from git (x11 etc.)"
+}
+post_upgrade()
+{
+ echo ":: This works best(or sometimes at all) with the rest of the graphics stack from git (x11 etc.)"
+}