summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2018-05-30 22:47:12 +0200
committertrya2018-05-30 22:47:12 +0200
commit4883bbe9d46b34871f9b088357af3d15a5cc3a52 (patch)
tree430b0dff228609a43038e42d5f06fdb6813706f0
parentbb539d5e49251137aa9a6f256a010a4cabd42017 (diff)
downloadaur-4883bbe9d46b34871f9b088357af3d15a5cc3a52.tar.gz
Less strict on versioning (as Arch Linux 32 may be a little late)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69b8a048bc6..eed6e577499 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
# Generated by mksrcinfo v8
-# Wed May 30 20:34:58 UTC 2018
+# Wed May 30 20:46:45 UTC 2018
pkgbase = xf86-video-mach64
pkgdesc = X.org mach64 video driver
pkgver = 6.9.6
- pkgrel = 1
+ pkgrel = 2
url = https://xorg.freedesktop.org/
arch = i686
arch = x86_64
groups = xorg-drivers
license = custom
makedepends = xorg-server-devel
- makedepends = X-ABI-VIDEODRV_VERSION=24.0
+ makedepends = X-ABI-VIDEODRV_VERSION>=23
+ makedepends = X-ABI-VIDEODRV_VERSION<25
depends = glibc
optdepends = mach64-dri: DRI1 support from community repo
optdepends = mach64drm: Mach64 DRM module
- conflicts = xorg-server<1.20
- conflicts = X-ABI-VIDEODRV_VERSION<24
+ conflicts = xorg-server<1.19
+ conflicts = X-ABI-VIDEODRV_VERSION<23
conflicts = X-ABI-VIDEODRV_VERSION>=25
options = !emptydirs
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index 8a83dd15aad..cf05bd5e6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=xf86-video-mach64
pkgver=6.9.6
-pkgrel=1
+pkgrel=2
pkgdesc="X.org mach64 video driver"
arch=(i686 x86_64)
url="https://xorg.freedesktop.org/"
license=('custom')
depends=('glibc')
-makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=24.0')
-conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION>=23' 'X-ABI-VIDEODRV_VERSION<25')
+conflicts=('xorg-server<1.19' 'X-ABI-VIDEODRV_VERSION<23' 'X-ABI-VIDEODRV_VERSION>=25')
optdepends=('mach64-dri: DRI1 support from community repo'
'mach64drm: Mach64 DRM module')
groups=('xorg-drivers')