aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArondight2016-05-21 14:47:29 +0800
committerArondight2016-05-21 14:47:29 +0800
commit9ef2ab7c7d6d6d2d5cc0e4754f219a8f79dfbc63 (patch)
tree9893989dd9bd7f5e8f8d5faa5a901e3e54526b87
downloadaur-9ef2ab7c7d6d6d2d5cc0e4754f219a8f79dfbc63.tar.gz
Init PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
-rw-r--r--fingerprint5
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76cb3debc32a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xf86-video-nouveau-blacklist-git
+ pkgdesc = Disable nouveau driver module
+ pkgver = r1.b6fa4d4
+ pkgrel = 1
+ url = https://github.com/Arondight/xf86-video-nouveau-blacklist.git
+ arch = any
+ license = GPL
+ makedepends = git
+ source = xf86-video-nouveau-blacklist-git::git+https://github.com/Arondight/xf86-video-nouveau-blacklist.git#branch=master
+ sha256sums = SKIP
+
+pkgname = xf86-video-nouveau-blacklist-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..557bcc86a005
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*~
+*.bak
+*.swp
+Makefile.old
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23b5f790246f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Arondight <shell_way@foxmail.com>
+
+pkgname='xf86-video-nouveau-blacklist-git'
+pkgver='r1.b6fa4d4'
+pkgrel=1
+pkgdesc='Disable nouveau driver module'
+arch=('any')
+url='https://github.com/Arondight/xf86-video-nouveau-blacklist.git'
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+${url}#branch=master")
+noextract=()
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
+ || printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+}
+
+check() {
+ cd "${srcdir}/${pkgname%-git}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+
+ make install DESTDIR=$pkgdir
+}
+
diff --git a/fingerprint b/fingerprint
new file mode 100644
index 000000000000..16161f7747f7
--- /dev/null
+++ b/fingerprint
@@ -0,0 +1,5 @@
+pub rsa4096/B66CC194 2016-04-15 [SC]
+ Key fingerprint = 4444 9495 01B3 CC2A 7657 9C08 25FF D92A B66C C194
+uid [ultimate] Arondight <shell_way@foxmail.com>
+sub rsa4096/F96E3CB7 2016-04-15 [E]
+