summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2018-07-07 16:24:58 +0200
committerLW-archlinux2018-07-07 16:24:58 +0200
commit99ffc3812f0d7ae40609b26d8a052f4e73a65f84 (patch)
tree38605fea3b4b3fa7f33852dcc8e0218d30436754
parentc1eaa95679d877b3c1b987b6b0771487b9ae8097 (diff)
downloadaur-99ffc3812f0d7ae40609b26d8a052f4e73a65f84.tar.gz
updated to work with xorg server 1.20
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--fix_defines.patch79
-rw-r--r--git-fixes.patch62
4 files changed, 120 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c2d723f7a1b..dbddf2b45ff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = xf86-video-sis
pkgdesc = X.org SiS video driver
- pkgver = 0.10.8
- pkgrel = 3
+ pkgver = 0.10.9.r7.ga50b2b3
+ pkgrel = 1
url = https://xorg.freedesktop.org/
- arch = i686
arch = x86_64
groups = xorg-drivers
license = custom
makedepends = xorg-server-devel
- makedepends = X-ABI-VIDEODRV_VERSION=23
+ makedepends = X-ABI-VIDEODRV_VERSION=24.0
makedepends = xf86dgaproto
+ makedepends = git
+ makedepends = pixman
depends = glibc
optdepends = sis-dri: DRI1 support from community repo
- conflicts = xorg-server<1.19
- conflicts = X-ABI-VIDEODRV_VERSION<23
- conflicts = X-ABI-VIDEODRV_VERSION>=24
- source = https://xorg.freedesktop.org//releases/individual/driver/xf86-video-sis-0.10.8.tar.bz2
- source = git-fixes.patch
- sha256sums = c8f3f2577f69334dfcc4bf96477dce45161170555f3abdfa105599e61bc7d3fe
- sha256sums = b3cbb937a94c5e0ea21e05005238b247ee146ba8640eda7bfbe8b382b25dde7b
+ conflicts = xorg-server<1.20
+ conflicts = X-ABI-VIDEODRV_VERSION<24
+ conflicts = X-ABI-VIDEODRV_VERSION>=25
+ source = git+https://anongit.freedesktop.org/git/xorg/driver/xf86-video-sis.git#commit=a50b2b3412dd8e7f3916acb142c942e85ffcb3e5
+ source = fix_defines.patch::https://ptpb.pw/2MVt
+ sha256sums = SKIP
+ sha256sums = 8338641b519c25d9a8387608ea562970b4313e7602f890ff0331a0742c3f7f8b
pkgname = xf86-video-sis
diff --git a/PKGBUILD b/PKGBUILD
index 942ff2de566d..ac0301743e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,49 @@
-# $Id: PKGBUILD 281737 2016-11-21 13:46:51Z lcarlier $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: lone_Wolf <lonewolf@xs4all.nl>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Porting this to xorg-server 1.20 made possible by : loqs, progandy, regid
+# see https://bbs.archlinux.org/viewtopic.php?id=237632
pkgname=xf86-video-sis
-pkgver=0.10.8
-pkgrel=3
+pkgver=0.10.9.r7.ga50b2b3
+pkgrel=1
pkgdesc="X.org SiS video driver"
-arch=(i686 x86_64)
+arch=(x86_64)
url="https://xorg.freedesktop.org/"
license=('custom')
depends=('glibc')
-makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=23' 'xf86dgaproto')
-conflicts=('xorg-server<1.19' 'X-ABI-VIDEODRV_VERSION<23' 'X-ABI-VIDEODRV_VERSION>=24')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=24.0' 'xf86dgaproto' 'git' 'pixman')
+conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25')
optdepends=('sis-dri: DRI1 support from community repo')
groups=('xorg-drivers')
-source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2
- git-fixes.patch)
-sha256sums=('c8f3f2577f69334dfcc4bf96477dce45161170555f3abdfa105599e61bc7d3fe'
- 'b3cbb937a94c5e0ea21e05005238b247ee146ba8640eda7bfbe8b382b25dde7b')
+_commit=a50b2b3412dd8e7f3916acb142c942e85ffcb3e5
+source=("git+https://anongit.freedesktop.org/git/xorg/driver/xf86-video-sis.git#commit=$_commit"
+ 'fix_defines.patch::https://ptpb.pw/2MVt')
+sha256sums=('SKIP'
+ '8338641b519c25d9a8387608ea562970b4313e7602f890ff0331a0742c3f7f8b')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --long | sed 's/^xf86-video-sis.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
- cd ${pkgname}-${pkgver}
- patch -Np1 -i ${srcdir}/git-fixes.patch
+ cd ${pkgname}
+ patch -Np1 -i ../fix_defines.patch
+ autoreconf -vfi
}
build() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname
+ export CFLAGS=${CFLAGS/-fno-plt}
+ export CXXFLAGS=${CXXFLAGS/-fno-plt}
+ export LDFLAGS=${LDFLAGS/,-z,now}
./configure --prefix=/usr
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dt "$pkgdir"/usr/share/licenses/$pkgname "$srcdir"/$pkgname/COPYING
}
diff --git a/fix_defines.patch b/fix_defines.patch
new file mode 100644
index 000000000000..42423bfdf0d1
--- /dev/null
+++ b/fix_defines.patch
@@ -0,0 +1,79 @@
+diff --git a/src/sis_driver.c b/src/sis_driver.c
+index 4e51e2e..13e6e24 100644
+--- a/src/sis_driver.c
++++ b/src/sis_driver.c
+@@ -4140,7 +4140,7 @@ SISPreInit(ScrnInfoPtr pScrn, int flags)
+ biossize = 0x8000;
+ break;
+ }
+-#if XSERVER_LIBPCIACCESS
++#ifdef XSERVER_LIBPCIACCESS
+ if(readpci) {
+ pSiS->PciInfo->rom_size = biossize;
+ pci_device_read_rom(pSiS->PciInfo, pSiS->BIOS);
+@@ -8973,11 +8973,11 @@ SISScreenInit(SCREEN_INIT_ARGS_DECL)
+ case 24: refreshArea = SISRefreshArea24; break;
+ case 32: refreshArea = SISRefreshArea32; break;
+ }
+-#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
++/*#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
+ xf86DisableRandR();
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "Driver rotation enabled, disabling RandR\n");
+-#endif
++#endif*/
+ } else if(pSiS->Reflect) {
+ switch(pScrn->bitsPerPixel) {
+ case 8:
+@@ -8986,11 +8986,11 @@ SISScreenInit(SCREEN_INIT_ARGS_DECL)
+ if(!pSiS->PointerMoved) pSiS->PointerMoved = pScrn->PointerMoved;
+ pScrn->PointerMoved = SISPointerMovedReflect;
+ refreshArea = SISRefreshAreaReflect;
+-#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
++/*#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
+ xf86DisableRandR();
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "Driver reflection enabled, disabling RandR\n");
+-#endif
++#endif*/
+ break;
+ default:
+ xf86DrvMsg(pScrn->scrnIndex, X_ERROR,
+@@ -9097,13 +9097,13 @@ SISScreenInit(SCREEN_INIT_ARGS_DECL)
+ pSiS->Rotate = 0;
+ pSiS->Reflect = 0;
+ pSiS->ShadowFB = FALSE;
+-#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
++/*#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
+ if(pSiS->CRT1XOffs || pSiS->CRT1YOffs || pSiS->CRT2XOffs || pSiS->CRT2YOffs) {
+ xf86DisableRandR();
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "MergedFB: CRT2Position offset used, disabling RandR\n");
+ }
+-#endif
++#endif*/
+ #ifdef SISXINERAMA
+ if(pSiS->UseSiSXinerama) {
+ SiSnoPanoramiXExtension = FALSE;
+diff --git a/src/sis_vga.c b/src/sis_vga.c
+index 8b625d2..cf39d0c 100644
+--- a/src/sis_vga.c
++++ b/src/sis_vga.c
+@@ -1715,7 +1715,7 @@ SiSVGAMapMem(ScrnInfoPtr pScrn)
+ if(pSiS->VGAMapPhys == 0) pSiS->VGAMapPhys = 0xA0000;
+
+ #if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(4,3,0,0,0)
+-#if XSERVER_LIBPCIACCESS
++#ifdef XSERVER_LIBPCIACCESS
+ (void) pci_device_map_legacy(pSiS->PciInfo, pSiS->VGAMapPhys, pSiS->VGAMapSize,
+ PCI_DEV_MAP_FLAG_WRITABLE, &pSiS->VGAMemBase);
+ #else
+@@ -1737,7 +1737,7 @@ SiSVGAUnmapMem(ScrnInfoPtr pScrn)
+
+ if(pSiS->VGAMemBase == NULL) return;
+
+-#if XSERVER_LIBPCIACCESS
++#ifdef XSERVER_LIBPCIACCESS
+ (void) pci_device_unmap_legacy(pSiS->PciInfo, pSiS->VGAMemBase, pSiS->VGAMapSize);
+ #else
+ xf86UnMapVidMem(pScrn->scrnIndex, pSiS->VGAMemBase, pSiS->VGAMapSize);
diff --git a/git-fixes.patch b/git-fixes.patch
deleted file mode 100644
index 6c99397ecba7..000000000000
--- a/git-fixes.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 328073e46f9b9fcc09e637c94496c90273a0a4f6 Mon Sep 17 00:00:00 2001
-From: Thomas Klausner <wiz@NetBSD.org>
-Date: Sun, 13 Sep 2015 23:28:53 +0200
-Subject: [PATCH 1/2] Fix arguments for miSetPointerPosition.
-
-For the call for the API between versions 5 and 15.
-
-Reviewed-by: Connor Behan <connor.behan@gmail.com>
----
- src/sis_driver.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/sis_driver.c b/src/sis_driver.c
-index 854cb54..8f06164 100644
---- a/src/sis_driver.c
-+++ b/src/sis_driver.c
-@@ -9395,9 +9395,9 @@ SISMergedPointerMoved(SCRN_ARG_TYPE arg, int x, int y)
- y = (int)dy;
- }
- #elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 13
-- miPointerSetPosition(inputInfo.pointer, Absolute, x, y);
-+ miPointerSetPosition(inputInfo.pointer, Absolute, &x, &y);
- #elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 5
-- miPointerSetPosition(inputInfo.pointer, x, y);
-+ miPointerSetPosition(inputInfo.pointer, &x, &y);
- #else
- UpdateCurrentTime();
- miPointerAbsoluteCursor(x, y, currentTime.milliseconds);
---
-2.10.2
-
-From 96fee560cd8bf7bf27048ce5fe67b7af6838c8d0 Mon Sep 17 00:00:00 2001
-From: Adam Jackson <ajax@redhat.com>
-Date: Tue, 19 Jul 2016 10:03:56 -0400
-Subject: [PATCH 2/2] Adapt Block/WakeupHandler signature for ABI 23
-
-Signed-off-by: Adam Jackson <ajax@redhat.com>
----
- src/compat-api.h | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/compat-api.h b/src/compat-api.h
-index 6bc946f..89976e4 100644
---- a/src/compat-api.h
-+++ b/src/compat-api.h
-@@ -75,8 +75,13 @@
-
- #define SCREEN_INIT_ARGS_DECL ScreenPtr pScreen, int argc, char **argv
-
-+#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(23, 0)
-+#define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer pTimeout
-+#define BLOCKHANDLER_ARGS arg, pTimeout
-+#else
- #define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer pTimeout, pointer pReadmask
- #define BLOCKHANDLER_ARGS arg, pTimeout, pReadmask
-+#endif
-
- #define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
- #define CLOSE_SCREEN_ARGS pScreen
---
-2.10.2
-