summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Carlier2017-01-14 21:23:47 +0100
committerLaurent Carlier2017-01-14 21:23:47 +0100
commitc1eaa95679d877b3c1b987b6b0771487b9ae8097 (patch)
tree2cc225882824e89de2d8b8ecb1433e9b9cfd957e
downloadaur-c1eaa95679d877b3c1b987b6b0771487b9ae8097.tar.gz
moved from extra
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--git-fixes.patch62
3 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c2d723f7a1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = xf86-video-sis
+ pkgdesc = X.org SiS video driver
+ pkgver = 0.10.8
+ pkgrel = 3
+ url = https://xorg.freedesktop.org/
+ arch = i686
+ arch = x86_64
+ groups = xorg-drivers
+ license = custom
+ makedepends = xorg-server-devel
+ makedepends = X-ABI-VIDEODRV_VERSION=23
+ makedepends = xf86dgaproto
+ depends = glibc
+ optdepends = sis-dri: DRI1 support from community repo
+ conflicts = xorg-server<1.19
+ conflicts = X-ABI-VIDEODRV_VERSION<23
+ conflicts = X-ABI-VIDEODRV_VERSION>=24
+ source = https://xorg.freedesktop.org//releases/individual/driver/xf86-video-sis-0.10.8.tar.bz2
+ source = git-fixes.patch
+ sha256sums = c8f3f2577f69334dfcc4bf96477dce45161170555f3abdfa105599e61bc7d3fe
+ sha256sums = b3cbb937a94c5e0ea21e05005238b247ee146ba8640eda7bfbe8b382b25dde7b
+
+pkgname = xf86-video-sis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..942ff2de566d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 281737 2016-11-21 13:46:51Z lcarlier $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xf86-video-sis
+pkgver=0.10.8
+pkgrel=3
+pkgdesc="X.org SiS video driver"
+arch=(i686 x86_64)
+url="https://xorg.freedesktop.org/"
+license=('custom')
+depends=('glibc')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=23' 'xf86dgaproto')
+conflicts=('xorg-server<1.19' 'X-ABI-VIDEODRV_VERSION<23' 'X-ABI-VIDEODRV_VERSION>=24')
+optdepends=('sis-dri: DRI1 support from community repo')
+groups=('xorg-drivers')
+source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2
+ git-fixes.patch)
+sha256sums=('c8f3f2577f69334dfcc4bf96477dce45161170555f3abdfa105599e61bc7d3fe'
+ 'b3cbb937a94c5e0ea21e05005238b247ee146ba8640eda7bfbe8b382b25dde7b')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i ${srcdir}/git-fixes.patch
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/git-fixes.patch b/git-fixes.patch
new file mode 100644
index 000000000000..6c99397ecba7
--- /dev/null
+++ b/git-fixes.patch
@@ -0,0 +1,62 @@
+From 328073e46f9b9fcc09e637c94496c90273a0a4f6 Mon Sep 17 00:00:00 2001
+From: Thomas Klausner <wiz@NetBSD.org>
+Date: Sun, 13 Sep 2015 23:28:53 +0200
+Subject: [PATCH 1/2] Fix arguments for miSetPointerPosition.
+
+For the call for the API between versions 5 and 15.
+
+Reviewed-by: Connor Behan <connor.behan@gmail.com>
+---
+ src/sis_driver.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/sis_driver.c b/src/sis_driver.c
+index 854cb54..8f06164 100644
+--- a/src/sis_driver.c
++++ b/src/sis_driver.c
+@@ -9395,9 +9395,9 @@ SISMergedPointerMoved(SCRN_ARG_TYPE arg, int x, int y)
+ y = (int)dy;
+ }
+ #elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 13
+- miPointerSetPosition(inputInfo.pointer, Absolute, x, y);
++ miPointerSetPosition(inputInfo.pointer, Absolute, &x, &y);
+ #elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 5
+- miPointerSetPosition(inputInfo.pointer, x, y);
++ miPointerSetPosition(inputInfo.pointer, &x, &y);
+ #else
+ UpdateCurrentTime();
+ miPointerAbsoluteCursor(x, y, currentTime.milliseconds);
+--
+2.10.2
+
+From 96fee560cd8bf7bf27048ce5fe67b7af6838c8d0 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 19 Jul 2016 10:03:56 -0400
+Subject: [PATCH 2/2] Adapt Block/WakeupHandler signature for ABI 23
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+ src/compat-api.h | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/compat-api.h b/src/compat-api.h
+index 6bc946f..89976e4 100644
+--- a/src/compat-api.h
++++ b/src/compat-api.h
+@@ -75,8 +75,13 @@
+
+ #define SCREEN_INIT_ARGS_DECL ScreenPtr pScreen, int argc, char **argv
+
++#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(23, 0)
++#define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer pTimeout
++#define BLOCKHANDLER_ARGS arg, pTimeout
++#else
+ #define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer pTimeout, pointer pReadmask
+ #define BLOCKHANDLER_ARGS arg, pTimeout, pReadmask
++#endif
+
+ #define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
+ #define CLOSE_SCREEN_ARGS pScreen
+--
+2.10.2
+