summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy MountainJohnson2018-08-17 12:22:09 -0500
committerJeremy MountainJohnson2018-08-17 12:22:09 -0500
commit998a5e2002aac92b3707a86e929bcab230fe2f7e (patch)
treeb0274f660bd84f9df41d9f73a2510ab50d6922da
downloadaur-998a5e2002aac92b3707a86e929bcab230fe2f7e.tar.gz
Initial add to aur for theme
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad66954865bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xfce-evolution-themes
+ pkgdesc = The Xfce Evolution theme attempts to rid the Xfce desktop of visual distractions by providing a more consistent look (buttons, scrollbars, menus, etc) across older and newer applications.
+ pkgver = 4.17.0
+ pkgrel = 1
+ url = http://www.itgroup.ro/WSX/browser.htm?.landingpage=wsx_content/en/linux/xfce-evolution.html
+ arch = any
+ license = GPLv2
+ depends = gtk-engine-murrine
+ optdepends = lib32-gtk-engine-murrine
+ optdepends = qt5-styleplugins
+ optdepends = noto-fonts
+ optdepends = elementary-xfce-icons
+ optdepends = nemo
+ source = https://downloads.sourceforge.net/project/xfce-evolution/xfce-evolution-4.17.0.zip
+ sha512sums = 616bcce9637ed8cecec3cd0272143b5f194733856fd0d8b7a201e4e2e07b98a0ab0e6322f6383a363a96f0d21b8d6caf9aefa1fcac3aa497018bd507bd1b383f
+
+pkgname = xfce-evolution-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f4836082983
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jeremy MountainJohnson <jskier@gmail.com>
+# Contributor: Jeremy MountainJohnson <jskier@gmail.com>
+
+pkgname=xfce-evolution-themes
+_name=xfce-evolution
+pkgver=4.17.0
+pkgrel=1
+pkgdesc="The Xfce Evolution theme attempts to rid the Xfce desktop of visual distractions by providing a more consistent look (buttons, scrollbars, menus, etc) across older and newer applications."
+arch=('any')
+url="http://www.itgroup.ro/WSX/browser.htm?.landingpage=wsx_content/en/linux/xfce-evolution.html"
+license=(GPLv2)
+depends=(gtk-engine-murrine)
+optdepends=(lib32-gtk-engine-murrine qt5-styleplugins noto-fonts elementary-xfce-icons nemo)
+source=(https://downloads.sourceforge.net/project/xfce-evolution/xfce-evolution-${pkgver}.zip)
+sha512sums=('616bcce9637ed8cecec3cd0272143b5f194733856fd0d8b7a201e4e2e07b98a0ab0e6322f6383a363a96f0d21b8d6caf9aefa1fcac3aa497018bd507bd1b383f')
+
+package() {
+ # Set correct mode on files from zip source extraction
+ find $srcdir -type f -exec chmod 644 {} +
+
+ # Prepare all theme directories for package
+ for i in $srcdir/Xfce\ Evolution*; do
+ if [ -d "$i" ]; then
+ install -dm 755 "$pkgdir/usr/share/themes/${i##*/}"
+ cp -rp "${i##*/}" "$pkgdir/usr/share/themes/"
+ fi
+ done
+
+ # Remove unnecessary TOOLS folder
+ rm -rf "$pkgdir/usr/share/themes/Xfce Evolution/TOOLS"
+}