summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-07-15 00:21:17 -0300
committerPablo Lezaeta Reyes2015-07-15 00:21:17 -0300
commit2a34c3b7c7a0a64545883f7a4a96f1080145b237 (patch)
treee6c6e3c45d61c28ffe03d7072befcc7e40317d6b
parentb986a9feacc2f1c2d8d927425fd1e792c2041d1d (diff)
downloadaur-2a34c3b7c7a0a64545883f7a4a96f1080145b237.tar.gz
propper versioning
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD18
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29c439dec92f..b977f8a024f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce-theme-albatross-git
pkgdesc = A dark, smooth Xfce theme, introduced in the release of Xubuntu 9.10
- pkgver = 1.7.3_5_g735e8f2
+ pkgver = 1.7.3.r108
pkgrel = 1
url = https://github.com/shimmerproject/Albatross
arch = any
@@ -10,7 +10,7 @@ pkgbase = xfce-theme-albatross-git
depends = gtk-engine-murrine
provides = xfce-theme-albatross
conflicts = xfce-theme-albatross
- source = git+http://github.com/shimmerproject/Albatross
+ source = Albatross::git+http://github.com/shimmerproject/Albatross
md5sums = SKIP
pkgname = xfce-theme-albatross-git
diff --git a/.gitignore b/.gitignore
index 7d813751c966..5e5208c7121f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@ src
srcdir
pkg
pkgdir
+Albatross
*.tar.*
*.xz
*.gz
diff --git a/PKGBUILD b/PKGBUILD
index 22acf425faf8..5eac0934ae3f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Diego <cdprincipe atgmaildot com>
+# Contributor: Diego <cdprincipe atgmaildot com>
+# Maintainer: Pablo Lezaeta <prflr88@gmai.com>
pkgname=xfce-theme-albatross-git
-pkgver=1.7.3_5_g735e8f2
+pkgver=1.7.3.r108
pkgrel=1
pkgdesc="A dark, smooth Xfce theme, introduced in the release of Xubuntu 9.10"
arch=('any')
@@ -11,24 +12,23 @@ depends=('gtk-engine-murrine')
makedepends=('git')
provides=('xfce-theme-albatross')
conflicts=('xfce-theme-albatross')
-source=('git+http://github.com/shimmerproject/Albatross')
+source=('Albatross::git+http://github.com/shimmerproject/Albatross')
md5sums=('SKIP')
pkgver() {
- cd Albatross
- git describe --always | sed 's#-#_#g;s#v##'
+ cd "Albatross"
+ echo $(git describe --always --abbrev=0).r$(git rev-list --count master) | sed 's|-|.|g' | sed 's|v||g'
}
package() {
- cd Albatross
+ cd "${srcdir}/Albatross"
# create theme dirs
- install -d -m 755 "$pkgdir"/usr/share/themes/Albatross{,-compact/xfwm4}
+ install -d -m 755 "${pkgdir}"/usr/share/themes/Albatross{,-compact/xfwm4}
# clean up
rm -rf {.git,.gitignore,LICENSE.{CC,GPL},README}
# install theme
- cp -r . "$pkgdir"/usr/share/themes/Albatross/
-
+ cp -r . "${pkgdir}/usr/share/themes/Albatross/"
}