summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-05-26 05:02:50 -0300
committerPablo Lezaeta Reyes2015-05-26 05:02:50 -0300
commitb986a9feacc2f1c2d8d927425fd1e792c2041d1d (patch)
treeb792a08d32809db12417db705212f2bb6994aa01
downloadaur-b986a9feacc2f1c2d8d927425fd1e792c2041d1d.tar.gz
add pkg
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore11
-rwxr-xr-xPKGBUILD34
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29c439dec92f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xfce-theme-albatross-git
+ pkgdesc = A dark, smooth Xfce theme, introduced in the release of Xubuntu 9.10
+ pkgver = 1.7.3_5_g735e8f2
+ pkgrel = 1
+ url = https://github.com/shimmerproject/Albatross
+ arch = any
+ license = GPL2
+ license = CCPL
+ makedepends = git
+ depends = gtk-engine-murrine
+ provides = xfce-theme-albatross
+ conflicts = xfce-theme-albatross
+ source = git+http://github.com/shimmerproject/Albatross
+ md5sums = SKIP
+
+pkgname = xfce-theme-albatross-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d813751c966
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+src
+srcdir
+pkg
+pkgdir
+*.tar.*
+*.xz
+*.gz
+*.bz2
+*.tar
+*.zip
+*.rar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..22acf425faf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Diego <cdprincipe atgmaildot com>
+
+pkgname=xfce-theme-albatross-git
+pkgver=1.7.3_5_g735e8f2
+pkgrel=1
+pkgdesc="A dark, smooth Xfce theme, introduced in the release of Xubuntu 9.10"
+arch=('any')
+url="https://github.com/shimmerproject/Albatross"
+license=('GPL2' 'CCPL')
+depends=('gtk-engine-murrine')
+makedepends=('git')
+provides=('xfce-theme-albatross')
+conflicts=('xfce-theme-albatross')
+source=('git+http://github.com/shimmerproject/Albatross')
+md5sums=('SKIP')
+
+pkgver() {
+ cd Albatross
+ git describe --always | sed 's#-#_#g;s#v##'
+}
+
+package() {
+ cd Albatross
+
+ # create theme dirs
+ install -d -m 755 "$pkgdir"/usr/share/themes/Albatross{,-compact/xfwm4}
+
+ # clean up
+ rm -rf {.git,.gitignore,LICENSE.{CC,GPL},README}
+
+ # install theme
+ cp -r . "$pkgdir"/usr/share/themes/Albatross/
+
+}