summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-09-07 15:23:49 -0400
committerMario Finelli2015-09-07 15:23:49 -0400
commit736ad67ee19490e0adb7c77a2cc4fdd9e685b74c (patch)
treecbeaebca4f55a1f440d8b241dd3ec72c27628185
downloadaur-736ad67ee19490e0adb7c77a2cc4fdd9e685b74c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65bb2a237049
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xfce-theme-blackbird
+ pkgdesc = Dark Desktop Suite for Xfce.
+ pkgver = 0.4
+ pkgrel = 2
+ url = https://github.com/shimmerproject/Blackbird
+ arch = any
+ license = CCPL:by-sa-3.0
+ license = GPL
+ depends = gtk-engine-murrine
+ optdepends = elementary-xfce-icons: matching icon set; use the dark icon theme
+ optdepends = gtk-engine-unico: required for gtk3 support
+ source = xfce-theme-blackbird-0.4.tar.gz::https://github.com/shimmerproject/Blackbird/archive/v0.4.tar.gz
+ sha256sums = ca31362254df2d336b2b090deb925f19a1dba72632ed9c7f82cf406be89ec1e6
+
+pkgname = xfce-theme-blackbird
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bb1e9b3a172
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: Limao Luo <luolimao+AUR at gmail dot com>
+
+pkgname=xfce-theme-blackbird
+_pkgname=Blackbird
+pkgver=0.4
+pkgrel=2
+pkgdesc="Dark Desktop Suite for Xfce."
+arch=(any)
+url="https://github.com/shimmerproject/Blackbird"
+license=(CCPL:by-sa-3.0 GPL)
+depends=(gtk-engine-murrine)
+optdepends=('elementary-xfce-icons: matching icon set; use the dark icon theme'
+ 'gtk-engine-unico: required for gtk3 support')
+source=($pkgname-$pkgver.tar.gz::https://github.com/shimmerproject/$_pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('ca31362254df2d336b2b090deb925f19a1dba72632ed9c7f82cf406be89ec1e6')
+
+package() {
+ install -d "$pkgdir"/usr/share/themes/
+ cp -rf $_pkgname-$pkgver/ "$pkgdir"/usr/share/themes/$_pkgname/
+ rm "$pkgdir"/usr/share/themes/$_pkgname/.gitignore
+}