summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM.Reynolds2020-01-16 11:45:54 -0500
committerM.Reynolds2020-01-16 11:45:54 -0500
commit54fe086a027eefbadf76f12d3abd4be8107f7643 (patch)
treed663b7265107b41b4f08dc6b590edbbf39d40f3f
parent34a0697348d0c629f1d2a94149e35fdca90eb0fc (diff)
downloadaur-54fe086a027eefbadf76f12d3abd4be8107f7643.tar.gz
Update package to use meson build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39d4b9178db5..0ea15be615ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = xfce-theme-greybird
pkgdesc = A grey and blue Xfce theme.
pkgver = 3.22.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/shimmerproject/Greybird
arch = any
groups = xfce-themes-shimmer-collection
license = CCPL:by-sa-3.0
license = GPL
- depends = gtk-engine-murrine
+ makedepends = meson
+ makedepends = sassc
+ makedepends = librsvg
optdepends = elementary-xfce-icons: matching icon set; use the dark icon theme
optdepends = gtk3: required for CSS/GTK3 theme
optdepends = lightdm-gtk-greeter: required for the LightDM GTK theme
optdepends = lightdm-unity-greeter: required for the LightDM Unity theme
optdepends = shimmer-wallpapers: contains the Greybird wallpaper, among others
+ optdepends = gtk-engine-murrine: required for gtk2 support
optdepends = lib32-gtk-engine-murrine: required for multilib
conflicts = xfce-theme-greybird-git
source = xfce-theme-greybird-3.22.11.tar.gz::https://github.com/shimmerproject/Greybird/archive/v3.22.11.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 6a4085c0b788..84a3c9b6156f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,30 @@
pkgname=xfce-theme-greybird
pkgver=3.22.11
-pkgrel=1
+pkgrel=2
pkgdesc="A grey and blue Xfce theme."
arch=('any')
url="https://github.com/shimmerproject/Greybird"
license=('CCPL:by-sa-3.0' 'GPL')
groups=('xfce-themes-shimmer-collection')
conflicts=("$pkgname-git")
-depends=('gtk-engine-murrine')
+makedepends=('meson' 'sassc' 'librsvg')
optdepends=('elementary-xfce-icons: matching icon set; use the dark icon theme'
'gtk3: required for CSS/GTK3 theme'
'lightdm-gtk-greeter: required for the LightDM GTK theme'
'lightdm-unity-greeter: required for the LightDM Unity theme'
'shimmer-wallpapers: contains the Greybird wallpaper, among others'
+ 'gtk-engine-murrine: required for gtk2 support'
'lib32-gtk-engine-murrine: required for multilib')
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/shimmerproject/Greybird/archive/v$pkgver.tar.gz")
sha256sums=('2bd51da36c445157d92c08039814571362d09986cbe19fa3917f1a08fbadbc61')
package() {
- cd "$srcdir"
- install -dm 755 "$pkgdir/usr/share/themes/Greybird Classic"
- install -dm 755 "$pkgdir/usr/share/themes/Greybird Compact"
- install -dm 755 "$pkgdir/usr/share/themes/Greybird a11y"
+ cd "$srcdir/Greybird-$pkgver"
+ meson --prefix="$pkgdir/usr" "build"
- cp -r "Greybird-$pkgver/" "$pkgdir/usr/share/themes/Greybird/"
- rm -rf "$pkgdir/usr/share/themes/Greybird/.gitignore"
-
- ln -s "/usr/share/themes/Greybird/xfwm4-compact" \
- "$pkgdir/usr/share/themes/Greybird Compact/xfwm4"
-
- ln -s "/usr/share/themes/Greybird/xfwm4-a11y" \
- "$pkgdir/usr/share/themes/Greybird a11y/xfwm4"
+ cd "build"
+ ninja
+ ninja install
}