summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2015-06-08 21:02:35 +0200
committerBjoern Franke2015-06-08 21:02:35 +0200
commitb269917b10b373dd7f6ea0690a116677f3c738cf (patch)
tree3f149044bc478a06a5a07ee3aedaaf7233e53f13
downloadaur-b269917b10b373dd7f6ea0690a116677f3c738cf.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa8444ad17d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xfce-theme-greybird
+ pkgdesc = A grey and blue Xfce theme, used by default in Xubuntu 12.04
+ pkgver = 1.5.3
+ pkgrel = 1
+ url = http://shimmerproject.org/projects/greybird/
+ arch = any
+ groups = xfce-themes-shimmer-collection
+ license = CCPL:by-sa-3.0
+ license = GPL
+ depends = gtk-engine-murrine
+ optdepends = elementary-xfce-icons: matching icon set; use the dark icon theme
+ optdepends = gtk3: required for CSS/GTK3 theme
+ optdepends = lightdm-gtk-greeter: required for the LightDM GTK theme
+ optdepends = lightdm-unity-greeter: required for the LightDM Unity theme
+ optdepends = shimmer-wallpapers: contains the Greybird wallpaper, among others
+ optdepends = lib32-gtk-engine-murrine: required for multilib
+ conflicts = xfce-theme-greybird-git
+ source = xfce-theme-greybird-1.5.3.tar.gz::https://github.com/shimmerproject/Greybird/archive/v1.5.3.tar.gz
+ sha512sums = 1010019b1341cf1c0d48d15d0bc371bbe62e3b6d4aa5d8feb6998093487f465c7dbe42133753a6ca74a01e351ce7b15fcc14c4e194a97034e2e4c171885accae
+
+pkgname = xfce-theme-greybird
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31652b959fe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Bjoern Franke <bjo at nord-west.org>
+# Contributor: flan_suse
+#
+# This suite contains the following:
+# * xfwm4 theme
+# * xfwm4 compact theme
+# * metacity theme
+# * emerald theme
+# * gtk2 theme
+# * gtk3 theme
+# * unity theme
+# * xfce4-notify theme
+# * lightdm theme
+# * wallpaper (found in the shimmer-wallpapers package; optdepends)
+
+pkgname=xfce-theme-greybird
+_pkgname=Greybird
+pkgver=1.5.3
+pkgrel=1
+pkgdesc="A grey and blue Xfce theme, used by default in Xubuntu 12.04"
+arch=(any)
+url=http://shimmerproject.org/projects/greybird/
+license=(CCPL:by-sa-3.0 GPL)
+groups=(xfce-themes-shimmer-collection)
+depends=(gtk-engine-murrine)
+optdepends=('elementary-xfce-icons: matching icon set; use the dark icon theme'
+ 'gtk3: required for CSS/GTK3 theme'
+ 'lightdm-gtk-greeter: required for the LightDM GTK theme'
+ 'lightdm-unity-greeter: required for the LightDM Unity theme'
+ 'shimmer-wallpapers: contains the Greybird wallpaper, among others'
+ 'lib32-gtk-engine-murrine: required for multilib')
+conflicts=($pkgname-git)
+source=($pkgname-$pkgver.tar.gz::https://github.com/shimmerproject/$_pkgname/archive/v$pkgver.tar.gz)
+sha512sums=('1010019b1341cf1c0d48d15d0bc371bbe62e3b6d4aa5d8feb6998093487f465c7dbe42133753a6ca74a01e351ce7b15fcc14c4e194a97034e2e4c171885accae')
+
+
+
+
+package() {
+ local _themedir="$pkgdir/usr/share/themes"
+ install -d "$_themedir/$_pkgname "{Classic,Compact}
+
+ cp -rf $_pkgname-$pkgver/ "$_themedir"/$_pkgname/
+ rm "$_themedir"/$_pkgname/.gitignore
+ ln -s /usr/share/themes/$_pkgname/xfwm4_compact "$_themedir/$_pkgname Compact/xfwm4"
+}