summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCheeseEBoi2020-06-27 11:22:05 -0400
committerCheeseEBoi2020-06-27 11:22:05 -0400
commit62952e1f92ac5ca60878557fae52a1d5a1f5d379 (patch)
treec9bad23016f118d5c3aa48287e2f66f9b755baf9
downloadaur-62952e1f92ac5ca60878557fae52a1d5a1f5d379.tar.gz
Created initial version of package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a2bec5ae1a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xfce-theme-greybird-geeko
+ pkgdesc = OpenSUSE's Modified 'Desktop Suite for Xfce
+ pkgver = 3.22.11
+ pkgrel = 1
+ url = https://shimmerproject.org
+ arch = any
+ license = GPL
+ makedepends = librsvg
+ makedepends = meson
+ makedepends = ruby-sass
+ makedepends = sassc
+ depends = gtk-engine-murrine
+ depends = gtk3
+ optdepends = elementary-xfce-icons: matching icon set; use the dark icon theme
+ optdepends = lightdm-gtk-greeter: required for the LightDM GTK theme
+ optdepends = shimmer-wallpapers: contains the Greybird wallpaper, among others
+ optdepends = lib32-gtk-engine-murrine: required for multilib
+ source = xfce-theme-greybird-geeko-3.22.11.tar.gz::https://github.com/shimmerproject/Greybird-Geeko/archive/v3.22.11.tar.gz
+ sha256sums = 3c71ae4377cc86d16093fb7d796b2762f869d8b6d2281649ea41b4aaab595cf9
+
+pkgname = xfce-theme-greybird-geeko
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1cb55f6925b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+# Maintainer: Mark Wagie <mark@manjaro.org>
+
+pkgname=xfce-theme-greybird-geeko
+pkgver=3.22.11
+pkgrel=1
+pkgdesc="OpenSUSE's Modified 'Desktop Suite for Xfce"
+arch=('any')
+url="https://shimmerproject.org"
+license=('GPL')
+depends=('gtk-engine-murrine' 'gtk3')
+makedepends=('librsvg' 'meson' 'ruby-sass' 'sassc')
+optdepends=('elementary-xfce-icons: matching icon set; use the dark icon theme'
+ 'lightdm-gtk-greeter: required for the LightDM GTK theme'
+ 'shimmer-wallpapers: contains the Greybird wallpaper, among others'
+ 'lib32-gtk-engine-murrine: required for multilib')
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/shimmerproject/Greybird-Geeko/archive/v$pkgver.tar.gz")
+sha256sums=('3c71ae4377cc86d16093fb7d796b2762f869d8b6d2281649ea41b4aaab595cf9')
+
+build() {
+ arch-meson "Greybird-Geeko-$pkgver" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}