summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-07-09 00:18:01 -0300
committerPablo Lezaeta Reyes2015-07-09 00:18:01 -0300
commit80712ef9be28d18c5ea63920e74cbbf30ecab75c (patch)
tree7af3f91157f3729253086e7dee7aa5c5423e4e8a
downloadaur-80712ef9be28d18c5ea63920e74cbbf30ecab75c.tar.gz
adopted
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab4a02148247
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xfce-theme-greybird-git
+ pkgdesc = Desktop theme suite from Xubuntu, with support for Xfce, Metacity and Unity
+ pkgver = v1.4.2.g98d9182.557.98d9182
+ pkgrel = 1
+ url = https://github.com/shimmerproject/Greybird
+ arch = any
+ license = GPL
+ license = CCPL
+ makedepends = git
+ depends = gtk-engine-murrine
+ optdepends = elementary-xfce-icons: matching icon theme
+ optdepends = emerald: emerald theme
+ optdepends = lightdm-gtk2-greeter: lightdm GTK+2 theme
+ optdepends = lightdm-gtk3-greeter: lightdm GTK+3 theme
+ optdepends = lightdm-unity-greeter: lightdm unity theme
+ provides = xfce-theme-greybird
+ conflicts = xfce-theme-greybird
+ options = !strip
+ source = git://github.com/shimmerproject/Greybird.git
+ md5sums = SKIP
+
+pkgname = xfce-theme-greybird-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4b3fb338b00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pablo Lezaeta <prflr 88 (arro'a) gmail puntocom>
+# Contributor: Ner0
+# Contributor: Alessio Sergi <asergi at archlinux dot us>
+
+pkgname=xfce-theme-greybird-git
+pkgver=v1.4.2.g98d9182.557.98d9182
+pkgrel=1
+pkgdesc="Desktop theme suite from Xubuntu, with support for Xfce, Metacity and Unity"
+arch=('any')
+url="https://github.com/shimmerproject/Greybird"
+license=('GPL' 'CCPL')
+depends=('gtk-engine-murrine')
+makedepends=('git')
+optdepends=('elementary-xfce-icons: matching icon theme'
+ 'emerald: emerald theme'
+ 'lightdm-gtk2-greeter: lightdm GTK+2 theme'
+ 'lightdm-gtk3-greeter: lightdm GTK+3 theme'
+ 'lightdm-unity-greeter: lightdm unity theme')
+provides=('xfce-theme-greybird')
+conflicts=('xfce-theme-greybird')
+options=('!strip')
+source=('git://github.com/shimmerproject/Greybird.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Greybird"
+ echo $(git describe --always).r$(git rev-list --count master).$(git rev-parse --short master) | sed 's|-|.|g' | sed 's|v||g'
+}
+
+package() {
+ cd "$srcdir/Greybird"
+
+ # install emerald theme
+ install -d -m 755 "$pkgdir/usr/share/emerald/themes/Greybird"
+ tar zxf Greybird.emerald -C "$pkgdir/usr/share/emerald/themes/Greybird/"
+
+ # create theme dirs
+ install -d -m 755 "$pkgdir"/usr/share/themes/Greybird{,-compact/xfwm4}
+
+ # install compact theme
+ install -m 644 xfwm4_compact/* "$pkgdir/usr/share/themes/Greybird-compact/xfwm4/"
+
+ # clean up
+ rm -rf {.git,.gitignore,Greybird.emerald,LICENSE.{CC,GPL},README,xfwm4_compact}
+
+ # install theme
+ cp -r . "$pkgdir/usr/share/themes/Greybird/"
+}