summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Rochev2016-07-01 01:32:14 +0300
committerAlexey Rochev2016-07-01 01:32:14 +0300
commit00edc9e475f7533df19a62e79ffc9ab5df5c9be4 (patch)
tree1ba71ce89983cd7dd26525466d2dd888723371f4
downloadaur-00edc9e475f7533df19a62e79ffc9ab5df5c9be4.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a44ff402ba3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xfce4-alsa-plugin
+ pkgdesc = Simple ALSA volume control for xfce4-panel
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/equeim/xfce4-alsa-plugin
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = python
+ makedepends = intltool
+ depends = alsa-lib
+ depends = gtk2
+ depends = xfce4-panel
+ source = https://github.com/equeim/xfce4-alsa-plugin/archive/0.1.1.tar.gz
+ sha256sums = 38a6b5aeb1664a0bb7ee49cc8b77070f0219362784281b6b55ec8afdb88a2956
+
+pkgname = xfce4-alsa-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e919285b0e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexey Rochev <equeim@gmail.com>
+
+pkgname='xfce4-alsa-plugin'
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Simple ALSA volume control for xfce4-panel'
+url='https://github.com/equeim/xfce4-alsa-plugin'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('alsa-lib' 'gtk2' 'xfce4-panel')
+makedepends=('vala' 'python' 'intltool')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('38a6b5aeb1664a0bb7ee49cc8b77070f0219362784281b6b55ec8afdb88a2956')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./waf configure build --prefix=/usr --libdir=/usr/lib
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ ./waf install --destdir="${pkgdir}"
+}