summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-08-11 10:36:40 -0400
committerTed Alff2017-08-11 10:36:40 -0400
commit43e950c128be57839a0b46ed1b1dcf4c7bd13cc7 (patch)
tree6b525f858dbfea363f5ee68b14d3ee873733b68d
downloadaur-43e950c128be57839a0b46ed1b1dcf4c7bd13cc7.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa66667189ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Aug 11 14:36:30 UTC 2017
+pkgbase = xfce4-appfinder-git
+ pkgdesc = An application finder for Xfce (GIT checkout)
+ pkgver = 4.12.0.r125.g3eac33d
+ pkgrel = 1
+ url = http://www.xfce.org/
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = intltool
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ depends = libxfce4ui
+ depends = garcon
+ depends = hicolor-icon-theme
+ provides = xfce4-appfinder=4.12.0.r125.g3eac33d
+ conflicts = xfce4-appfinder
+ replaces = xfce-utils
+ source = xfce4-appfinder::git://git.xfce.org/xfce/xfce4-appfinder
+ sha256sums = SKIP
+
+pkgname = xfce4-appfinder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35277428a7bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=xfce4-appfinder
+pkgname=${_pkgname}-git
+pkgver=4.12.0.r125.g3eac33d
+pkgrel=1
+pkgdesc="An application finder for Xfce (GIT checkout)"
+arch=('i686' 'x86_64')
+url="http://www.xfce.org/"
+license=('GPL2')
+groups=('xfce4')
+depends=('libxfce4ui' 'garcon' 'hicolor-icon-theme')
+makedepends=('intltool' 'git' 'xfce4-dev-tools')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+replaces=('xfce-utils')
+source=("${_pkgname}::git://git.xfce.org/xfce/xfce4-appfinder")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "${_pkgname}"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: